7.7 печатная ворма документа

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Ветал, 14 фев 2008.

  1. TopicStarter Overlay
    Ветал
    Offline

    Ветал

    Регистрация:
    11 фев 2008
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Есть документ
    Внем вносится Наименования и КГ

    сделал Печатную форму
    Код:
    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);    
    КонецПроцедуры
    //{{ПРОЦЕДУРА_ПЕЧАТИ(Печать)
    
    //Данный фрагмент построен конструктором.
    
    //При повторном использовании конструктора, внесенные вручную изменения будут потеряны!!!
    
    Процедура Печать()    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Печать");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(7,0,7,0);
    ВыбратьСтроки();    
    счетчик = 1;
    Пока ПолучитьСтроку() = 1 Цикл   
    если (Счетчик % 2) = 1 тогда
    Таб.ВывестиСекцию("Строка|Столбик1");
    Иначе
    Таб.ПрисоединитьСекцию("Строка|Столбик2"); 
    конецЕсли;
    счетчик = счетчик + 1;
    
    КонецЦикла;
    
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Печать Заявка","");
    КонецПроцедуры
    //}}ПРОЦЕДУРА_ПЕЧАТИ       
    
    


    Сейчас выводятся просто наименования и кг

    Как сделть чтобы помимо наименований выводилась название группы(папки как в справочнике в которой они находятся)в таблицу

    т.е

    СОСИСКИ
    Кубанские
    Прогресс
    ДЕЛИКАТЕСНАЯ ГРУППА
    выфв
    выфввыф
    фыввыф

    и.т.д.

    если можно на примере

    Используйте тэг
    Код:
    [/color]
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    У элемнтов справочника есть атрибут "Родитель" пример

    ТМЦ.Родитель

    Но в твоем случае при данном выводе на печать произойдет :

    СОСИСКИ
    Кубанские
    СОСИСКИ
    Прогресс
    ДЕЛИКАТЕСНАЯ ГРУППА
    выфв
    ДЕЛИКАТЕСНАЯ ГРУППА
    выфввыф
    ДЕЛИКАТЕСНАЯ ГРУППА
    фыввыф

    Дабы избежать сего надо всю табличную часть вызгрузить в таблицу значений добавить колонку "Род"
    и заполнить ее в цикле родителями, потом отсортировать по данной колонке, ну а потом вывести на печать родителя только один раз эт уже дело техники :unsure:

Поделиться этой страницей