7.7 печатная форма Торг-12

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Дмитрий Ив, 17 фев 2007.

  1. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    такого нет
  2. s_bond
    Offline

    s_bond

    Регистрация:
    17 фев 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    значит не там ищешь, попробуй простым или глобальным поиском набери слово "диалог"...

    извини, я тебе подсказал НЕ ПРАВИЛЬНО это Я ПРО ТО КАК ЭТО выглядит в восьмерке (1С8), в семерке я не знаю наименование функций, просто не посмотрел заголовок темы
  3. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    Функция ПредставлениеДокумента()

    Перем Результат;

    Результат = "";
    Если ПустоеЗначение(ПечДок) = 0 Тогда
    Результат = глНазваниеДокументаВЖурнале(ПечДок) + " № " + СокрЛП(ПечДок.НомерДок) + " от " + ПечДок.ДатаДок;
    КонецЕсли;

    Возврат Результат;

    КонецФункции //

    может дело здесь?
  4. s_bond
    Offline

    s_bond

    Регистрация:
    17 фев 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Но думаю по смыслу что это вот этот кусок кода делает

    Перем ПечатаемыйДок;

    ПечатаемыйДок = ?(ПустоеЗначение(Док) = 1, ПечДок, Док);

    ТестОшибки = "";
    Если ПустоеЗначение(ПечатаемыйДок) = 1 Тогда
    ТестОшибки = "Не выбран документ!";
    ИначеЕсли ПустоеЗначение(Грузополучатель) = 1 Тогда
    ТестОшибки = "Не выбран грузополучатель!";
    КонецЕсли;

    Если ПустоеЗначение(ТестОшибки) = 0 Тогда
    Предупреждение(ТестОшибки, 60);
    Возврат;
    КонецЕсли;

    Печать(ПечатаемыйДок);
  5. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    Пока оставил так как есть, время нету, надо другие дела делать...
    И все таки суббота, может потом еще поищу выход.

    Спасибо за участие SB999 ! :)

    Если кто хорошо разбирается в конфигурировании, пожалуйста гляньте код, и подскажите как решить мою задачу!!!

    Это код товаро транспортной накладной с выбором грузополучателя, когда нажимаешь на печать, поевляется сначало окно модуля с выбором грузополучателя и затем только формируется печатная форма. Нужно отключить модуль, так чтоб сразу формировалась печатная форма.

    Надеюсь на вашу помощь, форумчане!!!



    Перем Устройство;
    Перем КолвоКопий;
    Перем ПечДок;

    //******************************************************************************
    // Функция ПредставлениеДокумента()
    //
    // Параметры:
    // Нет
    //
    // Возвращаемое значение:
    // Строковое представление выбранного документа
    //
    // Вызывается из формул элементов диалога:
    // Элемент диалога Текст (без идентификатора)
    //
    // Описание:
    // Возвращает строковое представление выбранного документа.
    //

    Функция ПредставлениеДокумента()

    Перем Результат;

    Результат = "";
    Если ПустоеЗначение(ПечДок) = 0 Тогда
    Результат = глНазваниеДокументаВЖурнале(ПечДок) + " № " + СокрЛП(ПечДок.НомерДок) + " от " + ПечДок.ДатаДок;
    КонецЕсли;

    Возврат Результат;

    КонецФункции // ПредставлениеДокумента()

    //******************************************************************************
    // ПриИзмененииДокумента()
    //
    // Параметры:
    // Нет
    //
    // Возвращаемое значение:
    // Нет
    //
    // Вызывается из формул элементов диалога:
    // Элемент диалога Док
    //
    // Описание:
    // Заполняет реквизит диалога грузополучатель.
    //
    Процедура ПриИзмененииДокумента()

    Если Док.Выбран() = 1 Тогда
    Грузополучатель = Док.Контрагент;
    КонецЕсли;

    КонецПроцедуры // ПриИзмененииДокумента()

    //******************************************************************************
    // ФормПарПечШапки(Парметры)
    //
    // Параметры:
    // Параметры - сисок, содержащий значения для формирования шапки печатной формы
    //
    // Возвращаемое значение:
    // Нет
    //
    // Описание:
    // Формирует список, содержащий значения полей для печати шапки документа
    //
    Процедура ФормПарПечШапки(Фирма, Контрагент, Параметры)

    Параметры = СоздатьОбъект("СписокЗначений");

    // поставщик (контрагент)

    Банк = "";НомерСчета = "";БИКБанка = "";СчетБанка = "";
    глПлатежныеРеквизиты(Фирма.ОсновнойСчет, , Банк, НомерСчета, БИКБанка, СчетБанка);

    Если (ПустоеЗначение(НомерСчета) = 1) ИЛИ (ПустоеЗначение(Банк) = 1) Тогда
    ПоставщикРеквизиты = "";
    Иначе
    ПоставщикРеквизиты = "р/с " + НомерСчета + " в " + Банк +
    ?(ПустоеЗначение(БИКБанка) = 0, " ,БИК " + БИКБанка, "") +
    ?(ПустоеЗначение(СчетБанка) = 0, " ,корр/с " + СчетБанка, "");
    КонецЕсли;

    ЮрЛицо = Фирма.ЮрЛицо;

    Параметры.ДобавитьЗначение(СокрЛП(ЮрЛицо.ПолнНаименование) + ?(ПустоеЗначение(ЮрЛицо.ИНН)=0, ", ИНН " + СокрЛП(ЮрЛицо.ИНН), ""),
    "ПоставщикНаименование");
    Параметры.ДобавитьЗначение(глПредставлениеАдреса(ЮрЛицо.ЮрАдрес), "ПоставщикАдрес");
    Параметры.ДобавитьЗначение(СокрЛП(ЮрЛицо.Телефоны) , "ПоставщикТелефоны");
    Параметры.ДобавитьЗначение(ПоставщикРеквизиты , "ПоставщикРеквизиты");
    Параметры.ДобавитьЗначение(СокрЛП(ЮрЛицо.ОКПО) , "ПоставщикОКПО");

    // плательщик

    Контр = Контрагент.ЮрФизЛицо;
    Если ПустоеЗначение(Контр) = 1 Тогда
    ПлательщикНаименование = "";
    ПлательщикАдрес = "";
    ПлательщикРеквизиты = "";
    ПлательщикОКПО = "";
    Иначе
    ПлательщикНаименование = СокрЛП(Контр.ПолнНаименование) +
    ?(ПустоеЗначение(Контр.ИНН) = 0, ", ИНН " + СокрЛП(Контр.ИНН), "");
    ПлательщикАдрес = глПредставлениеАдреса(Контр.ЮрАдрес);
    Если Контр.Вид() = "ФизЛица" Тогда
    ПлательщикОКПО = ""; // у физ лица нет ОКПО
    Иначе
    ПлательщикОКПО = СокрЛП(Контр.ОКПО);
    КонецЕсли;

    Банк = "";НомерСчета = "";БИКБанка = "";СчетБанка = "";
    глПлатежныеРеквизиты(Контрагент.ОсновнойСчет, , Банк, НомерСчета, БИКБанка, СчетБанка);

    Если (ПустоеЗначение(НомерСчета) = 1) ИЛИ (ПустоеЗначение(Банк) = 1) Тогда
    ПлательщикРеквизиты = "";
    Иначе
    ПлательщикРеквизиты = "р/с " + СокрЛП(НомерСчета) + " в " + СокрЛП(Банк) +
    ?(ПустоеЗначение(БИКБанка) = 0, " ,БИК " + СокрЛП(БИКБанка), "") +
    ?(ПустоеЗначение(СчетБанка) = 0, " ,корр/с " + СокрЛП(СчетБанка), "");
    КонецЕсли;
    КонецЕсли;

    Параметры.ДобавитьЗначение(ПлательщикНаименование , "ПлательщикНаименование");
    Параметры.ДобавитьЗначение(ПлательщикАдрес , "ПлательщикАдрес");
    Параметры.ДобавитьЗначение(ПлательщикРеквизиты , "ПлательщикРеквизиты");
    Параметры.ДобавитьЗначение(ПлательщикОКПО , "ПлательщикОКПО");

    // Грузополучатель

    Получатель = Грузополучатель.ЮрФизЛицо;

    Если ПустоеЗначение(Получатель) = 1 Тогда
    ПолучательНаименование = "";
    ПолучательАдрес = "";
    ПолучательРеквизиты = "";
    ПолучательОКПО = "";
    Иначе
    ПолучательНаименование = СокрЛП(Получатель.ПолнНаименование) +
    ?(ПустоеЗначение(Получатель.ИНН) = 0, ", ИНН " + СокрЛП(Получатель.ИНН), "");
    ПолучательАдрес = глПредставлениеАдреса(Получатель.ФактАдрес);
    Если Получатель.Вид() = "ФизЛица" Тогда
    ПолучательОКПО = ""; // у физ лица нет ОКПО
    Иначе
    ПолучательОКПО = СокрЛП(Получатель.ОКПО);
    КонецЕсли;

    Банк = "";НомерСчета = "";БИКБанка = "";СчетБанка = "";
    глПлатежныеРеквизиты(Грузополучатель.ОсновнойСчет, , Банк, НомерСчета, БИКБанка, СчетБанка);

    Если (ПустоеЗначение(НомерСчета) = 1) ИЛИ (ПустоеЗначение(Банк) = 1) Тогда
    ПолучательРеквизиты = "";
    Иначе
    ПолучательРеквизиты = "р/с " + СокрЛП(НомерСчета) + " в " + СокрЛП(Банк) +
    ?(ПустоеЗначение(БИКБанка) = 0, " ,БИК " + СокрЛП(БИКБанка), "") +
    ?(ПустоеЗначение(СчетБанка) = 0, " ,корр/с " + СокрЛП(СчетБанка), "");
    КонецЕсли;
    КонецЕсли;

    Параметры.ДобавитьЗначение(ПолучательНаименование , "ПолучательНаименование");
    Параметры.ДобавитьЗначение(ПолучательАдрес , "ПолучательАдрес");
    Параметры.ДобавитьЗначение(ПолучательРеквизиты , "ПолучательРеквизиты");
    Параметры.ДобавитьЗначение(ПолучательОКПО , "ПолучательОКПО");

    КонецПроцедуры // ФормПарПечШапки()

    //******************************************************************************
    // Печать(СразуНаПринтер, КолЭкз)
    //
    // Параметры:
    // СразуНаПринтер - (1) если печать на принтер, (0) - с предварительным просмотром
    // КолЭкз - количество экземпляров печати
    //
    // Возвращаемое значение:
    // нет.
    //
    // Описание:
    //
    Процедура Печать(Докум)

    Перем ПарамШапки;

    ПечТабл = СоздатьОбъект("Таблица");

    // инициализация переменных для печати шапки
    ФормПарПечШапки(Докум.Фирма, Докум.Контрагент, ПарамШапки);

    // собственная фирма
    ПоставщикНаименование = ПарамШапки.Получить("ПоставщикНаименование");
    ПоставщикАдрес = ПарамШапки.Получить("ПоставщикАдрес");
    ПоставщикТелефоны = ПарамШапки.Получить("ПоставщикТелефоны");
    ПоставщикРеквизиты = ПарамШапки.Получить("ПоставщикРеквизиты");
    ПоставщикОКПО = ПарамШапки.Получить("ПоставщикОКПО");

    ПоставщикКратко = ПоставщикНаименование +
    ?(ПустоеЗначение(ПоставщикАдрес) = 0, ", " + ПоставщикАдрес, "");
    ПоставщикПолностью = ПоставщикКратко +
    ?(ПустоеЗначение(ПоставщикТелефоны) = 0, ", " + ПоставщикТелефоны, "") +
    ?(ПустоеЗначение(ПоставщикРеквизиты) = 0, ", " + ПоставщикРеквизиты, "");

    // плательщик

    ПлательщикНаименование = ПарамШапки.Получить("ПлательщикНаименование");
    ПлательщикАдрес = ПарамШапки.Получить("ПлательщикАдрес");
    ПлательщикРеквизиты = ПарамШапки.Получить("ПлательщикРеквизиты");
    ПлательщикКратко = ПлательщикНаименование +
    ?(ПустоеЗначение(ПлательщикАдрес) = 0, " ," + ПлательщикАдрес, "");
    ПлательщикПолностью = ПлательщикКратко +
    ?(ПустоеЗначение(ПлательщикРеквизиты) = 0, ", " + ПлательщикРеквизиты, "");
    ПлательщикОКПО = ПарамШапки.Получить("ПлательщикОКПО");

    // грузополучатель

    ПолучательНаименование = ПарамШапки.Получить("ПолучательНаименование");
    ПолучательАдрес = ПарамШапки.Получить("ПолучательАдрес");
    ПолучательРеквизиты = ПарамШапки.Получить("ПолучательРеквизиты");
    ПолучательКратко = ПолучательНаименование +
    ?(ПустоеЗначение(ПолучательАдрес) = 0, " ," + ПолучательАдрес, "");
    ПолучательПолностью = ПолучательКратко +
    ?(ПустоеЗначение(ПолучательРеквизиты) = 0, ", " + ПолучательРеквизиты, "");
    ПолучательОКПО = ПарамШапки.Получить("ПолучательОКПО");

    // выясним, какую вертикальную секцию будем использовать
    Если Докум.УчитыватьНП = 0 Тогда
    ВертСекция = "БезНП";
    Иначе
    ВертСекция = "НП";
    КонецЕсли;

    // Выводим шапку таблицы. Шапка печатается на каждом листе.

    ПечТабл.ВывестиСекцию("Шапка|" + ВертСекция);

    // Выводим спецификацию

    //Для простоты настройки печатной формы примем следующие соглашения:
    // - высота строк в таблице печатной формы задана жестко,
    // тогда известно, сколько строк помещается на странице;

    // Изменил 22 на 24 я дима !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    СтрокНаСтранице = 26;
    // - высота шапки и подвала задана жестко и кратна высоте строк таблицы,
    // тогда можно указать, сколько строк занимают шапка и подвал
    // в пересчете на строки таблицы;
    СтрокШапки = 10;
    СтрокПодвала = 9;
    // - для нормальной работы алгоритма необходимо, чтобы шапка и подвал
    // могли поместиться на одной странице + хотя бы одна строка таблицы:
    // СтрокНаСтранице >= СтрокШапки + СтрокПодвала + 1
    // - если подвал не помещается на странице, он переносится на другую
    // страницу с последней строкой; исключение составляет случай,
    // когда в таблице всего одна строка.
    НомерСтраницы = 1;

    КолвоСтрок = Докум.КоличествоСтрок();
    Если КолвоСтрок = 1 Тогда
    ПереноситьПоследнююСтроку = 0;
    Иначе
    ЦелыхСтраницСПодвалом = Цел((СтрокШапки + КолвоСтрок + СтрокПодвала) / СтрокНаСтранице);
    ЦелыхСтраницБезПодвала = Цел((СтрокШапки + КолвоСтрок - 1) / СтрокНаСтранице);
    ПереноситьПоследнююСтроку = ЦелыхСтраницСПодвалом - ЦелыхСтраницБезПодвала;
    КонецЕсли;

    // инициализация итогов по странице
    ИтогоКоличествоНаСтранице = 0;
    ИтогоСуммаНаСтранице = 0;
    ИтогоНДСНаСтранице = 0;
    ИтогоСуммаСНДСНаСтранице = 0;
    ИтогоНГСМНаСтранице = 0;
    ИтогоНПНаСтранице = 0;

    // инициализация итогов по документу
    ИтогоКоличество = 0;
    ИтогоСумма = 0;
    ИтогоНДС = 0;
    ИтогоСуммаСНДС = 0;
    ИтогоНГСМ = 0;
    ИтогоНП = 0;

    Ном = 0;
    КурсРублей = глКурсДляВалюты(глРубли, Докум.ДатаДок);

    ПечТабл.ВывестиСекцию("ЗаголовокТаблицы |"+ВертСекция);

    Докум.ВыбратьСтроки();
    Пока Докум.ПолучитьСтроку() = 1 Цикл
    Ном = Ном + 1;

    //Начинаем новую страницу, если предыдущая строка была последней на странице
    //или пора переносить последнюю строку на последнюю страницу с подвалом.
    ЦелаяСтраница = (СтрокШапки + Ном - 1) / СтрокНаСтранице;

    Если (ЦелаяСтраница = Цел(ЦелаяСтраница))
    или ((ПереноситьПоследнююСтроку = 1) и (Ном = КолвоСтрок)) Тогда
    ПечТабл.ВывестиСекцию("ИтогоПоСтранице|"+ВертСекция);
    ИтогоКоличествоНаСтранице = 0;
    ИтогоСуммаНаСтранице = 0;
    ИтогоНДСНаСтранице = 0;
    ИтогоСуммаСНДСНаСтранице = 0;
    ИтогоНГСМНаСтранице = 0;
    ИтогоНПНаСтранице = 0;
    ПечТабл.НоваяСтраница();
    НомерСтраницы = НомерСтраницы + 1;
    ПечТабл.ВывестиСекцию("ЗаголовокТаблицы|" + ВертСекция);
    КонецЕсли;

    ПечТовар = Докум.Номенклатура;
    ПечЕдиница = Докум.Единица;
    ПечКоличество = Докум.Количество;

    ПечКолвоВОдномМесте = ?(Докум.Коэффициент <= 1, "", Докум.Коэффициент);
    ПечКоличествоМест = ?(Докум.Коэффициент <= 1, "", Докум.Количество);



    КолВо = ?(ПечКоличество=0, 1, ПечКоличество);

    СуммаПеч = глПересчет(Докум.Сумма , Докум.Валюта, Докум.Курс, глРубли, Докум.ДатаДок, Докум.Кратность);
    СуммаНДСПеч = глПересчет(Докум.СуммаНДС, Докум.Валюта, Докум.Курс, глРубли, Докум.ДатаДок, Докум.Кратность);
    СуммаНППеч = глПересчет(Докум.СуммаНП , Докум.Валюта, Докум.Курс, глРубли, Докум.ДатаДок, Докум.Кратность);

    Если Докум.СуммаВклНП = 1 Тогда
    СуммаБезНП = СуммаПеч - СуммаНППеч;
    Иначе
    СуммаБезНП = СуммаПеч;
    КонецЕсли;

    Если Докум.СуммаВклНДС = 1 Тогда
    СуммаБезНДС = СуммаБезНП - СуммаНДСПеч;
    СуммаСНДС = СуммаБезНП;
    Иначе
    СуммаБезНДС = СуммаБезНП;
    СуммаСНДС = СуммаБезНП + СуммаНДСПеч;
    КонецЕсли;

    ПечНДС = СуммаНДСПеч;

    Если Докум.УчитыватьНП = 1 Тогда
    ПечНП = СуммаНППеч;
    Иначе
    ПечНП = "";
    КонецЕсли;

    ПечЦена = ?(Докум.Количество <> 0, СуммаБезНДС / Докум.Количество, СуммаБезНДС);

    // Если цена, указанная в документе в рублях,
    // без налогов и без скидки
    // то в печ. форме надо отражть ее.
    Если ((Докум.УчитыватьНДС = 0) или (Докум.СуммаВклНДС = 0))
    и (Докум.СуммаВклНП = 0)
    и (Докум.Валюта = глРубли)
    и (Докум.Скидка.Выбран() = 0) Тогда
    ПечЦена = Докум.Цена;
    КонецЕсли;

    ПечТабл.ВывестиСекцию("Строка|" + ВертСекция);

    ИтогоКоличествоНаСтранице = ИтогоКоличествоНаСтранице + Докум.Количество;
    ИтогоСуммаНаСтранице = ИтогоСуммаНаСтранице + СуммаБезНДС;
    ИтогоНДСНаСтранице = ИтогоНДСНаСтранице + ПечНДС;
    ИтогоСуммаСНДСНаСтранице = ИтогоСуммаСНДСНаСтранице + СуммаСНДС;

    Если Докум.УчитыватьНП = 1 Тогда
    ИтогоНПНаСтранице = ИтогоНПНаСтранице + ПечНП;
    КонецЕсли;

    ИтогоКоличество = ИтогоКоличество + Докум.Количество;
    ИтогоСумма = ИтогоСумма + СуммаБезНДС;
    ИтогоНДС = ИтогоНДС + ПечНДС;
    ИтогоСуммаСНДС = ИтогоСуммаСНДС + СуммаСНДС;

    Если Докум.УчитыватьНП = 1 Тогда
    ИтогоНП = ИтогоНП + ПечНП;
    КонецЕсли;
    КонецЦикла;

    ПечТабл.ВывестиСекцию("ИтогоПоСтранице|" + ВертСекция);
    ПечТабл.ВывестиСекцию("Всего|" + ВертСекция);

    // выводим подвал
    НаСумму = "на сумму " + глСуммаПрописью(ИтогоСуммаСНДС + ИтогоНП, глРубли);

    // формируем строку для вывода количества листов накладной
    // Слово лист склоняется
    Если (НомерСтраницы > 10) И (НомерСтраницы < 20) Тогда
    Слово = " листах";
    Иначе
    ПоследняяЦифра = НомерСтраницы % 10;
    Если ПоследняяЦифра = 1 Тогда
    Слово = " листе";
    Иначе
    Слово = " листах";
    КонецЕсли;
    КонецЕсли;

    ПечГлавБух = Докум.Фирма.ЮрЛицо.ГлБухгалтер.Получить(Докум.ДатаДок);

    СтрокаКоличествоЛистов = Строка(НомерСтраницы) + Слово;
    ПечТабл.ВывестиСекцию("Подвал|" + ВертСекция);

    // показать сформированную таблицу
    Если Устройство = 0 Тогда
    ПечТабл.Опции(0,0,0,0,"ДляРеализации");

    Если глПолучитьПолномочие("РазрешитьРедактированиеТаблиц") = 0 Тогда
    ПечТабл.Защита(1);
    Иначе
    ПечТабл.Защита(0);
    КонецЕсли;
    ПечТабл.ТолькоПросмотр(1);

    ПечТабл.Показать(глНазваниеДокументаВжурнале(Докум),"");
    Иначе
    ПечТабл.ПараметрыСтраницы(,,,,,,,,,1,,);
    ПечТабл.КоличествоЭкземпляров(КолвоКопий);
    ПечТабл.Напечатать(0);
    КонецЕсли;
    КонецПроцедуры // Печать()//*******************************************

    //******************************************************************************
    // ПоКнопкеПечать()
    //
    // Параметры:
    // Нет
    //
    // Возвращаемое значение:
    // Нет
    //
    // Вызывается из формул элементов диалога:
    // Кнопка "Печать"
    //
    // Описание:
    // Выполняет проверку заполнения реквизитов диалога, вызывает процедуру Печать
    //


    Процедура ПоКнопкеПечать()

    Перем ПечатаемыйДок;

    ПечатаемыйДок = ?(ПустоеЗначение(Док) = 1, ПечДок, Док);

    ТестОшибки = "";
    Если ПустоеЗначение(ПечатаемыйДок) = 1 Тогда
    ТестОшибки = "Не выбран документ!";
    ИначеЕсли ПустоеЗначение(Грузополучатель) = 1 Тогда
    ТестОшибки = "Не выбран грузополучатель!";
    КонецЕсли;

    Если ПустоеЗначение(ТестОшибки) = 0 Тогда
    Предупреждение(ТестОшибки, 60);
    Возврат;
    КонецЕсли;

    Печать(ПечатаемыйДок);

    КонецПроцедуры // ПоКнопкеПечать()

    //******************************************************************************
    // Предопределенная процедура
    //

    Процедура ПриОткрытии()
    Если ПустоеЗначение(Форма.Параметр) = 1 Тогда
    // не передан контекст документа
    Форма.ИспользоватьСлой("Шапка1,Подвал", 2);
    Иначе
    ПечДок = Форма.Параметр.Получить("Контекст");
    Грузополучатель = ПечДок.Контрагент;
    Устройство = Форма.Параметр.Получить("Устройство");
    КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
    Форма.ИспользоватьСлой("Шапка2,Подвал", 2);
    КонецЕсли;

    Форма.Грузополучатель.ВыборГруппы(0);
    КонецПроцедуры // ПриОткрытии()

    Устройство = 0;
    КолвоКопий = 1;
  6. Максимка
    Offline

    Максимка

    Регистрация:
    17 фев 2007
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Ну ведь все проще чем кажется. Надо пробывать и все здесь пару ссылок заремировать и все дела.
  7. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    Ну так подскажи как4ие ссылки?
  8. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
  9. Максимка
    Offline

    Максимка

    Регистрация:
    17 фев 2007
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Зайди в конфигуратор, открой свою форму, и там где будет проверка перед запуском (ведь там есть обработка файла) закомментируй эти процедуры и все дела.
  10. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    СЕЙЧАС ПОПРОБУЮ...
  11. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    //////////////////
  12. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    В конце процедуры ПриОткрытии() добавь команду
    СтатусВозврата(0);
    Возврат;
  13. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    теперь вообще ничего не выводит на печать...
    Я сделал так:


    Процедура ПриОткрытии()
    Если ПустоеЗначение(Форма.Параметр) = 1 Тогда
    // не передан контекст документа
    Форма.ИспользоватьСлой("Шапка1,Подвал", 2);
    Иначе
    ПечДок = Форма.Параметр.Получить("Контекст");
    Грузополучатель = ПечДок.Контрагент;
    Устройство = Форма.Параметр.Получить("Устройство");
    КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
    Форма.ИспользоватьСлой("Шапка2,Подвал", 2);
    КонецЕсли;

    СтатусВозврата(0);

    Форма.Грузополучатель.ВыборГруппы(0);
    КонецПроцедуры // ПриОткрытии()
  14. TopicStarter Overlay
    Дмитрий Ив
    Offline

    Дмитрий Ив Опытный в 1С

    Регистрация:
    14 дек 2006
    Сообщения:
    82
    Симпатии:
    0
    Баллы:
    26
    Всем спасибо.

    Я не стал делать новую печатную форму, а вернулся к изменению базовой печатной формы в конфегурации. Путем редактирования модуля в документе реализации и основной печатной формы ТОРГ-12, я доостиг изночального поставленной цели.


    Всем огромное спасибо кто участвовал в моем поиске и пытался мне помочь

    PS: нажно было изменить только одну цифру, как я сразу не догадался...
  15. Максимка
    Offline

    Максимка

    Регистрация:
    17 фев 2007
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Я же сказал, что все очень просто!
  16. Амадеус
    Offline

    Амадеус

    Регистрация:
    22 авг 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
  17. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    потрудись конкретизировать что тебя интересует
  18. Амадеус
    Offline

    Амадеус

    Регистрация:
    22 авг 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    У меня такой вопрос в Торг 12 если номеклатуры больше двух позиций, последнюю наменклатуру переносит на следующую страницу, получается Торг-12 на двух страницах, как это изменить?

    Хочется чтоб торг 12 печаталась на 1-м листе с максимальным числом номенклатурных позиций. Хотя бы пять. Как это зделать? И какое число максимум возможно?
    Как мне кажется можно разместить в печатной форме - 5-7 номенклатурных позиций, без проблем...

    Именно это, помогите разобраться! Да,1С семерка
  19. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    семерка... торговля, бух, усн, зик, комплексная, предприниматель, дальше перечислять?
  20. Амадеус
    Offline

    Амадеус

    Регистрация:
    22 авг 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Предприятие торговля-склад,редакция 9.2

Поделиться этой страницей