8.х ЗУП Печатная форма по больничному (Начислено пособия с учетом РК)

Тема в разделе ""1С:Зарплата и управление персоналом ЗУП"", создана пользователем snake.87, 4 мар 2013.

  1. TopicStarter Overlay
    snake.87
    Offline

    snake.87

    Регистрация:
    25 июл 2012
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Конфигурация ЗУП 2.5.59.2

    Как сделать чтобы в печатной форме начисления по больничному "Расчет пособия по б/л 2011" в пункте "Начислено пособия" при МРОТ+РК большем чем средняя зарплата писал "Начислено пособия с учетом РК: 1,15"

    Выборку нашел, как подправить не могу понять
    Находится в документы-НачислениеПоБольничномуЛисту
    строки ~ 1317 и 1815


    Код:
    Если Выборка.Следующий() Тогда
    Если Выборка.Средний < Выборка.СреднийМРОТ И Выборка.РайонныйКоэффициентРФОрганизации > 1 Тогда
    СекцияРасчетПособияШапка.Параметры.УчетРК = " с учетом РК: " + Выборка.РайонныйКоэффициентРФОрганизации
    КонецЕсли;
    КонецЕсли;
    
    т.е. Если средняя ЗП< МРОТ+РК>1 Тогда (интересует как задать такое условие)
  2. Aston
    Offline

    Aston Опытный в 1С

    Регистрация:
    6 июн 2012
    Сообщения:
    467
    Симпатии:
    3
    Баллы:
    29
    Может надо так?
    Код:
    Если СредняяЗП< МРОТ И РК>1 Тогда
  3. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Не совсем внятно вопрос сформулировали...
    Можно на цифрах? Сколько начислено, какой РК и что конкретно хотите видеть в строке печатной формы и что у Вас выводится сейчас.

    Бо, насколько я вижу по коду, как раз сейчас у Вас и должно выводиться то, что Вы хотите видеть.

    РК-то на сотрудника у Вас введен?
  4. TopicStarter Overlay
    snake.87
    Offline

    snake.87

    Регистрация:
    25 июл 2012
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    РК-1,15
    хочу увидеть при "Минимальном среднедневном заработке исчисленном из МРОТ"+РК большем чем "среднедневной заработок" в шапке таблицы "Начислено пособия с учетом РК 1,15"
    т.е. если 180,4<171,12*1,15 тогда в шапке таблицы "Начислено пособия" добавляется "с учетом РК"
    программа выполняет условие такое условие 180,4<171,12 тогда..., т.е. не прибавляет к МРОТ районный коэффициент.
    Печатная форма:
    http://files.mail.ru/7ED304A271CC43138A55ED9A372664E2?t=1
  5. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Так вроде как проблема-то в чем? Вот так тогда:
    Код:
    Если Выборка.Средний < Выборка.СреднийМРОТ*Выборка.РайонныйКоэффициентРФОрганизации И Выборка.РайонныйКоэффициентРФОрганизации > 1 Тогда
    СекцияРасчетПособияШапка.Параметры.УчетРК = " с учетом РК: " + Выборка.РайонныйКоэффициентРФОрганизации
    КонецЕсли;
    
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    Надеюсь вы внешнюю печатную форму делаете, а не в типовой правите?

Поделиться этой страницей