7.7 Печать Заказов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 4 авг 2009.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Народ. Помогите. Как сделать так чтобы, печаталась заявка сразу по нескольким параметрам.
    Суть в следующем, есть заявки по которым склад собирает товар на отгрузку. Надо сделать так, чтобы заявка еще и распечатывалась отдельная на каждую зону хранения(вместе с общей).
    Создаю справочник Залы Хранения в Номенклатуре создаю аналогичный реквизит. Туда забиваю данные(например:корма,игрушки и т.д.) Так вот надо как-то сделать так чтобы при печати если это корма то он печатает отдельно заявку корма если это игрушки он печатает отдельно заявку игрушки.
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Реквизит у тебя уже есть. Выгружай табличну часть в ТЗ, сортируй по зонам, формируй заявки
  4. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Да
  5. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    а в чем сложность-то?
    Код:
    Var oSpr; 
    Function ПодборЭлтов(oVT,pValue)
    If ValueTypeStr(oVT) <> "ТаблицаЗначений" Then    
    oVT = CreateObject("ValueTable");
    oVT.InsertColumn("ID");
    ...
    EndIf;
    oSpr.UseParent(pValue);
    oSpr.SelectItems();
    While oSpr.GetItem() = 1 Do
    oVT.NewLine();
    oVT.ID = pValue;
    ...// заполняем нужные поля
    EndDo;    
    Return oVT;             
    EndFunction
    
    Procedure Main()
    oSpr = CreateObject("Справочник.Номенклатура");
    oSpr.FindByCode("...1"); //корма  
    pКорма = oSpr.CurrentItem();
    oSpr.FindByCode("...2"); //игрушки
    pИгрушки = oSpr.CurrentItem();
    oVT = ПодборЭлтов(oVT,pКорма);
    oVT = ПодборЭлтов(oVT,pИгрушки);
    oVT.SelectLines();
    While oVT.GetLine() = 1 Do
    If oVT.ID = "Игрушки" Then
    //печать формы игрушки
    ElsIf oVT.ID = "Корма" Then
    //печать формы корма
    ...
    EndIf;
    EndDo;
    EndProcedure
    
    
    может я не правильно понял, конечно, еще не проснулся ...сорри за транслит..
  6. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    фобец, ну ты дал... Автор мяу, по-моему, в 1с сказать не может, ты ему на тарабарском...

    Proman, кодить смогешь?
  7. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    не, ну, я примерно набросал, кодить-то ему все равно видимо придется :unsure:
  8. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Реквезит есть, но он может относиться как группе(подгруппе) так и к элементу. Форма есть готовая и свободная(из пакетной печати:валютная)
    Посмотреть вложение 2470
    так вот в этой форме надо только добавить зал хранения и сделать так чтобы отбирались позиции при заявке согласно залу. Как это сделать.

    немного.главное суть понять

    Вложения:

    • Форма.JPG
      Форма.JPG
      Размер файла:
      108,4 КБ
      Просмотров:
      26
  9. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    эта форма относится к какому-то документу. ты хочешь ее перенести в отчет или печатать несколько форм из этого документа?
  10. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Да предзаявка.В шапку пишем выражение Номенклатура.ЗалХранения и при печати он мне выдает в загаловке что надо но как сделать так чтобы при печати он пробежался по всем строкам и отобрал конкретную позицию и при смене начал заново отбор т.е. в заявке есть товар из кормов и есть товар из игрушки надо чтобы сразу при печати выводилось корма один лист игрушки другой и т.д.

    Код:
    // валютная заявка
    Если (В_накл = 1) и (К_В_Н > 0) 	Тогда
    
    ТаблицаДокумента = СоздатьОбъект("ТаблицаЗначений");
    ВыгрузитьТабличнуюЧасть(ТаблицаДокумента,"Валюта");
    ТаблицаДокумента.Свернуть("Валюта","Валюта");
    ПечКур="Курс: ";
    ТаблицаДокумента.ВыбратьСтроки();
    Пока ТаблицаДокумента.ПолучитьСтроку()=1 Цикл
    Если ТаблицаДокумента.Валюта.Наименование<>"руб." Тогда
    ПечКур=ПечКур+ТаблицаДокумента.Валюта+" - "+КурсДляВалюты(ТаблицаДокумента.Валюта)+";";
    КонецЕсли;
    КонецЦикла;
    
    ИсхТабл = СоздатьОбъект("Таблица");
    ИсхТабл.ИсходнаяТаблица("ВалютнаяЗаявка");
    НачПовт = 0; КонПовт = 0;
    ПечФирма = ""; Банк = ""; Счет = ""; БИК = ""; СчетБанка = "";
    
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(БанковскийСчет, "БанковскийСчет");
    глРеквизитыПлательщикаПолучателя(Параметры);
    ПечФирма 	= Параметры.Получить("Результат");
    Банк		= Параметры.Получить("СтрокаБанка");
    Счет		= Параметры.Получить("РасчетныйСчет");
    БИК			= Параметры.Получить("БИК");
    СчетБанка	= Параметры.Получить("КоррСчет");
    
    ИсхТабл.ВывестиСекцию("Заголовок");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");
    ИсхТабл.ВывестиСекцию("Шапка");
    КонПовт = НачПовт + ИсхТабл.ВысотаСекции("Шапка");
    ИсхТабл.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);
    НомСтроки = 0;
    ВыбратьСтроки();
    ВсегоСумма=0;
    ВсегоUSD=0;
    ВсегоEUR=0;
    ВсегоRub=0;
    Пока ПолучитьСтроку() = 1 Цикл
    НомСтроки = НомСтроки + 1;
    Если Валюта.Наименование="руб." Тогда
    ЦенаДок=Окр(Цена-Скидка.Процент/100*Цена,2,1);
    СуммаДок=Окр(ЦенаДок*Количество,2,1);
    Иначе
    ЦенаДок=Окр(Окр(Цена-Скидка.Процент/100*Цена,3,1)*КурсДляВалюты(Валюта),2,1); //глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);
    СуммаДок=Окр(ЦенаДок*Количество,3,1);
    КонецЕсли;
    Если Лев(Валюта,3)="USD" Тогда
    ВсегоUSD=ВсегоUSD+Сумма;
    ИначеЕсли Лев(Валюта,3)="EUR" Тогда
    ВсегоEUR=ВсегоEUR+Сумма;
    ИначеЕсли НРег(Лев(Валюта,3))="руб" Тогда
    ВсегоRub=ВсегоRub+Сумма;
    КонецЕсли;
    ВсегоСумма=Окр(ВсегоСумма+СуммаДок,2,1);
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    ИсхТабл.ВывестиСекцию("Итоги");
    ИсхТабл.ВывестиСекцию("Подписи");
    Если БПСпособПечати = 1 Тогда
    СразуНаПринтер = 0;
    Иначе                  
    СразуНаПринтер = 1;
    КонецЕсли;
    Если СразуНаПринтер = 0 Тогда
    ИсхТабл.Опции(0,0,0,0,"ОпцииПечатиПлПор","ПараметрыОкнаПлПор");
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.Защита(1);
    ИсхТабл.ТолькоПросмотр(0);
    ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),"");  
    Иначе     
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.КоличествоЭкземпляров(К_В_Н);
    ИсхТабл.Напечатать(0);
    КонецЕсли; 
    КонецЕсли;
    
    
    Что в этом коде надо добавить чтобы заработала моя схема
  11. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    тогда примерно так:
    Код:
    Var oSpr; 
    Function ПодборЭлтов(oVT = "",pValue)
    If ValueTypeStr(oVT) <> "ТаблицаЗначений" Then    
    oVT = CreateObject("ValueTable");
    oVT.InsertColumn("ID");
    oVT.InsertColumn("Наименование");
    oVT.InsertColumn("Количество");
    oVT.InsertColumn("Скидка");
    oVT.InsertColumn("Валюта");
    oVT.InsertColumn("Цена");
    ...
    EndIf;
    oSpr.UseParent(pValue);
    oSpr.SelectItems();
    While oSpr.GetItem() = 1 Do
    oVT.NewLine();
    oVT.ID = pValue.Наименование;
    ...// заполняем нужные поля
    EndDo;    
    Return oVT;             
    EndFunction
    
    Procedure ПечатьФормы(oVT)
    If oVT.LinesCnt()>0 Then
    oTab = CreateObject("Table");
    oTab.SourceTable("ИмяТаблицы"); //название вашей фомы
    oTab.PutSection("Заголовок"); 
    oTab.PutSection("Шапка"); 
    oVT.SelectLines();
    While oVT.GetLine() = 1 Do
    Наименование = TrimAll(oVT.Наименование); //в печатной форме вместо СокрЛП(Номенклатура.Наименование) пишем Наименование
    Количество = oVT.Количество;
    Валюта = oVT.Валюта;
    ...
    oTab.PutSection("Строка"); 
    EndDo;                     
    oTab.PutSection("Итоги"); 
    oTab.PutSection("Подписи"); 
    
    EndIf;
    EndProcedure
    
    Procedure ПодготовкаКПечати()
    oSpr = CreateObject("Справочник.Номенклатура");
    oSpr.FindByCode("...1"); //корма  
    pКорма = oSpr.CurrentItem();
    oSpr.FindByCode("...2"); //игрушки
    pИгрушки = oSpr.CurrentItem();
    SelectLines();//выбираем табличную часть документа
    While GetLine()= 1 Do //бежим по строкам
    If Наименование.Parent = pКорма Then
    oVT1 = ПодборЭлтов(oVT1,pКорма);
    ElsIf Наименование.Parent = pИгрушки Then
    oVT2 = ПодборЭлтов(oVT2,pИгрушки);
    EndIf;
    EndDo;
    ПечатьФормы(oVT1);
    ПечатьФормы(oVT2);
    EndProcedure
    
    

    упс.. ща поглядим

    вот эту свою штукунадо вставить здесь:

    Код:
    Procedure ПечатьФормы(oVT)
    If oVT.LinesCnt()>0 Then
    ...
    EndIf;
    
    
    
    ну и соответсвенно мой кусок с циклом это будет это
    Код:
                      Пока ПолучитьСтроку() = 1 Цикл
    НомСтроки = НомСтроки + 1;
    Если Валюта.Наименование="руб." Тогда
    ЦенаДок=Окр(Цена-Скидка.Процент/100*Цена,2,1);
    СуммаДок=Окр(ЦенаДок*Количество,2,1);
    Иначе
    ...
    
    
    по табличной части в моем коде мы бежали в процедуре Печать() соответсвенно тут будет уже вместо данных из ТЧ данные из таблицы значений.. я пишу лишь приблизительно. .у меня условия на наличии номенклатуры в группах Игрушки или Корма, если разделения по группам нет значит условием будет уже какойто реквизит элемента номенклатуры..
    P.S. форум переклинило чуток от моего кода
  12. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Печать пакетная и вот эта моя штука находится внутри Процедуры Печать()
    Код:
    Процедура Печать()
    Перем НачПовт, КонПовт;                      
    Перем Р_накл, К_Руб_н, В_накл, К_В_Н, БПСпособПечати;	
    
    //Если (НазваниеИнтерфейса()<>"Администратор") и (Фирма.Наименование <> "Инкос") Тогда
    //	Предупреждение("Нельзя печатать счета не от Инкоса",10);
    //	Возврат;
    //КонецЕсли;
    
    Параметр	= СоздатьОбъект("СписокЗначений");
    Параметр.ДобавитьЗначение(1 , "Счет");
    Параметр.ДобавитьЗначение(Р_накл , "Р_накл");	
    Параметр.ДобавитьЗначение(К_Руб_н , "К_Руб_н");	
    Параметр.ДобавитьЗначение(В_накл , "В_накл");	
    Параметр.ДобавитьЗначение(К_В_Н , "К_В_Н");	
    Параметр.ДобавитьЗначение(2 , "БПСпособПечати");	
    // открываем форму обработки
    ОткрытьФормуМодально("Обработка.ПакетнаяПечать", Параметр);
    
    Если Параметр.Получить("СтатусВозврата") = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Р_накл = Параметр.Получить("Р_накл");	
    К_Руб_н = Параметр.Получить("К_Руб_н");	
    В_накл = Параметр.Получить("В_накл");	
    К_В_Н = Параметр.Получить("К_В_Н");	
    БПСпособПечати = Параметр.Получить("БПСпособПечати");	
    
    ТаблицаДокумента = СоздатьОбъект("ТаблицаЗначений");
    ВыгрузитьТабличнуюЧасть(ТаблицаДокумента);
    СписокПараметровПечати = СоздатьОбъект("СписокЗначений");		
    
    
    // рублевая заявка
    Если (Р_накл = 1) и (К_Руб_н > 0) 	Тогда     
    
    РегХран=СоздатьОбъект("Регистр.ХранениеТовара");
    ТЗН=СоздатьОбъект("ТаблицаЗначений");
    
    ИсхТабл = СоздатьОбъект("Таблица");
    ИсхТабл.ИсходнаяТаблица("РублеваяЗаявка");
    НачПовт = 0; КонПовт = 0;
    ПечФирма = ""; Банк = ""; Счет = ""; БИК = ""; СчетБанка = "";
    
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(БанковскийСчет, "БанковскийСчет");
    глРеквизитыПлательщикаПолучателя(Параметры);
    ПечФирма 	= Параметры.Получить("Результат");
    Банк		= Параметры.Получить("СтрокаБанка");
    Счет		= Параметры.Получить("РасчетныйСчет");
    БИК			= Параметры.Получить("БИК");
    СчетБанка	= Параметры.Получить("КоррСчет");
    
    ИсхТабл.ВывестиСекцию("Заголовок");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");
    ИсхТабл.ВывестиСекцию("Шапка");
    КонПовт = НачПовт + ИсхТабл.ВысотаСекции("Шапка");
    ИсхТабл.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);
    НомСтроки = 0;
    ВыбратьСтроки();
    ВсегоСумма=0;
    ВсегоНДС=0;
    Пока ПолучитьСтроку() = 1 Цикл
    НомСтроки = НомСтроки + 1;
    Если Валюта.Наименование="руб." Тогда
    ЦенаДок=Окр(Цена-Скидка.Процент/100*Цена,2,1);
    СуммаДок=Окр(ЦенаДок*Количество,2,1);
    Иначе
    ЦенаДок=Окр(Окр(Цена-Скидка.Процент/100*Цена,3,1)*КурсДляВалюты(Валюта),2,1); //глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);
    СуммаДок=Окр(ЦенаДок*Количество,3,1);
    КонецЕсли;
    Если СуммаВклНДС=1 Тогда
    НДСДок=СуммаДок*глВыделяемыйНДС(СтавкаНДС);
    Иначе
    НДСДок=СуммаДок*глНачисляемыйНДС(СтавкаНДС);
    КонецЕсли;
    
    //НДСДок=Окр(СуммаНДС*КурсДляВалюты(Валюта),2,1); //глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);
    ВсегоНДС=Окр(ВсегоНДС+НДСДок,2,1);
    ВсегоСумма=Окр(ВсегоСумма+СуммаДок,2,1);
    РегХран.УстановитьФильтр(,Номенклатура);
    РегХран.ВыгрузитьИтоги(ТЗН);
    МХ="";
    ТЗН.ВыбратьСтроки();
    Пока ТЗН.ПолучитьСтроку()=1 Цикл
    МХ=МХ+СокрЛП(ТЗН.Место.Код)+"; ";
    КонецЦикла;
    
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    ИсхТабл.ВывестиСекцию("Итоги");
    Если БПСпособПечати = 1 Тогда
    СразуНаПринтер = 0;
    Иначе                  
    СразуНаПринтер = 1;
    КонецЕсли;
    Если СразуНаПринтер = 0 Тогда
    ИсхТабл.Опции(0,0,0,0,"ОпцииПечатиПлПор","ПараметрыОкнаПлПор");
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.Защита(1);
    ИсхТабл.ТолькоПросмотр(0);
    ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),"");  
    Иначе     
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.КоличествоЭкземпляров(К_Руб_н);
    ИсхТабл.Напечатать(0);
    КонецЕсли; 
    КонецЕсли;
    
    // валютная заявка
    Если (В_накл = 1) и (К_В_Н > 0) 	Тогда
    
    ТаблицаДокумента = СоздатьОбъект("ТаблицаЗначений");
    ВыгрузитьТабличнуюЧасть(ТаблицаДокумента,"Валюта");
    ТаблицаДокумента.Свернуть("Валюта","Валюта");
    ПечКур="Курс: ";
    ТаблицаДокумента.ВыбратьСтроки();
    Пока ТаблицаДокумента.ПолучитьСтроку()=1 Цикл
    Если ТаблицаДокумента.Валюта.Наименование<>"руб." Тогда
    ПечКур=ПечКур+ТаблицаДокумента.Валюта+" - "+КурсДляВалюты(ТаблицаДокумента.Валюта)+";";
    КонецЕсли;
    КонецЦикла;
    
    ИсхТабл = СоздатьОбъект("Таблица");
    ИсхТабл.ИсходнаяТаблица("ВалютнаяЗаявка");
    НачПовт = 0; КонПовт = 0;
    ПечФирма = ""; Банк = ""; Счет = ""; БИК = ""; СчетБанка = "";
    
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(БанковскийСчет, "БанковскийСчет");
    глРеквизитыПлательщикаПолучателя(Параметры);
    ПечФирма 	= Параметры.Получить("Результат");
    Банк		= Параметры.Получить("СтрокаБанка");
    Счет		= Параметры.Получить("РасчетныйСчет");
    БИК			= Параметры.Получить("БИК");
    СчетБанка	= Параметры.Получить("КоррСчет");
    
    ИсхТабл.ВывестиСекцию("Заголовок");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");
    ИсхТабл.ВывестиСекцию("Шапка");
    КонПовт = НачПовт + ИсхТабл.ВысотаСекции("Шапка");
    ИсхТабл.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);
    НомСтроки = 0;
    ВыбратьСтроки();
    ВсегоСумма=0;
    ВсегоUSD=0;
    ВсегоEUR=0;
    ВсегоRub=0;
    Пока ПолучитьСтроку() = 1 Цикл
    НомСтроки = НомСтроки + 1;
    Если Валюта.Наименование="руб." Тогда
    ЦенаДок=Окр(Цена-Скидка.Процент/100*Цена,2,1);
    СуммаДок=Окр(ЦенаДок*Количество,2,1);
    Иначе
    ЦенаДок=Окр(Окр(Цена-Скидка.Процент/100*Цена,3,1)*КурсДляВалюты(Валюта),2,1); //глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);
    СуммаДок=Окр(ЦенаДок*Количество,3,1);
    КонецЕсли;
    Если Лев(Валюта,3)="USD" Тогда
    ВсегоUSD=ВсегоUSD+Сумма;
    ИначеЕсли Лев(Валюта,3)="EUR" Тогда
    ВсегоEUR=ВсегоEUR+Сумма;
    ИначеЕсли НРег(Лев(Валюта,3))="руб" Тогда
    ВсегоRub=ВсегоRub+Сумма;
    КонецЕсли;
    ВсегоСумма=Окр(ВсегоСумма+СуммаДок,2,1);
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    ИсхТабл.ВывестиСекцию("Итоги");
    ИсхТабл.ВывестиСекцию("Подписи");
    Если БПСпособПечати = 1 Тогда
    СразуНаПринтер = 0;
    Иначе                  
    СразуНаПринтер = 1;
    КонецЕсли;
    Если СразуНаПринтер = 0 Тогда
    ИсхТабл.Опции(0,0,0,0,"ОпцииПечатиПлПор","ПараметрыОкнаПлПор");
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.Защита(1);
    ИсхТабл.ТолькоПросмотр(0);
    ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),"");  
    Иначе     
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.КоличествоЭкземпляров(К_В_Н);
    ИсхТабл.Напечатать(0);
    КонецЕсли; 
    КонецЕсли;
    
    КонецПроцедуры // Печать();
    
    
    И вот в печать надо вставить именно какую то функцию
    так чтобы выходила основная(рублевая) заявка и отдельно фыходила печать по группам(ЗалХранения)
  13. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ну и что что пакетная, можно в отдельную обработку все это вынести... мне надо перекурить, подумать
  14. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    как-то так

    Вложения:

  15. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Нельзя отдельной обработкой
    Есть готовая и к ней менеджеры привыкли
    Код:
    Процедура Отмена()
    Форма.Параметр.Установить("СтатусВозврата"	, 0);
    КонецПроцедуры
    
    
    //*******************************************
    Процедура Выполнить()
    Если Форма.Параметр.Получить("Счет")=0 тогда
    Форма.Параметр.Установить("Тов_накл", Тов_накл);
    Форма.Параметр.Установить("К_Тов_н", К_Тов_н);
    Форма.Параметр.Установить("СФ", СФ);	
    Форма.Параметр.Установить("К_СФ", К_СФ);	
    Форма.Параметр.Установить("Запрос", Запрос);	
    Форма.Параметр.Установить("К_Зап", К_Зап);
    Форма.Параметр.Установить("К_ТТН", К_ТТН);
    Форма.Параметр.Установить("Т_ТТН", Т_ТТН);
    Форма.Параметр.Установить("ГрузоОтправДОК", ГрузоОтправДОК);
    КонецЕсли;
    Форма.Параметр.Установить("Р_накл", Р_накл);	
    Форма.Параметр.Установить("К_Руб_н", К_Руб_н);	
    Форма.Параметр.Установить("В_накл", В_накл);	
    Форма.Параметр.Установить("К_В_Н", К_В_Н);
    Форма.Параметр.Установить("С_серт", С_серт);
    Форма.Параметр.Установить("К_Сер", К_Сер);
    Форма.Параметр.Установить("БПСпособПечати", БПСпособПечати);	
    КонецПроцедуры
    
    
    //*******************************************
    Процедура ПриОткрытии()                     
    Если Форма.Параметр.Получить("Счет")=1 тогда
    Форма.Тов_накл.Доступность(0);
    Тов_накл=0;
    Форма.К_Тов_н.Доступность(0);
    К_Тов_н=0;
    Т_ТТН=0; 
    Форма.Т_ТТН.Доступность(0);
    Форма.К_ТТН.Доступность(0);
    К_ТТН=0;
    Форма.СФ.Доступность(0);
    СФ=0;
    Форма.К_СФ.Доступность(0);
    К_СФ=0;
    Форма.Запрос.Доступность(0);
    Запрос=0;
    Форма.К_Зап.Доступность(0);
    К_Зап=0;  
    
    
    Форма.ГрузоОтправДОК.Доступность(0);  
    Форма.Уд.Доступность(0);
    Форма.Р_накл.Заголовок("Рублевый счет");	
    Форма.В_накл.Заголовок("По зонам");	
    Иначе  
    Форма.Т_ТТН.Доступность(1);
    Форма.К_ТТН.Доступность(1);
    Форма.Тов_накл.Доступность(1);
    Форма.К_Тов_н.Доступность(1);
    Форма.СФ.Доступность(1);
    Форма.К_СФ.Доступность(1);
    Форма.Запрос.Доступность(0);
    Запрос=1;
    Форма.К_Зап.Доступность(0);
    К_Зап=1;  
    Форма.ГрузоОтправДОК.Доступность(1);  
    Форма.Уд.Доступность(1);
    Форма.Р_накл.Заголовок("Рублевую накладную");	
    Форма.В_накл.Заголовок("Валютную накладную"); 
    ГрузоОтправДОК="";
    //	ГрузоОтправДОК=Форма.Параметр.Получить("ГрузоОтправДОК");
    КонецЕсли;  
    
    БПСпособПечати=Форма.Параметр.Получить("БПСпособПечати"); 
    
    
    КонецПроцедуры
    
    
    
    
    Вот она и её надо переделать как Это сделать?
  16. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    дык я не переделывал я тебе твой кусок кода скинул который в твоем документе надо заменить примерно, просто в ертшнике .. ток тестируй не на живой базе конечно :)
    ну и вместо процедуры Печать() у тебя должна вызываться процедура ПодготовкаКПечати()
  17. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Все конечно хорошо но я по русски плохо код пишу а в транслите вообще ничего не понимаю
  18. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Выкладывай сюда обработку
  19. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Вот обработка пакетной печати Посмотреть вложение 2473
    А вот код самой заявки
    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НачальнаяДатаДокумента[color=red];[/color] [color=green]// для механизма контроля уникальности номеров[/color]
    
    [color=green]// Для контроля необходимости пересчетов[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СтараяДата[color=red],[/color] СтараяФирма[color=red],[/color] СтарыйДоговор[color=red],[/color] СтарыйКонтрагент[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СуммаДокументаСтараяРуб[color=red],[/color]ВалютаДоговораСтарая[color=red];[/color] [color=green]// для пересчета суммы в валюте взаиморасчетов[/color]
    
    [color=green]//Перем ТекущийДолг;[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ОбщРег[color=red],[/color] ОстаткиТМЦ[color=red],[/color] РезервыТМЦ[color=red],[/color] СписокПараметров[color=red];[/color] [color=green]// для показа остатков[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ТекстUSD[color=red],[/color] ТекстEUR[color=red],[/color] ТекстРуб[color=red],[/color] ТекстВалИтог[color=red],[/color] ТекстРубИтог[color=red],[/color] ТекстИтогВес[color=red],[/color] ТекстИтогОбъем[color=red];[/color]
    
    
    
    [color=green]//******************************************************************************[/color]
    [color=green]// [/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриИзмененииСклада[color=red]([/color][color=red])[/color]          
    Преф[color=red]=[/color]Сред[color=red]([/color]Склад[color=red].[/color]Наименование[color=red],[/color]Найти[color=red]([/color]Склад[color=red].[/color]Наименование[color=red],[/color][color=black]" "[/color][color=red])[/color][color=red]+[/color][color=black]1[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red]+[/color][color=black]"-"[/color][color=red];[/color]
    УстановитьНовыйНомер[color=red]([/color]Преф[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ПодобратьДоговор[color=red]([/color]Вал[color=red])[/color]
    ИмяДог[color=red]=[/color][color=black]""[/color][color=red];[/color]
    Спр [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Справочник.Договоры"[/color][color=red])[/color][color=red];[/color]
    Спр[color=red].[/color]ИспользоватьВладельца[color=red]([/color]Контрагент[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Лев[color=red]([/color]Вал[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"руб"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяДог[color=red]=[/color][color=black]"руб."[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> Лев[color=red]([/color]Вал[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"USD"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяДог[color=red]=[/color][color=black]"USD (ЦБ)"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> Лев[color=red]([/color]Вал[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"EUR"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИмяДог[color=red]=[/color][color=black]"EUR (ЦБ)"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    Спр[color=red].[/color]НайтиПоНаименованию[color=red]([/color]ИмяДог[color=red],[/color][color=black]1[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> Спр[color=red].[/color]ТекущийЭлемент[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span>
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> КурсДляВалюты[color=red]([/color]Вал[color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Вал[color=red].[/color]Наименование[color=red]=[/color][color=black]"USD (ЦБ)"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span> КурсДЦБ[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Вал[color=red].[/color]Наименование[color=red]=[/color][color=black]"USD (вн)"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> КурсДВН[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Вал[color=red].[/color]Наименование[color=red]=[/color][color=black]"EUR (ЦБ)"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> КурсЕЦБ[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Вал[color=red].[/color]Наименование[color=red]=[/color][color=black]"EUR (вн)"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> КурсЕВН[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Вал[color=red].[/color]Наименование[color=red]=[/color][color=black]"руб."[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span> [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]  
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span>
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриИзмененииФирмы[color=red]([/color][color=red])[/color]
    БанковскийСчет[color=red]=[/color]Фирма[color=red].[/color]Основнойсчет[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    
    
    
    
    
    
    
    [color=green]//******************************************************************************[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПечатьНаклейки[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/экспорт')">Экспорт</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ПечЕдиница[color=red],[/color] ПечНаименование[color=red],[/color] ПечРозн[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Таб[color=red],[/color]Исключить[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ТабТоваров[color=red],[/color] ДанныеДляПечати[color=red];[/color]
    СпрПН [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Справочник.ПечатьНаклеек"[/color][color=red])[/color][color=red];[/color]
    СпрН [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Справочник.Номенклатура"[/color][color=red])[/color][color=red];[/color]
    
    
    ТабТоваров [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    ТабТоваров[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Товар"[/color][color=red])[/color][color=red];[/color] 
    ТабТоваров[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Колво"[/color][color=red])[/color][color=red];[/color]
    ТабТоваров[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Страна"[/color][color=red])[/color][color=red];[/color]
    ТабТоваров[color=red].[/color]НоваяКолонка[color=red]([/color][color=black]"Штрихкод"[/color][color=red])[/color][color=red];[/color]
    
    
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span> 
    НомД[color=red]=[/color]СокрЛП[color=red]([/color]Номенклатура[color=red].[/color]Наименование[color=red])[/color][color=red];[/color] 
    НомА[color=red]=[/color]СокрЛП[color=red]([/color]Номенклатура[color=red].[/color]Артикул[color=red])[/color][color=red];[/color]
    Исключить[color=red]=[/color][color=black]0[/color][color=red];[/color]
    СпрПН[color=red].[/color]ВыбратьЭлементы[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">				Пока</span> СпрПН[color=red].[/color]ПолучитьЭлемент[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    ТекПН[color=red]=[/color]СокрЛП[color=red]([/color]СпрПН[color=red].[/color]Исключения[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span>  СпрН[color=red].[/color]НайтиПоНаименованию[color=red]([/color]ТекПН[color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>
    ТекН[color=red]=[/color]СпрН[color=red].[/color]ТекущийЭлемент[color=red]([/color][color=red])[/color][color=red];[/color] 
    [color=green]//ТекН_Наим=СокрЛП(ТекН.Наименование);[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">						Если</span> ТекН[color=red].[/color]ЭтоГруппа[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">								Если</span> Номенклатура[color=red].[/color]ПринадлежитГруппе[color=red]([/color]ТекН[color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span> 
    Исключить[color=red]=[/color][color=black]1[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/прервать')">									Прервать</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">								КонецЕсли</span>[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">						КонецЕсли</span>[color=red];[/color]
    
    [color=green]//Если НомД = ТекПН тогда [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> СокрЛП[color=red]([/color]Номенклатура[color=red].[/color]Наименование[color=red])[/color] [color=red]=[/color] СокрЛП[color=red]([/color]СпрПН[color=red].[/color]Исключения[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>
    Исключить[color=red]=[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/прервать')">						Прервать</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span> 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">				КонецЦикла</span>[color=red];[/color]	 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> Исключить[color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>
    ТабТоваров[color=red].[/color]НоваяСтрока[color=red]([/color][color=red])[/color][color=red];[/color]
    ТабТоваров[color=red].[/color]Товар    [color=red]=[/color] СокрЛП[color=red]([/color]Номенклатура[color=red].[/color]ПолнНаименование[color=red])[/color][color=red];[/color] 
    ТабТоваров[color=red].[/color]Колво    [color=red]=[/color] Количество[color=red];[/color]
    ТабТоваров[color=red].[/color]Страна   [color=red]=[/color] СокрЛП[color=red]([/color]Номенклатура[color=red].[/color]СтранаПроисхождения[color=red])[/color][color=red];[/color]
    ТабТоваров[color=red].[/color]Штрихкод [color=red]=[/color] СокрЛП[color=red]([/color]Номенклатура[color=red].[/color]БазоваяЕдиница[color=red].[/color]Штрихкод[color=red])[/color][color=red];[/color] 	
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    
    
    [color=green]// упакуем данные в список[/color]
    ДанныеДляПечати [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    ДанныеДляПечати[color=red].[/color]ДобавитьЗначение[color=red]([/color]ТабТоваров     [color=red],[/color] [color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    
    ОткрытьФорму[color=red]([/color][color=black]"Обработка.ПечатьНаклейки"[/color][color=red],[/color] ДанныеДляПечати[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПечатьНаклейки[/color]
    
    
    
    [color=green]//******************************************************************************[/color]
    [color=green]// [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> Подбор[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Контрагент[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">Предупреждение</span>[color=red]([/color][color=black]"Не выбран контрагент!"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    Параметры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Фирма[color=red],[/color]           [color=black]"Фирма"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]Склад[color=red],[/color]           [color=black]"Склад"[/color][color=red])[/color][color=red];[/color]
    [color=green]//Параметры.ДобавитьЗначение(Договор,         "Договор");[/color]
    [color=green]//Параметры.ДобавитьЗначение(0,               "ЕстьВидТМЦ");[/color]
    [color=green]//Параметры.ДобавитьЗначение("ИзСправочника", "ЦенаВподборе");[/color]
    [color=green]//Параметры.ДобавитьЗначение(ТипЦен,          "ТипЦен");      [/color]
    [color=green]//Параметры.ДобавитьЗначение(Валюта,          "Валюта");[/color]
    [color=green]//Параметры.ДобавитьЗначение(Курс,            "Курс");[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Выбран[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]"Дата"[/color][color=red],[/color]  [color=black]"ТипГраницы"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]ДатаДок[color=red],[/color] [color=black]"ЗначениеГраницы"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]"Позиция"[/color][color=red],[/color]         [color=black]"ТипГраницы"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]ПолучитьПозицию[color=red]([/color][color=red])[/color][color=red],[/color] [color=black]"ЗначениеГраницы"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    [color=green]//[/color]
    [color=green]//Параметры.ДобавитьЗначение("Подбор номенклатуры в документ " + ПредставлениеВида() + " № " + НомерДок, "Заголовок");[/color]
    
    ОткрытьПодбор[color=red]([/color][color=black]"Справочник.Номенклатура"[/color][color=red],[/color][color=black]"ПоСкладам"[/color][color=red],[/color]Параметры[color=red],[/color][color=black]1[/color][color=red])[/color]	
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    
    [color=green]//******************************************************************************[/color]
    [color=green]// [/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПроверкаЦены[color=red]([/color][color=red])[/color]          
    Таб[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"Цены"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    НомСтроки[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    НомСтроки[color=red]=[/color]НомСтроки[color=red]+[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Цена[color=red]<[/color][color=red]>[/color]глПолучитьЦену[color=red]([/color]Номенклатура[color=red],[/color]Номенклатура[color=red].[/color]БазоваяЦена[color=red],[/color]ДатаДок[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка1"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка2"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    Таб[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]   
    Таб[color=red].[/color]Показать[color=red]([/color][color=black]"Отчет по ценам"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>  
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПересчетИтогов[color=red]([/color][color=red])[/color]
    
    SumUSD[color=red]=[/color][color=black]0[/color][color=red];[/color]
    SumEUR[color=red]=[/color][color=black]0[/color][color=red];[/color]
    SumRub[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ItogRub[color=red]=[/color][color=black]0[/color][color=red];[/color]
    
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Лев[color=red]([/color]Валюта[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"USD"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    SumUSD[color=red]=[/color]SumUSD[color=red]+[/color]сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> Лев[color=red]([/color]Валюта[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"EUR"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    SumEUR[color=red]=[/color]SumEUR[color=red]+[/color]сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">		ИначеЕсли</span> Лев[color=red]([/color]Валюта[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"руб"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    SumRub[color=red]=[/color]SumRub[color=red]+[/color]сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Валюта[color=red].[/color]Наименование[color=red]=[/color][color=black]"руб."[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ItogRub[color=red]=[/color]ItogRub[color=red]+[/color]сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    ЦенаС [color=red]=[/color] Окр[color=red]([/color]Цена[color=red]-[/color]Скидка[color=red].[/color]Процент[color=red]/[/color][color=black]100[/color][color=red]*[/color]Цена[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ЦенаСР [color=red]=[/color] Окр[color=red]([/color]глПересчет[color=red]([/color]ЦенаС[color=red],[/color]Валюта[color=red],[/color]КурсДляВалюты[color=red]([/color]Валюта[color=red])[/color][color=red],[/color]ГлРубли[color=red],[/color]ДатаДок[color=red])[/color][color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ItogRub[color=red]=[/color]ItogRub[color=red]+[/color]ЦенаСР[color=red]*[/color]Количество[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> [color=red]([/color]Вес[color=red]=[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Вес[color=red]<[/color][color=red]>[/color]Номенклатура[color=red].[/color]ВесЕд[color=red]*[/color]Количество[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НовыйВес[color=red]=[/color]Номенклатура[color=red].[/color]ВесЕд[color=red]*[/color]Количество[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> НовыйВес[color=red]<[/color][color=red]>[/color]Вес <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Вес[color=red]=[/color]НовыйВес[color=red];[/color]
    [color=green]//Сообщить("Изменился вес у "+Номенклатура);[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]  
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> [color=red]([/color]Объем[color=red]=[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Объем[color=red]<[/color][color=red]>[/color]Номенклатура[color=red].[/color]ОбъемЕд[color=red]*[/color]Количество[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НовыйОбъем[color=red]=[/color]Номенклатура[color=red].[/color]ОбъемЕд[color=red]*[/color]Количество[color=red];[/color]          
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> НовыйОбъем[color=red]<[/color][color=red]>[/color]Объем <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Объем[color=red]=[/color]НовыйОбъем[color=red];[/color]
    [color=green]//Сообщить("Изменился объем у "+Номенклатура);[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    ItogRub[color=red]=[/color]ItogRub[color=red]+[/color]СуммаДоп[color=red];[/color]
    SumRub[color=red]=[/color]SumRub[color=red]+[/color]СуммаДоп[color=red];[/color]
    ТекстUSD[color=red]=[/color]SumUSD[color=red];[/color]
    ТекстEUR[color=red]=[/color]SumEUR[color=red];[/color]
    ТекстРуб[color=red]=[/color]SumRub[color=red];[/color]
    ТекстРубИтог[color=red]=[/color]ItogRub[color=red];[/color]  
    
    ТекстИтогВес[color=red]=[/color]Итог[color=red]([/color][color=black]"Вес"[/color][color=red])[/color][color=red];[/color]
    ТекстИтогОбъем[color=red]=[/color]Итог[color=red]([/color][color=black]"Объем"[/color][color=red])[/color][color=red];[/color]
    
    СтараяСумма[color=red]=[/color]СуммаВзаиморасчетов[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтараяСумма[color=red]<[/color][color=red]>[/color]ItogRub <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаВзаиморасчетов[color=red]=[/color]ItogRub[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]      
    
    СтараяСумма[color=red]=[/color]СуммаUSD[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтараяСумма[color=red]<[/color][color=red]>[/color]SumUSD <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаUSD[color=red]=[/color]SumUSD[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]      
    
    СтараяСумма[color=red]=[/color]СуммаEUR[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтараяСумма[color=red]<[/color][color=red]>[/color]SumEUR <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаEUR[color=red]=[/color]SumEUR[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]      
    
    СтараяСумма[color=red]=[/color]СуммаРуб[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> СтараяСумма[color=red]<[/color][color=red]>[/color]SumRub <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаРуб[color=red]=[/color]SumRub[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]      
    
    КонецПроцедуры	[color=green]//ПересчетИтогов()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// УправлениеВидимостью()[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Делает видимыми или невидимыми колонки НП и НДС в зависимости от флагов [/color]
    [color=green]//  "УчитыватьНП" и "УчитыватьНДС"[/color]
    [color=green]//  Делает невидимой колонку "Скидка", если скидка не выбрана[/color]
    [color=green]//  Делает невидимой колонку всего, если все налоги в сумме[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> УправлениеВидимостью[color=red]([/color][color=red])[/color]
    
    
    
    Форма[color=red].[/color]СуммаНП	[color=red].[/color]Видимость[color=red]([/color]УчитыватьНП[color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]СтавкаНП	[color=red].[/color]Видимость[color=red]([/color]УчитыватьНП[color=red])[/color][color=red];[/color]
    
    Форма[color=red].[/color]СуммаНДС	[color=red].[/color]Видимость[color=red]([/color]УчитыватьНДС[color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]СтавкаНДС	[color=red].[/color]Видимость[color=red]([/color]УчитыватьНДС[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color][color=red]([/color]СуммаВклНП [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]УчитыватьНП[color=red]=[/color][color=black]0[/color][color=red])[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color][color=red]([/color]СуммаВклНДС [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]УчитыватьНДС[color=red]=[/color][color=black]0[/color][color=red])[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]Всего[color=red].[/color]Видимость[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Форма[color=red].[/color]Всего[color=red].[/color]Видимость[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]    
    
    Форма[color=red].[/color]СуммаНДС[color=red].[/color]Заголовок[color=red]([/color][color=red]?[/color][color=red]([/color]СуммаВклНДС[color=red]=[/color][color=black]1[/color][color=red],[/color][color=black]"в т.ч. НДС"[/color][color=red],[/color][color=black]"Сумма НДС"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]СуммаНП[color=red].[/color]Заголовок[color=red]([/color][color=red]?[/color][color=red]([/color]СуммаВклНП[color=red]=[/color][color=black]1[/color][color=red],[/color][color=black]"в т.ч. НП"[/color][color=red],[/color][color=black]"Сумма НП"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    
    Форма[color=red].[/color]СуммаВклНДСфл[color=red].[/color]Видимость[color=red]([/color]УчитыватьНДСфл[color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]СуммаВклНПфл[color=red].[/color]Видимость[color=red]([/color]УчитыватьНПфл[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//УправлениеВидимостью()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ОбновитьНадписи()[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Обновляет текст информационных надписей в форме документа[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбновитьНадписи[color=red]([/color][color=red])[/color]    
    
    
    УправлениеВидимостью[color=red]([/color][color=red])[/color][color=red];[/color]
    ПересчетИтогов[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//ОбновитьНадписи()[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбработкаЦен[color=red]([/color][color=red])[/color]
    УчитыватьНДС[color=red]=[/color]УчитыватьНДСфл[color=red];[/color]
    СуммаВклНДС[color=red]=[/color]СуммаВклНДСфл[color=red];[/color]
    УчитыватьНП[color=red]=[/color]УчитыватьНПфл[color=red];[/color]
    СуммаВклНП[color=red]=[/color]СуммаВклНПфл[color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    глРасчетНалога[color=red]([/color]Контекст[color=red],[/color][color=black]"НП"[/color][color=red])[/color][color=red];[/color]
    глРасчетНалога[color=red]([/color]Контекст[color=red],[/color][color=black]"НДС"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    УправлениеВидимостью[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры	</span>
    
    
    
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ИсторияСкидок[color=red]([/color][color=red])[/color]   
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Запрос[color=red],[/color] ТекстЗапроса[color=red],[/color] Таб[color=red];[/color]
    
    Таб [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"Скидки"[/color][color=red])[/color][color=red];[/color]
    
    
    ВыбКонтр[color=red]=[/color]Контрагент[color=red];[/color]
    ВыбНоменклатура[color=red]=[/color]Номенклатура[color=red];[/color]	
    СкидкаНД[color=red]=[/color]Скидка[color=red];[/color]
    ВыбНачПериода[color=red]=[/color][color=black]"01.01.2003"[/color][color=red];[/color]
    ВыбКонПериода[color=red]=[/color]ТекущаяДата[color=red]([/color][color=red])[/color][color=red];[/color]
    
    Запрос [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Запрос"[/color][color=red])[/color][color=red];[/color]
    ТекстЗапроса [color=red]=[/color] 
    [color=black]"//{{ЗАПРОС(Сформировать)[/color]
    [color=black]	|Период с ВыбНачПериода по ВыбКонПериода;[/color]
    [color=black]	|ДатаДокумента = Документ.ПакетПродаж.ДатаДок;[/color]
    [color=black]	|НомерДокумента = Документ.ПакетПродаж.НомерДок;[/color]
    [color=black]	|Контрагент = Документ.ПакетПродаж.Контрагент;[/color]
    [color=black]	|Док = Документ.ПакетПродаж.ТекущийДокумент;[/color]
    [color=black]	|Номенклатура = Документ.ПакетПродаж.Номенклатура;[/color]
    [color=black]	|СкидкаЗ = Документ.ПакетПродаж.Скидка;[/color]
    [color=black]	|Группировка СкидкаЗ все ВошедшиеВЗапрос;[/color]
    [color=black]	|Группировка ДатаДокумента;[/color]
    [color=black]//	|Группировка НомерДокумента;  [/color]
    [color=black]	|Группировка Док;[/color]
    [color=black]	|Условие(Контрагент = ВыбКонтр);[/color]
    [color=black]	|Условие(Номенклатура в ВыбНоменклатура); [/color]
    [color=black]	|"[/color][color=green]//}}ЗАПРОС[/color]
    [color=brown];[/color]
    [color=green]// Если ошибка в запросе, то выход из процедуры[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color]ТекстЗапроса[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    ТЗНМ[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    Запрос[color=red].[/color]Выгрузить[color=red]([/color]ТЗНМ[color=red])[/color][color=red];[/color] 
    ТЗНМ[color=red].[/color]Сортировать[color=red]([/color][color=black]"ДатаДокумента"[/color][color=red])[/color][color=red];[/color]
    
    ТЗН[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    Запрос[color=red].[/color]Выгрузить[color=red]([/color]ТЗН[color=red])[/color][color=red];[/color]
    ТЗН[color=red].[/color]Свернуть[color=red]([/color][color=black]"СкидкаЗ"[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]
    ТЗН[color=red].[/color]УдалитьСтроку[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color] 
    ВсеСкидки[color=red]=[/color][color=black]""[/color][color=red];[/color]
    ТЗН[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ТЗН[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    Скидка1[color=red]=[/color]Строка[color=red]([/color]ТЗН[color=red].[/color]СкидкаЗ[color=red])[/color][color=red];[/color]
    ВсеСкидки[color=red]=[/color]ВсеСкидки [color=red]+[/color] [color=black]"   "[/color] [color=red]+[/color] Скидка1[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    
    ТЗНМ[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> ТЗНМ[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]ТЗНМ[color=red].[/color]Док[color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]             
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]   
    
    Таб[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]                     
    Таб[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=black]100[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Показать[color=red]([/color][color=black]""[/color][color=red])[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> 
    
    
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПересчетТаблЧасти(Колонка)[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПересчетТаблЧасти[color=red]([/color]Колонка[color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ВремКоэфф[color=red],[/color] ВремЦена[color=red],[/color] НоваяНоменклатура[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ЕстьСкидка[color=red];[/color]    [color=green]// 1 - в документе есть скидка, 0 - скидки нет[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ПроцентСкидки[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ЕстьНДС[color=red],[/color] ЕстьНП[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ЦенаЦены[color=red],[/color] ЕдЦены[color=red],[/color] ВалютаЦены[color=red];[/color]
    
    ПроцентСкидки[color=red]=[/color]Скидка[color=red].[/color]Процент[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Колонка [color=red]=[/color] [color=black]"Номенклатура"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]//Форма.Текущая[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]Номенклатура[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// Очистили Номенклатуру[/color]
    Единица 		[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Коэффициент 	[color=red]=[/color] [color=black]0[/color][color=red];[/color]                  
    Цена			[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Количество 		[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Сумма 			[color=red]=[/color] [color=black]0[/color][color=red];[/color]     
    СуммаНДС		[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    СуммаНП			[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Вес		 		[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Объем 			[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    [color=green]// Определим, поменяли ли Номенклатуру?[/color]
    НоваяНоменклатура [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]Единица[color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НоваяНоменклатура [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window

    Вложения:

  20. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    копируешь проц печать в печать2(пЗал) записываешь её выше проц печать

    Далее в проц печать вставляешь код
    ТаблицаДокумента.Свернуть("ЗалХранения")
    ТабДок=ТаблицаДокумента
    ТабДок.ВыбратьСтроки()
    Пока ТабДок.ПолучитьСтроку()=1 Цикл
    Печать2(Табок.ЗалХранения)
    КонецЦикла

    перед
    // валютная заявка Если (В_накл = 1) и (К_В_Н > 0) Тогда

    В проц Печать2(пЗал)
    В цикле
    Пока ПолучитьСтроку() = 1 Цикл
    добавь
    Если ЗалХранения<>пЗал Тогда
    продолжить;
    КонецЕсли

    Ну и в таблице нужно изменить вывод вместо склада ЗалХранения
    Возможно нужно скопировать Таблицу в таблицу2 и в проц Печать2 использовать Таблицу2 и в ней поменять склад на зал

Поделиться этой страницей