7.7 Печать текущей строки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Almius, 7 дек 2011.

  1. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Есть документ из которого необходимо напечатать только текущую строку. А не все строки.
    подскажите пожалуйста как сделать. Это пример печати всех строк.
    Код:
    Процедура ПечатьНакладная() 
    Таб=СоздатьОбъект("Таблица");
    ТабЗн=СоздатьОбъект("ТаблицаЗначений"); 
    ВыгрузитьТабличнуюЧасть(ТабЗн,);
    Таб.ИсходнаяТаблица("Таблица1");
    Таб.ВывестиСекцию("Секция_1");
    ТабЗн.ВыбратьСтроки (); 
    Пока ТабЗн.ПолучитьСтроку () = 1 Цикл
    Таб.ВывестиСекцию ("Секция_8");
    КонецЦикла;	 
    Таб.ВывестиСекцию("Секция_3");
    Таб.Опции(0,0,0,0,"ОпцииПечатьТаблица1");
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Накладная","");
    КонецПроцедуры
    
    
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Удалить отмеченные строки:
    Код:
    Процедура ПечатьНакладная() 
    Таб=СоздатьОбъект("Таблица");
    ТабЗн=СоздатьОбъект("ТаблицаЗначений"); 
    ВыгрузитьТабличнуюЧасть(ТабЗн,); // Эту
    Таб.ИсходнаяТаблица("Таблица1");
    Таб.ВывестиСекцию("Секция_1");
    ТабЗн.ВыбратьСтроки (); 
    Пока ТабЗн.ПолучитьСтроку () = 1 Цикл  // Эту
    Таб.ВывестиСекцию ("Секция_8");
    КонецЦикла;                                          //  И эту
    Таб.ВывестиСекцию("Секция_3");
    Таб.Опции(0,0,0,0,"ОпцииПечатьТаблица1");
    Таб.ТолькоПросмотр(0);
    Таб.Показать("Накладная","");
    КонецПроцедуры
    
    А в макете печатной формы в "Секция_8" исправить формулы получения значений (по идее просто поудалять "ТабЗн.", но может еще чего).
  3. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Спасибо, вопрос закрыт.

Поделиться этой страницей