7.7 печать по ширине странице

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем denn-m, 20 окт 2010.

  1. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! Как сделать в 1с 7.7 по умолчанию "печать по ширине странице"?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ПараметрыСтраницы(<Ориентация>,<Масштаб>,<РежимПечатиКопий>,<ПолеСлева>,<ПолеСправа>,<ПолеСверху>,<ПолеСнизу>,<КолонтитулСверху>,<КолонтитулСнизу>,<Автомасштаб>,<ФлагЧБПечати>,<ИмяПринтера>)
  3. TopicStarter Overlay
    denn-m
    Offline

    denn-m Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    55
    Симпатии:
    0
    Баллы:
    26
    подскажите, где в этом тексте изменить чтобы печать стояла "по ширине страницы"?
    Код:
    Процедура ПечатьАкт()
    
    Таб = СоздатьОбъект("Таблица");
    ИмяФайлаПечатнойФормы = КаталогИБ()+"ExtForms\PrnForms\1cbakt.mxl";
    Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
    Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);
    Иначе
    Таб.ИсходнаяТаблица("Таблица");
    КонецЕсли;
    
    АдресТелефон = "Адрес: "+глПредставлениеАдреса(Константа.АдресОрганизации);;
    Таб.ВывестиСекцию("Шапка");
    
    Ном 		= 0;
    ИтогСумма	= 0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Если (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.Услуга) и
    (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.ПосредническаяУслуга)и
    (Номенклатура.ТипНоменклатуры<>Перечисление.ТипыНоменклатуры.УслугаЕНВД) Тогда
    Продолжить;
    КонецЕсли;
    Ном = Ном + 1;
    Наименование = ?(ПустаяСтрока(Номенклатура.ПолнНаименование)=1, Номенклатура.Наименование, Номенклатура.ПолнНаименование);
    Таб.ВывестиСекцию("Строка");
    ИтогСумма	= ИтогСумма + Сумма;
    Состояние("Выведено строк: " + НомерСтроки);
    КонецЦикла;
    
    Таб.ВывестиСекцию("Итоги");
    Таб.ВывестиСекцию("Подвал");
    
    Таб.Опции(0,0,0,0,"ОпцииПечатиАкта","ОкноАкта"); 
    Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);    
    Таб.КоличествоЭкземпляров(2);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать акта");
    
    КонецПроцедуры // ПечатьАкт()
    
    
    [warn=Внимание!]
    Пользуемся тегами
    [/warn]
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    У вас уже стоит - 10й параметр (автомасштаб) метода ПараметрыСтраницы

Поделиться этой страницей