7.7 Печать Номенклатуры со ШК сверху вниз а не слева направо

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем YuriyK, 4 мар 2015.

  1. TopicStarter Overlay
    YuriyK
    Offline

    YuriyK

    Регистрация:
    11 окт 2010
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Подскажите как вывести на печатать номенклатуру со ШК на лист сверху вниз, а не слева на право, сейчас выводит 20 строк потом к ним 20 строк вправо, посмотрите пожалуйста вот код:
    Код:
    Процедура Сформировать(ТаблицаТоваров, Устройство, Столбцов)
    
       //  Создание Таблицы для выходного отчета
       Таб   = СоздатьОбъект("Таблица");
       Таб.ИсходнаяТаблица("Этикетка");
     
       Если ТаблицаТоваров.КоличествоСтрок() = 1 Тогда
        ТаблицаТоваров.ПолучитьСтрокуПоНомеру(1);
     
         Если ПроверитьШтрихкод(ТаблицаТоваров.Штрихкод) = 0 Тогда
           Предупреждение("У товара """ + ТаблицаТоваров.Товар + """ штрихкод не задан или имеет неверный формат!");
           Возврат;
         Иначе 
           Таб.ВывестиСекцию("ГорТело|ВертТело");
         КонецЕсли;
       
       Иначе
         ВсегоКолонок = 2;
         ВсегоСтрок  = 20;
       
         ТекКолонка = 1;
         ТекСтрока  = 1;
       
         ТаблицаТоваров.ВыбратьСтроки();
         Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
           Если ПроверитьШтрихкод(ТаблицаТоваров.Штрихкод) = 0 Тогда
             Сообщить("У товара """ + ТаблицаТоваров.Товар + """ штрихкод не задан или имеет неверный формат!");
           Иначе
             Если ТекСтрока > ВсегоСтрок Тогда 
               ТекСтрока  = 1;
               ТекКолонка  = ТекКолонка + 1;
             КонецЕсли;
           
             Если ТекКолонка > ВсегоКолонок Тогда
               ТекКолонка = 1;
               Таб.НоваяСтраница();
             КонецЕсли;
           
           
             Если ТекКолонка = 1 Тогда
               //Таб.Область("R1C1:R20C1");
               Таб.ВывестиСекцию("ГорТело|ВертТело");
             Иначе
               Таб.НоваяКолонка();
               //Таб.Область("R1C2:R20C2");
               Таб.ПрисоединитьСекцию("ГорТело|ВертТело");
             КонецЕсли;
           
             ТекСтрока  = ТекСтрока + 1;
           КонецЕсли;
         КонецЦикла;
       
       КонецЕсли;
     
       //Вызов выходного отчета в окно просмотра и редактирования.
       Таб.Опции(0, 0, 0, 0, "ПечатьЭтикетки", "ПечатьЭтикетки");
       Если Устройство="экран" Тогда
         Таб.ТолькоПросмотр(1);
         Таб.Показать("Этикетка", "");
       Иначе
         Таб.Напечатать(0);
       КонецЕсли;
     
    КонецПроцедуры
    Последнее редактирование модератором: 4 мар 2015
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
        ТаблицаТоваров.ВыбратьСтроки();
        Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
            Если ПроверитьШтрихкод(ТаблицаТоваров.Штрихкод) = 0 Тогда
                Сообщить("У товара """ + ТаблицаТоваров.Товар + """ штрихкод не задан или имеет неверный формат!");
            Иначе
                Если ТекСтрока > ВсегоСтрок Тогда
                    ТекСтрока = 1;
                    ТекКолонка = 1;
                    Таб.НоваяСтраница();
                КонецЕсли;
               
                Если ТекКолонка > ВсегоКолонок Тогда
                    ТекКолонка = 1;
                КонецЕсли;
               
                Если ТекКолонка = 1 Тогда
                    Таб.ВывестиСекцию("ГорТело|ВертТело");
                    ТекСтрока = ТекСтрока + 1;
                Иначе
                    Таб.ПрисоединитьСекцию("ГорТело|ВертТело");
                    ТекКолонка=ТекКолонка+1;
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
    
  3. TopicStarter Overlay
    YuriyK
    Offline

    YuriyK

    Регистрация:
    11 окт 2010
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Печатает в одну колонку на всех страницах, колонки не плюсует.
    --- Объединение сообщений, 4 мар 2015 ---
    Иначе
    Таб.ПрисоединитьСекцию("ГорТело|ВертТело");
    ТекКолонка=ТекКолонка+1;
    КонецЕсли;

    В это условие не заходит
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    пардон. конечно не заходит
    Код:
               Если ТекКолонка = 1 Тогда
                    Таб.ВывестиСекцию("ГорТело|ВертТело");
                    ТекСтрока = ТекСтрока + 1;
                Иначе
                    Таб.ПрисоединитьСекцию("ГорТело|ВертТело");               
                КонецЕсли;
    ТекКолонка=ТекКолонка+1;
    

Поделиться этой страницей