Печать логотипа на FPrint-22 из УТ-11

Тема в разделе "Торговое оборудование в 1С", создана пользователем d_control, 16 май 2013.

  1. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    Добрый день, специалисты 1c-pro.ru.

    Конфигурация: УТ 11.0.9.15.
    Платформа: 8.2.18.61

    Имеется принтер документов ЕНВД FPrint-22.

    Если зайти через АТОЛовский драйвер на закладку "Графика", указать там путь к файлу с картинкой и нажать на кнопку "Печать граф.файла", то на принтере документов будет напечатана картинка из файла.

    Посмотрел в описании драйвера и нашел метод PrintBitmapFromFile(), который и выводит на печать картинку из файла.

    Вот как этим методом воспользоваться из 1Ски?
    Среди методов компоненты "ATOL_KKM_1C" подобного метода не нахожу.
    Неужели из 1Ски нельзя воспользоваться функцией печати логотипа на данном аппарате?

    Спасибо за внимание!
  2. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    в стандартной обработке АТОЛ: Фискальные регистраторы нет печати картинок,
    надо дописывать обработку.
  3. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    Благодарю за ответ, tsd.

    Имеется ввиду что нужно дописывать внешнюю компоненту AddIn.ATOL_KKM_1C?
  4. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    если точнее то дописывать обработку АТОЛ: Фискальные регистраторы.
  5. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    Вот я и хотел в модуле "ПодключаемоеОборудованиеАтолФискальныеРегистраторы"
    в процедуре "ОткрытьЧек" после успешного открытия чека на FPrint-22 вызвать метод для печати картинки.

    В том то и вопрос, как его вызвать?

    Вызов открытия чека производится методом:
    ОбъектДрайвера.ОткрытьЧек(...)
    Печать фискальной строки:
    ОбъектДрайвера.НапечататьФискСтроку(...)

    А вот как сказать ОбъектуДрайвера что нужно напечатать картинку из файла?
    В документации именно для Atol_KKM_1C такого метода нет.
    А в общем драйвере Атол такой метод есть...
  6. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    видимо документация устаревшая, скиньте мыло отправлю FprnM_Pm_0.pdf
  7. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    d_control sobaka mail.ru
  8. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    да вроде свежую документацию смотрю.
    Там с 204 страницы начинается описание стандарта по работе с драйвером через 1Ску.

    Там нет метода для печати картинки.. (
  9. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    скинул. см.стр. 145
  10. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    Благодарю, tsd.

    Да, такую инструкцию я скачивал с сайта Атол.
    Но вот как из 1Ски воспользоваться методом PrintBitmapFromFile?
    Я так понимаю что это метод основного драйвера АТОЛ, а 1С подключается к специальной атоловской dll разработанной под стандарты 1Ски.

    Когда пробую вызвать такой метод:

    ОбъектДрайвера.PrintBitmapFromFile(..) то получаю в ответ, что такой метод не существует...

    Может каким-то образом нужно подключиться к основному драйверу и работать через него?
  11. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Не уверен что у объекта Вы можете получить этот метод, скорее всего он не опубликован, посему даже внешней компонентой Вы не вытяните этот метод.
  12. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    ECR.Password = "30";
    ECR.Mode = 1;
    Если ECR.SetMode() <> 0 тогда
    Возврат;
    КонецЕсли;
    ECR.FileName="C:\Program Files\ATOL DTO6_2013_04_19\Drivers\Data\Pics\АТОЛ 112x200.bmp";
    ECR.PrintBitmapFromFile();

    проверил работает.
  13. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    а можно строчки в которых ECR создается?
  14. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    в УТ11 подключается внешняя компонента вот так:

    Код:
    ProgID = "AddIn.ATOL_KKM_1C";
    ПодключитьВнешнююКомпоненту(ProgID);
    ОбъектДрайвера = Новый (ProgID);
    и у ОбъектДрайвера нет метода PrintBitmapFromFile
  15. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    Код:
    Попытка
    ЗагрузитьВнешнююКомпоненту("FPRNM1C.dll");
    ECR = Новый("AddIn.FprnM45");
    исключение
    Предупреждение("Ошибка загрузки внешней компоненты FPRNM1C.dll");
    ЗавершитьРаботуСистемы();
    конецпопытки;
    
    Код:
    ECR.DeviceEnabled = 1;
    Если ECR.ResultCode <> 0 тогда
    Возврат;
    КонецЕсли;
    
    Если ECR.GetStatus() <> 0 тогда
    Возврат;
    КонецЕсли;
    
    Если ECR.CheckState <> 0 тогда
    Если ECR.CancelCheck() <> 0 тогда
    Возврат;
    КонецЕсли;
    КонецЕсли;
    
    
    ECR.Password = "30";  
    ECR.Mode = 1;
    Если ECR.SetMode() <> 0 тогда
    Возврат;
    КонецЕсли;
    
    
    ECR.FileName="C:\Program Files\ATOL DTO6_2013_04_19\Drivers\Data\Pics\АТОЛ 112x200.bmp";
    ECR.PrintBitmapFromFile();  
    версия драйвера 6.18.
  16. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    ух ты.. здОрово!
    А в какая вас конфигурация?

    Хорошо, попробую так...
    Интересно, нужно ли будет все методы по работе с кассой переписывать...
    или же можно будет параллельно подключить компоненту по вашему примеру и в нужном месте только картинку через нее распечатать...
  17. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    попробуй так


    Код:
    ПрогИД = "AddIn.FprnM45";
    ПодключитьВнешнююКомпоненту(ПрогИД);
    ECR = Новый (ПрогИД);
    
  18. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    вернее так

    Код:
    ПрогИД = "AddIn.FprnM45";
    ПодключитьВнешнююКомпоненту(ПрогИД);
    ОбъектДрайвера = Новый (ПрогИД);
  19. TopicStarter Overlay
    d_control
    Offline

    d_control Опытный в 1С

    Регистрация:
    21 дек 2011
    Сообщения:
    511
    Симпатии:
    0
    Баллы:
    26
    ок, попробую.
    Думаю что придется переписывать все методы по подключению ККМ, печати чеков, открытию/закрытию смены и т.п...
  20. tsd
    Offline

    tsd Опытный в 1С

    Регистрация:
    19 авг 2008
    Сообщения:
    68
    Симпатии:
    2
    Баллы:
    29
    скорее всего так.

Поделиться этой страницей