7.7 Печать карточек

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Almius, 15 май 2008.

  1. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Подскажите кто сталкивался с ведением складских карточек в электронном виде.
    У меня появилась необходимость печатать карточки складского учета.
    както немного коряво постараюсь объяснить что и как.

    Есть два документа Приход ТМЦ и Расход ТМЦ которые формируют проводки на счет 20.207.2 у этого счета есть 3 субконто Материалы, Сотрудники, Каталожный номер.
    Единственное что пришло в голову написать следующую обработку:
    Но это не закрывает мой вопрос подскажите как мне достать документ который сформировал проводку и получить из него данные: дату проводки, номер документа, контрагента.
    Код:
    Процедура Карточки()  
    Таб2=СоздатьОбъект("Таблица"); 
    Таб2.ИсходнаяТаблица("Таблица2");
    Таб2.ВывестиСекцию("Секция_1");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги"); 
    Ит.ПериодД(Дата1,Дата2);    
    Ит.ИспользоватьСубконто(ВидыСубконто.Материалы);
    Ит.ВыполнитьЗапрос(Дата1,Дата2,СчетПоКоду ("20.207.2"));
    Ит.ВыбратьСубконто(,,,,,"Код");
    Пока Ит.ПолучитьСубконто(1)=1 Цикл  
    Если Ит.СНД(3)+Ит.ДО(3)+Ит.КО(3)+Ит.СКД(3)<>0 Тогда 
    Таб2.ВывестиСекцию("Секция_4");
    Таб2.ВывестиСекцию("Секция_2");  
    Таб2.ВывестиСекцию("Секция_3"); 
    КонецЕсли;
    КонецЦикла;
    Таб2.Опции(0,0,0,,"ОпцииПечатьТаблица2");
    Таб2.ТолькоПросмотр(0);
    Таб2.Показать("Таблица2","");
    КонецПроцедуры
    
    Заранее спасибо всем кто помог. Посмотреть вложение 915

    Вложения:

    • Карт_C.ert
      Размер файла:
      19,5 КБ
      Просмотров:
      82
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Ит.ВыполнитьЗапрос(Дата1,Дата2,СчетПоКоду ("20.207.2"),,,,"Операция","К"); :unsure:
  3. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Спасибо за ответ. Но понимание как то не пришло.

Поделиться этой страницей