8.х Печать *.jpg вместе с ТОРГ-12

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ACID, 29 май 2008.

  1. TopicStarter Overlay
    ACID
    Offline

    ACID

    Регистрация:
    29 май 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Господа, тут такая задача. :unsure:
    При печати накладной в УТ10.3.3.3 надо чтоб автоматом за ней на печать выползал сертификат качества(например отсканированный жепег). А так как сертификаты чатсо меняются, удобнее было бы их закреплять за своим товаром. Я решил их закреплять как картинку в номенклатуре и печатать все сертификаты товаров из таблчасти. Но вот код у меня чего родиться не может. В литературе 1с очень скудная информация о возможностях печати.

    Спасибо!
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Если ничего не делать - ничего и не родиться...
  3. tosia
    Offline

    tosia

    Регистрация:
    20 май 2008
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Была проблема распчатать картинку, прикрепленную к документу. Решение нашлось, не самое красивое, но вот такое:

    Код:
                          ТабДок = Новый ТабличныйДокумент;
    Рис=ТабДок.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
    Индекс=ТабДок.Рисунки.Индекс(Рис);
    ТабДок.Рисунки[Индекс].Картинка =  ФормаДокОб.ЭлементыФормы.ПолеКартинки.Картинка;
    ТабДок.Рисунки[Индекс].Расположить(ТабДок.Область("R1C1:R134C16"));
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.АвтоМасштаб = Ложь;
    ТабДок.МасштабПечати = 70;
    ТабДок.Показать();
    
  4. TopicStarter Overlay
    ACID
    Offline

    ACID

    Регистрация:
    29 май 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Спасибо за внимание!
    Решение пришло во сне :unsure:


    Код:
                         
    Процедура ПечатьСертификата()
    
    Для каждого ТекущаяСтрока из ЭтотОбъект.Товары Цикл 
    Если НЕ ТекущаяСтрока = Неопределено
    И НЕ ТекущаяСтрока.Номенклатура.ЭтоГруппа
    И НЕ ТекущаяСтрока.Номенклатура.ОсновноеИзображение.Пустая() Тогда
    Картинка =           ТекущаяСтрока.Номенклатура.ОсновноеИзображение.Хранилище.Получить(); // получил
    Иначе
    Продолжить;	
    КонецЕсли;
    
    Таб = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("ФотоСертификат");
    ОблИзобр = Макет.ПолучитьОбласть("Изобр");
    ОблИзобр.Рисунки.D1.Картинка=Картинка;
    Таб.Вывести(ОблИзобр); 
    НапечататьДокумент(Таб);	
    КонецЦикла;
    КонецПроцедуры
    
    
    
  5. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    А что делать если для разных позиций один и тот же сертификат?
  6. TopicStarter Overlay
    ACID
    Offline

    ACID

    Регистрация:
    29 май 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    также в качестве изображения поставить такую же картинку. тогда на печать выйдет два одинаковых сертификата.

    Чтобы этого избежать, нужно проверить на вхождение в список уже напечатаных.
  7. FLoYD777
    Offline

    FLoYD777 Опытный в 1С

    Регистрация:
    4 май 2009
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Подскажите пжлста, у меня похожая задача... в УТ 10.3 необходимо сделать следующее:
    Есть переменная(НамОб) в которой хранится название номенклатуры.
    Необходимо по этой номенклатуре вывести на экран все имеющиеся изображения кроме "основного изображения" и при необходимости пустить их на печать.

    Никак у меня не получается разобраться, как обращатся к этому списку картинок.
    Насколько я понимаю они хранятся в справочнике ХранилищеДополнительнойИнформации.
    Я думал нужно брать реквизит "Объект", как то ограничивать его по реквизиту "ВидДанных" (ставить как то ограничение: тип данных "Картинка") и так же ставить отбор по номенклатере и указывать отбор по имеющейся переменной(НамОб). Заранее благодарен за помощЪ!!!=)
  8. Waldemar
    Offline

    Waldemar

    Регистрация:
    28 янв 2010
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Приветствую. У меня тоже задача, связанная с основным изображением номенклатуры, но мне требуется наоборот - загрузить изображение для номенклатуры из кода. Подскажите, как такое сделать?
  9. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Смотрите в типовых - там все есть.

Поделиться этой страницей