8.х Печать документов с префиксом

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ComOK, 8 сен 2008.

  1. TopicStarter Overlay
    ComOK
    Offline

    ComOK Опытный в 1С

    Регистрация:
    11 ноя 2007
    Сообщения:
    56
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    В Бухгалтерии 1.6.9.4 возникла следующая проблема. В базе ведется учет по одной организации. У этой организации установлен префикс. При создании документа к номеру добавляется префикс,но при печати префикс отсекается. Как сделать так, чтобы при печати префикс выводился?
    Спасибо!
  2. hot
    Offline

    hot

    Регистрация:
    29 май 2008
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Думаю что, типовым способом не сделать. Это надо переписывать код.

    В УПП это производиться в общем модуле общего назначения, в функции ПолучитьНомерНаПечать

    Вот чать кода, где происходит обрезание префикса
    //////////////////////////////////////////////
    Для Каждого ТекущийПрефикс ИЗ МассивПрефиксовДляОбхода Цикл

    // удаление префикса из номера документа
    Если Найти(Номер, ТекущийПрефикс)=1 Тогда
    Номер = Сред(Номер, СтрДлина(ТекущийПрефикс)+1);
    КонецЕсли;

    // так же, может остаться "минус" впереди
    Если Лев(Номер, 1) = "-" Тогда
    Номер = Сред(Номер, 2);
    КонецЕсли;

    // удаление ведущих нулей
    Пока Лев(Номер, 1)="0" Цикл
    Номер = Сред(Номер, 2);
    КонецЦикла;
    КонецЦикла;
    ///////////////////////////////////////////////////////

    Т.е. условия обращения к этой части кода нет, значит он всегда обрезается при печати и типовых решений нет.

Поделиться этой страницей