7.7 Печать документов на разных принтерах

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем root.domain, 15 июн 2007.

  1. TopicStarter Overlay
    root.domain
    Offline

    root.domain

    Регистрация:
    15 июн 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Проблема в следующем:
    Печатаются накладные и еще кое какие документы нужно что бы при печати документов допустим накладных печатались на принтере по умолчанию а еще один документ печатался на другом принтере как это сделать???
    вот кусок кода ответственный за печать другого документа вместе с накладной
    ---------------------------------------------------------------------------------------------------
    Процедура ПечатьВетСвидетельства(Конт,Клиент=0,ВидТранспорта,Количество,НомФормы,ВарПечати,ЧислоЭкз=2,ПредвПоказ=1) Экспорт
    Перем Стр;
    Таб=СоздатьОбъект("Таблица");
    Фирма=СоздатьОбъект("Справочник.Фирмы");
    // Таб.ИсходнаяТаблица("Ветеринарное свидетельство формы № 2");
    Если (ВарПечати=1) Тогда
    Таб.ИсходнаяТаблица("Ветеринарное свидетельство формы № "+Строка(НомФормы)+"П");
    иначе
    Таб.ИсходнаяТаблица("Ветеринарное свидетельство формы № "+Строка(НомФормы));
    КонецЕсли;
    Фирма.ИспользоватьДату(Конт.ДатаДок,1);
    Фирма.НайтиЭлемент(Конт.Фирма);
    Год=ДатаГод(Конт.ДатаДок);
    НомерГода=Формат(Год-Окр(Год,-2),"Ч(0)2");

    НомерДня=ДатаЧисло(Конт.ДатаДок);
    ИмяМесяца=ПолучитьИмяМесяца(Конт);
    ИмяФирмы=Фирма.ОфициальноеНаименование;
    ИмяРуководителя=Строка(Фирма.Руководитель);
    Если Клиент=0 Тогда
    КлиентПеч="торговую сеть";
    ТТНПеч="ТТН";
    АдресФирмы=Строка(Фирма.ПочтовыйАдрес);
    ИНАЧЕ
    АдресФирмы=Строка(Фирма.ПочтовыйАдрес);
    ТТНПеч="ТТН"+"№ "+Строка(Конт.НомерДок)+" от "+Строка(Конт.ДатаДок);
    КлиентПеч=Клиент.Наименование+Клиент.ПочтовыйАдрес;
    КонецЕсли;
    ДатаВыработки= Формат(Конт.ДатаДок, "Д (0)ДДММММГГГГ");
    Таб.ПараметрыСтраницы(1,100,1,8,1,0,0,0,0,0,1);
    Если (ВарПечати=0) Тогда
    ОбщееКоличестоПеч="";
    ИНАЧЕ
    ОбщееКоличестоПеч=Строка(Количество)+" кг.";
    КонецЕсли;

    ДатаНаклПеч=Конт.ДатаДок;
    ИмяВрача=Константа.ВетеринарныйВрач;
    ИмяМенеджера=Константа.ИмяМенеджера;
    НомерУдостовПеч="77-03-"+Строка(НомерДняГода(Конт.ДатаДок));
    Таб.Вывести();
    Таб.КоличествоЭкземпляров(ЧислоЭкз);
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Если (ПредвПоказ=1) Тогда
    Таб.Показать("Печать Ветеринарного свидетельства ","");
    Иначе
    Таб.Напечатать(0);
    КонецЕсли;
    КонецПроцедуры
    ------------------------------------------------------------------------------------------------------------
  2. Aptem
    Offline

    Aptem

    Регистрация:
    15 май 2007
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    Тебе поможет ms_whs.als, в инете найти легко
    Там в scriptingRuntimeLibrary есть метод SetDefaultPrinter(<?>)

Поделиться этой страницей