8.х Печать документа "РеализацияТоваровИУслуг"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем smallangel, 5 авг 2008.

  1. TopicStarter Overlay
    smallangel
    Offline

    smallangel

    Регистрация:
    6 авг 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    При создании обработки для печати пакета документов на реализацию на текущую дату столкнулась с проблемой того, что при непосредственной печати документов - они не влезают на один лист.

    Если не выводить банковские реквизиты грузополучателя и плательщика - то все отлично влезет на 1 лист А4. Но не знаю как это сделать, так как использую уже существующие процедуры печати типовой конфигурации.

    Посмотреть вложение 1103

    Вложения:

  2. TopicStarter Overlay
    smallangel
    Offline

    smallangel

    Регистрация:
    6 авг 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ОсновныеДействияФормыПечатьДокВ(Кнопка)
    Если СформированныеДокументы.Количество()<>0 тогда
    НаПринтер=Истина;
    НепосредственнаяПечать=Истина;
    Для Каждого Стр Из СформированныеДокументы Цикл
    Если (Стр.СчетФактураВыданный<>Неопределено)И (Стр.РеализацияТоваровИУслуг<>Неопределено) тогда
    Объект=Стр.РеализацияТоваровИУслуг.ПолучитьОбъект();
    // 2 копии реализации
    Объект.Печать("ТОРГ12_БезУслуг", 2, НаПринтер);
    // 1 копия счета-фактуры
    Объект=Стр.СчетФактураВыданный.ПолучитьОбъект();
    Объект.Печать("СчетФактура", 1, НаПринтер);
    КонецЕсли;
    Если (Стр.СчетФактураВыданный<>Неопределено)тогда
    //еще по 1 копии счетов-фактур
    Объект.Печать("СчетФактура", 1, НаПринтер);
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецПроцедуры
    
    
    Так я вывожу на печать сформированные документы, которые имеют заполненные реквизиты и проведены
  3. TopicStarter Overlay
    smallangel
    Offline

    smallangel

    Регистрация:
    6 авг 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Реализацию формирую автоматически следующим образом:

    Код:
    Процедура СоздатьДокументРеализация(СтрокаТаблицыЗапроса)
    РеализацияТов=Документы.РеализацияТоваровУслуг.СоздатьДокумент();
    ВалютаРегламентированногоУчета=Константы.ВалютаРегламентированногоУчета.Получить();
    ЗаполнитьШапкуДокумента(РеализацияТов, глТекущийПользователь, ВалютаРегламентированногоУчета, "Продажа",,);
    РеализацияТов.Дата=ГлобТекущаяДата;
    //организация
    РеализацияТов.Организация=Организация;
    РеализацияТов.Контрагент=СтрокаТаблицыЗапроса.Клиент;
    РеализацияТов.Записать();
    
    РеализацияТов.ДоговорКонтрагента=СтрокаТаблицыЗапроса.НачальныйДокументПодписки.ДоговорНаПодписку.Ссылка;
    //ПриИзмененииЗначенияКонтрагента(РеализацияТов);
    //РеализацияТов.ДоговорКонтрагента=СтрокаТаблицыЗапроса.Клиент.ОсновнойДоговорКонтрагента;
    РеализацияТов.СуммаВключаетНДС=Истина;                                             
    РеализацияТов.ТипЦен=РеализацияТов.ДоговорКонтрагента.ТипЦен;
    РеализацияТов.ВалютаДокумента=РеализацияТов.ДоговорКонтрагента.ВалютаВзаиморасчетов;
    
    РеализацияТов.КурсВзаиморасчетов=КурсДокумента(РеализацияТов, ВалютаРегламентированногоУчета);
    РеализацияТов.КратностьВзаиморасчетов=КратностьДокумента(РеализацияТов, ВалютаРегламентированногоУчета);
    РеализацияТов.УчитыватьНДС=Истина;
    //склад
    РеализацияТов.Склад=Склад;
    РеализацияТов.БанковскийСчетОрганизации=Организация.ОсновнойБанковскийСчет;
    РеализацияТов.ВидОперации=Перечисления.ВидыОперацийРеализацияТоваров.ПродажаКомиссия;
    РеализацияТов.ВидПередачи=Перечисления.ВидыПередачиТоваров.СоСклада;
    РеализацияТов.ОтражатьВБухгалтерскомУчете=Истина;
    РеализацияТов.ОтражатьВНалоговомУчете=Истина;
    РеализацияТов.ОтражатьВУправленческомУчете=Истина;
    
    ТекущийПользовательИБ=глЗначениеПеременной("глТекущийПользователь");
    Если ТекущийПользовательИБ<>Неопределено тогда
    РеализацияТов.ОтпускПроизвел=ТекущийПользовательИБ.ФизЛицо;
    РеализацияТов.ОтпускРазрешил=ТекущийПользовательИБ.ФизЛицо;
    РеализацияТов.Ответственный=глЗначениеПеременной("глТекущийПользователь");
    ///РеализацияТов.Подразделение=ТекущийПользовательИБ.
    КонецЕсли;                                     
    //РеализацияТов.Грузоотправитель=Справочники.Контрагенты.НайтиПоНаименованию(РеализацияТов.Организация.Наименование);
    РеализацияТов.Грузополучатель=РеализацияТов.Контрагент;
    //РеализацияТов.АдресДоставки=ПолучитьАдресДоставкиСтрокой(РеализацияТов.Грузополучатель,);
    //РеализацияТов.Подразделение=Справочники.Подразделения.НайтиПоНаименованию("ОсновноеПодразделение");
    
    РеализацияТов.Записать();
    
    СтрокаДок=РеализацияТов.Товары.Добавить();
    
    СтрокаДок.Номенклатура=СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры;                                              
    СтрокаДок.Содержание=СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры.Наименование+" за "+ИмяМесяцаПоНомеру(ГлобТекущаяДата)+" "+Год(ГлобТекущаяДата)+"г";
    СтрокаДок.ЕдиницаИзмерения=СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры.ЕдиницаХраненияОстатков;
    СтрокаДок.Коэффициент=СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры.ЕдиницаХраненияОстатков.Коэффициент;
    СтрокаДок.Количество=1;
    
    РеализацияТов.Записать();
    СтрокаДок.СтавкаНДС=СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры.СтавкаНДС;
    Сумма1=ОпределитьСуммуПоПериодичности(СтрокаТаблицыЗапроса.ВидПодписки,СтрокаТаблицыЗапроса.Периодичность);
    
    Если СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры.СтавкаНДС=Перечисления.СтавкиНДС.НДС10 Тогда
    СтрокаДок.СуммаНДС=Сумма1-Сумма1/110*100;
    ИначеЕсли СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры.СтавкаНДС=Перечисления.СтавкиНДС.НДС18 Тогда
    СтрокаДок.СуммаНДС=Сумма1-Сумма1/118*100;
    КонецЕсли;
    СтрокаДок.Цена=Сумма1;
    СтрокаДок.Сумма=Сумма1*СтрокаДок.Количество;
    //бухгалтерский учет
    СчетаУчета= ПолучитьСчетаУчетаНоменклатуры(Организация,СтрокаТаблицыЗапроса.ВидПодписки.ВидНоменклатуры);
    РеализацияТов.ЗаполнитьСчетаБУРегл(СтрокаДок, "Товары", СчетаУчета, истина);
    РеализацияТов.ЗаполнитьСчетаНУРегл(СтрокаДок, "Товары", СчетаУчета, истина);
    
    //управление взаиморасчетами
    СчетаУчетаКонтр = ПолучитьСчетаРасчетовСКонтрагентом(Организация, СтрокаТаблицыЗапроса.Клиент, СтрокаТаблицыЗапроса.Клиент.ОсновнойДоговорКонтрагента);
    РеализацияТов.СчетУчетаРасчетовСКонтрагентом=СчетаУчетаКонтр.СчетАвансовПокупателя;
    РеализацияТов.СчетУчетаРасчетовПоАвансам=СчетаУчетаКонтр.СчетРасчетовПокупателя;
    РеализацияТов.СуммаДокумента=СтрокаДок.Сумма;
    ТаблицаПоТоварам=РеализацияТов.Товары;
    ТаблицаПоУслугам=РеализацияТов.Услуги;
    //РеализацияТов.ПодготовитьТаблицыДокумента(СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоУслугам,);
    РеализацияТов.Записать();
    РеализацияТов.Записать(РежимЗаписиДокумента.Проведение);
    ТекущаяРеализация=РеализацияТов.Ссылка;
    КонецПроцедуры
    
    
  4. TopicStarter Overlay
    smallangel
    Offline

    smallangel

    Регистрация:
    6 авг 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    :unsure: ну помогите мне!!!
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Чем помочь-то? Я вот вопроса не вижу...
  6. TopicStarter Overlay
    smallangel
    Offline

    smallangel

    Регистрация:
    6 авг 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    ну мне не нужно выводить банковские реквизиты при печати Реализации в графах грузополучатель и плательщик

    как выводить без них на печать документ? просто на лист А4 не влезает
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Ну дык ты сам ответил на свой вопрос :)

Поделиться этой страницей