8.х УТ Печать документа Поступление товаров и услуг.

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Titov, 8 дек 2008.

  1. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    Подскажите плиз, в печатной форме док-та Поступление товаров и услуг есть поле номенклатура в которые выводится реквизит ПолноеНаименование из справочника Номенлкатура.
    Можно ли чтобы в печатной форме выводилось вместо поля ПолноеНаименование просто Наименование из спр. Номенлкатура не прибегая к изменению конфигуратора? :unsure:
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Подключить внешнюю печатную форму.. в которой будет выводиться нужные данные.. или просто переименовывайте как надо.. или конфигуратор)
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Более резонный вопрос - а зачем? Заполняйте тогда полное наименование также...
  4. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    Сильно много номенклатуры, везде только реквизит наименование, полное наименование пустое, видимо прийдется обработку писать для заполнения.
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Обработка пишется за 10 минут на коленке :)
  6. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Обработка займет строк 10)) и минут поменьше0)))) так что решайтесь)))
  7. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    С 7.7 перехожу на 8, мало что знаю, написал обработку - она не работает подскажите в чем косяк.
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    ВыбНмк= Справочники.Номенклатура.Выбрать();
    Пока ВыбНмк.Следующий() Цикл
    ВыбНмк.НаименованиеПолное = ВыбНмк.Наименование;
    КонецЦикла;
    КонецПроцедуры
    
    
    Пишет поле объекта недоступно для записи (НаименованиеПолное)
    Подскажите плиз))
  8. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26

    я бы сделал лучше так чтоб исключить группы
    Код:
    Запрос=новый Запрос;
    Запрос.Текст="
    |ВЫБРАТЬ
    |	Номенклатура.Наименование
    |ИЗ
    |	Справочник.Номенклатура КАК Номенклатура
    |ГДЕ
    |	Номенклатура.ЭтоГруппа = ЛОЖЬ
    |";
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    Объект = Результат.ПолучитьОбъект();
    Объект.НаименованиеПолное = Объект.Наименование;
    Объект.Записать();
    
    КонецЦикла;
    
    
    
    
    
    Если по твоему то просто вставь строки
    с объектом..т.е. получить и записать
  9. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    Разобрался!
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    ВыбНмк= Справочники.Номенклатура.Выбрать();
    Пока ВыбНмк.Следующий() Цикл
    //ВыбНмк.НаименованиеПолное = ВыбНмк.Наименование;
    Если Не ВыбНмк.ЭтоГруппа  Тогда 
    об = ВыбНмк.ПолучитьОбъект();
    //Сообщить(об.ПолноеНаименование());
    //об.ПолноеНаименование = ВыбНмк.Наименование;
    об.НаименованиеПолное = ВыбНмк.Наименование;
    об.Записать();
    Конецесли;
    
    КонецЦикла;
    КонецПроцедуры
    
    
    
Похожие темы
  1. MaikGr
    Ответов:
    3
    Просмотров:
    1.297
  2. Scinn
    Ответов:
    6
    Просмотров:
    945
  3. alboldinov
    Ответов:
    2
    Просмотров:
    194
  4. Robix
    Ответов:
    1
    Просмотров:
    980
  5. konetzkaya
    Ответов:
    3
    Просмотров:
    557
Загрузка...

Поделиться этой страницей