8.х Печать договора

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Dmitrij, 26 окт 2008.

  1. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    Затея такая сделать макет печатной формы договора (внешняя обработка), данные должны браться из ФормаЭлемента справочника ДоговорыКонтрагентов. Проблема в следующем как обратится к форме, я написал след код
    Код:
    Функция ПолучитьДоговор()
    
    ТекДог=СсылкаНаОбъект.ПолучитьОбъект();
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДоговор", СсылкаНаОбъект);
    Запрос.Текст =
    "ВЫБРАТЬ
    |    Владелец,
    |    Организация,
    |    Дата,
    |    Номер,
    |    франОтветственноеЛицоИсполнителя,
    |    франОтветственноеЛицоЗаказчика,
    |    франДокументОснованиеДействийСотрудника,
    |    франДокументОснованиеДействийЗаказчика,
    |    франТипДоговора
    |ИЗ
    |    Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
    |ГДЕ
    |    ДоговорыКонтрагентов.Ссылка = &ТекущийДоговор";
    ЗапросШапка = Запрос.Выполнить().Выбрать();
    Макет       = ПолучитьМакет("Договор");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Дата = ЗапросШапка.Дата;
    Шапка.Параметры.Номер = ЗапросШапка.Номер;
    ТабДокумент.Вывести(Шапка);
    ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    ТабДокумент.ПолеСверху = 10;
    ТабДокумент.ПолеСлева  = 10;
    ТабДокумент.ПолеСнизу  = 10;
    ТабДокумент.ПолеСправа = 10;
    Возврат ТабДокумент;
    
    КонецФункции // ПечатьАктаОбОказанииУслуг()
    
    Функция Печать() Экспорт
    Если ТипЗнч(СсылкаНаОбъект) = Тип("СправочникСсылка.ДоговорыКонтрагентов") Тогда
    Возврат ПолучитьДоговор();
    КонецЕсли;
    КонецФункции // Печать
    
    
    
    
    код не работает данные не подставляются в макет, подскажите что не так?
  2. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Ну так давай дальше код...
  3. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    дописал
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    1. Где определение ТабДокумента?
    2. Где проверка выборки?
    3. Причем тут форма элемента?
    4. Рекомендую ознакомиться с темой по созданию ВПФ - поможет.
Похожие темы
  1. OIT
    Ответов:
    4
    Просмотров:
    907
  2. Guzey
    Ответов:
    0
    Просмотров:
    1.416
Загрузка...

Поделиться этой страницей