7.7 печать данных табличной части документа

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем smolet, 4 мар 2011.

  1. TopicStarter Overlay
    smolet
    Offline

    smolet

    Регистрация:
    4 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Добрый день!

    Подскажите пожалуйста такой вопрос.
    Есть документ, состоящий целиком из табличной части.
    Могу ли я выводить на печать данные по каждой строке отдельно?
    Если да то в какую сторону двигаться?

    Заранее спасибо
  2. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Код:
    Для Каждого Строка из Документ.ТабличнаяЧасть Цикл
    Товар = Строка.Товар;
    Цена = Строка.Цена;
    
    // и т.д. выбираем из табличной части нужные параметры и печатаем 
    
    КонецЦикла;
    
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Внимательнее смотрим на ветку.. Здесь 7.7

    Код:
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    //Тут делаем с данными что хотим - выводим на печать в том числе
    КонецЦикла;
    
    
    
  4. TopicStarter Overlay
    smolet
    Offline

    smolet

    Регистрация:
    4 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    спасибо за быстрый ответ, я сам не очень силен в 1с...
    пошел ковырять
  5. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    воспользуйтесь конструктором печати и все. а форму потом уже и подправить можно.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    если человек не силен в 1с конструктор (если имеется ввиду конструктор макета) только запутает его.
    Тем более не думаю что для построчной печати потребуются секции...

    Там наверное простая конструкция подойдет
    Код:
    Таб=СоздатьОбъект("Таблица");
    Таб.Вывести();
    Таб.Показать();
    
    
  7. TopicStarter Overlay
    smolet
    Offline

    smolet

    Регистрация:
    4 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    еще раз спасибо и еще один вопрос
    а если мне нужно вывести данные отдельно взятой строчки?
    как правило конечно последней, т.е. заполняются данные и тут же распечатываются....
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    ПолучитьСтрокуПоНомеру(КоличествоСтрок());
    
    
    в данном случае спозиционировались в документе на последнюю строку...
  9. TopicStarter Overlay
    smolet
    Offline

    smolet

    Регистрация:
    4 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    т.е. в принципе я могу ввести переменную, задаваемую на кнопке формы, которая бы выводила вполне конкретную строку?
    ну если вдруг такое понадобится...

    что-то типа

    ПолучитьСтрокуПоНомеру N (КоличествоСтрок()); ?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Можно и так. Только проверяйте переменную чтобы не была больше чем количество строк и не равнялась нулю. А можно и схитрить.... Выведите кнопку, но без указания номера строки. В этом случае будет печататься ТЕКУЩАЯ. Пускай пользователь сам выбирает!
    Код:
    Процедура ПечатьМоейСтроки()
    Если КоличествоСтрок()=0 Тогда
    Возврат;
    КонецЕсли;
    //выведем на печать текущую строку
    Таб=СоздатьОбъект("Таблица");
    Таб.Вывести();
    Таб.Показать();
    КонецПроцедуры
    
    
  11. TopicStarter Overlay
    smolet
    Offline

    smolet

    Регистрация:
    4 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    о! с текущей это вообще шикарно!
    буду пробовать сегодня

Поделиться этой страницей