Печать чека в зависимости от формы оплаты фиск. реестратор datecs FP 3530T через утилиту CashFile.ex

Тема в разделе "Торговое оборудование в 1С", создана пользователем Mister-X, 31 янв 2013.

  1. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Кто работал из этим реестратором через утилиту CashFile.exe?
    есть печать чека в 1С 7.7 - конфа торговля самописка

    Код:
    ...
    ИначеЕсли ВидЭККА = Перечисление.ВидыЭККА.DatecsFP3530TCashFile Тогда
    Если ФС.СуществуетФайл("c:\CashFile.inp") = 1 Тогда ФС.УдалитьФайл("c:\CashFile.inp"); КонецЕсли;
    FPFile= СоздатьОбъект("Текст");
    FPFile.КодоваяСтраница(1); //Переключатель "5" в "Оп"
    FPFile.Очистить();
    FPFile.ДобавитьСтроку("P1С.Док."+НомерДок+";");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Новый= 0;
    АртикулЭККА = глД_ПолучитьАртикул(Контекст,СпрТМЦ,Новый);
    ТТТ= лев(сокрЛП(ТМЦ.Наименование),24);
    ТТТ= СтрЗаменить(ТТТ,"і","i");
    ТТТ= СтрЗаменить(ТТТ,"ї","i");
    ТТТ= СтрЗаменить(ТТТ,"І","I");
    ТТТ= СтрЗаменить(ТТТ,"Ї","I");
    Если Новый = 1 Тогда
    FPFile.ДобавитьСтроку("R"+ Строка(АртикулЭККА)+ ";"+ лев(ТТТ,24)+ ";"+ сред(ТТТ,25)+ ";"+ сокрЛП(Формат(ЦенаСНДС,"Ч10.2"))+ ";1;"+ Строка(глНалГруппаКассы(ТМЦ.СтавкаНДС)));
    КонецЕсли;
    FPFile.ДобавитьСтроку("D"+ Строка(АртикулЭККА)+ "*"+ Строка(Кво));
    КонецЦикла;
    Если СуммаОплаты = 0 Тогда
    FPFile.ДобавитьСтроку("T0;");
    ИначеЕсли СуммаОплаты >= Итог("СуммаСНДС") Тогда
    FPFile.ДобавитьСтроку("E0;"+ сокрЛП(формат(СуммаОплаты,"Ч10.2")));
    Иначе
    //ОтменитьТранзакцию();
    Предупреждение("ВНИМАНИЕ! Сумма оплаты меньше суммы по Чеку..."+РазделительСтрок+"Чек НЕ печатается !!!");
    Возврат;
    КонецЕсли;
    FPFile.Записать("c:\CashFile.inp");
    RunApp("c:\CashFile.exe c:\CashFile.inp >c:\CashFile.rpt");
    НомерЧека=1;
    
    нужно сделать печать чека в зависимости от формы оплаты рис.
    [​IMG]
    (док. "Розничная накл." формы оплаты естественно только наличные, но доработать другие - пустяк)

    возможно ли это сделать через эту утилиту (и как, есть ли у кого опись полей файла параметров) или нужно другим методом (утилитой) это делать?
    Спасибо за ответы.
  2. TopicStarter Overlay
    Mister-X
    Offline

    Mister-X

    Регистрация:
    20 июн 2008
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    формы оплаты: карточка (на рис. "картка"), деньги (на рис. "гроші")...

Поделиться этой страницей