7.7 Печать ценников по остаткам

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем vadim, 12 фев 2008.

  1. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    :unsure: Всем привет!!!!

    Имеется 1с 7.7 ТиС типовая конфигурация. При печати ценников он выводит на печать все ценники и даже ценники того товара которого нету на остатках мне надо чтобы он выводил ценники только тех товаров которые есть на остатках!!!

    У меня была обработка для не типовой конфигурации я там начал кое что переделывать но у меня ни чего не получается если кто сможет помогите пожалусто!!!!

    Смысл этой обработки таков выбираю товарную группу добавляю в таблицу и нажав на кнопку ост он должен оставить только те позиции которые есть на остатках. И в типовой конфигурации есть щаблон ценника розничный вот я и хочу чтобы он сразу выводил розничные ценники на товар!!!

    Если не затруднит помогите!!!

    Вложения:

    • 12345.ert
      Размер файла:
      186 КБ
      Просмотров:
      152
  2. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Еще нашел обработку в нете

    как сделать чтобы она печатала только то что есть на остатках

    Вложения:

    • cen_ES.ert
      Размер файла:
      216 КБ
      Просмотров:
      201
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    У тебя идет выбор вэлементов справочника сделай запрос к остатком и в список вноси только результаты запроса и будет решение проблемы
  4. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Код:
     Если ПоНаличию = 1 Тогда
    
    ТекстЗапросаОстатков = "
    |Номенклатура    = Регистр.ОстаткиТМЦ.Номенклатура;
    |Количество        = Регистр.ОстаткиТМЦ.Количество;
    |
    |Функция КоличествоКонОст = КонОст(Количество);
    |
    |Группировка Номенклатура без групп;";
    
    ТекстЗапросаОстатков = "Фирма = Регистр.ОстаткиТМЦ.Фирма;" + 
    ТекстЗапросаОстатков +
    "Условие(Фирма = ВыбРазделитель1);";
    КонецЕсли;
    
    
    Я в обработку добавил если ставишь галочку он должен выводить только товар с остатком но не получается
    Может кто исправит прикрепляю саму обработку

    Вложения:

  5. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    vadim во второй обработке не разобрался, а в первой в процедуре "ДобавитьТоварВТаблицуТоваров"
    нужно вставить запрос

    Код:
    Если ПоНаличию = 1 Тогда   
    Запрос = СоздатьОбъект("Запрос");             
    ТекстЗапросаОстатков = "        
    |Фирма =Регистр.ОстаткиТМЦ.Фирма;
    |Номенклатура    = Регистр.ОстаткиТМЦ.Номенклатура;        
    |Количество        = Регистр.ОстаткиТМЦ.Количество;        
    |Функция КоличествоКонОст = КонОст(Количество);        
    |Группировка Номенклатура без групп;        
    |Условие(Фирма = ВыбРазделитель1);       
    |Условие(Номенклатура  в СпрВыбТов);";          
    Если Запрос.Выполнить(ТекстЗапросаОстатков ) = 0 Тогда
    Возврат;
    КонецЕсли;
    Пока Запрос.Группировка(1) = 1 Цикл
    Если ТаблицаТоваров.НайтиЗначение(Запрос.Номенклатура,,"Товар") = 0 Тогда
    ТаблицаТоваров.НоваяСтрока();
    ТаблицаТоваров.Код = Запрос.Номенклатура.Код;
    ТаблицаТоваров.Товар = Запрос.Номенклатура; 
    ТаблицаТоваров.ЦенаПродажи = Запрос.Номенклатура.ЦенаПродажи;
    ТаблицаТоваров.Флажок = 2;
    Н = Н + 1;
    Состояние("Добавлено товаров: " + Н);
    КонецЕсли;
    КонецЦикла;
    
    КонецЕсли;
    
    
    
    :unsure:

Поделиться этой страницей