7.7 Печать артикула в ценнике, ТиС

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Harley, 23 янв 2013.

  1. TopicStarter Overlay
    Harley
    Offline

    Harley

    Регистрация:
    23 янв 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Имеется 1С:Предприятие 7.7 для SQL
    Типовая конфа Торговля + Склад 8,5 (7.70.851)
    Что прописать нужно что бы на ценнике печатался артикул.
    В инете очень много читал, пробовал, но что то не получается. Только начал изучать 1С, так сказать для себя:)
    Ах да, вот код:
    Код:
    Процедура ПечатьЦенника()
    Перем ПечНаименование, Ценник, ВремЦена, ЦенаТовара, ПечЕдиница, ПечВалюта, СтавкаНПпроц;
    Если Выбран() = 0 Тогда
    Предупреждение("Элемент не сохранен!");
    Возврат;
    КонецЕсли;
    
    Ценник = СоздатьОбъект("Таблица");
    Ценник.ИсходнаяТаблица("Ценник");
    
    ПечНаименование = ПолнНаименование;
    
    
    // Печатаем цену, указанную как розничная
    Если ПустоеЗначение(Константа.РозничнаяКатегорияЦен) = 0 Тогда
    ЦенаТовара = глВернутьЦену(ТекущийЭлемент(), Константа.РозничнаяКатегорияЦен);
    Если ПустоеЗначение(ЦенаТовара) = 0 Тогда
    ВремЦена = ЦенаТовара.Цена.Получить(РабочаяДата());
    // добавим НП
    СтавкаНПпроц=глПолучитьСтавкуНП(ТекущийЭлемент(),РабочаяДата());
    ВремЦена = ВремЦена * (100+СтавкаНПпроц) / 100;
    ПечВалюта = ЦенаТовара.Валюта.Получить(РабочаяДата());
    ПечЕдиница = ЦенаТовара.Единица.Получить(РабочаяДата());
    
    ПечРозн = СокрЛ(Формат(ВремЦена,"Ч15.2"))+" "+ПечВалюта;
    Иначе
    // цену не нашли
    // не печатаем товар без цены
    Предупреждение("У товара "+Наименование+РазделительСтрок+
    "не найден тип цены '"+Константа.РозничнаяКатегорияЦен.Наименование+"'");
    Возврат;
    КонецЕсли;
    Иначе
    // не задана розничная категория
    Предупреждение("Не задана розничная категория цен.");
    Возврат;
    КонецЕсли;
    
    Ценник.ВывестиСекцию("Товар|Ценник");
    Ценник.Опции(0,0,0,0);
    Ценник.Показать("Ценник");
    КонецПроцедуры
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Релиз, мягко говоря, староват. Но дело даже не в этом.
    Ты в печатной форме создал соответствующий реквизит? В модуле его описал?
    Тот модуль, что ты выложил, это типовой или сам "рисовал"?
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Судя по присутствию метода Выбран() печать производится из модуля формы элемента.
    Думаю достаточно будет
    Код:
    ПечНаименование = ПолнНаименование+" "+Артикул;
    
    при условии, что Артикул - реквизит справочника.
  4. TopicStarter Overlay
    Harley
    Offline

    Harley

    Регистрация:
    23 янв 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Ребят поймите:) только начал, и тут сразу попросили сделать Артикул на ценнике, так что не пинайте:)
    Сделал вот так, а что в печатной форме сделать нужно?

    Код:
    Процедура ПечатьЦенника()
    Перем ПечНаименование, Ценник, ВремЦена, ЦенаТовара, ПечЕдиница, ПечВалюта, СтавкаНПпроц;
    Если Выбран() = 0 Тогда
    Предупреждение("Элемент не сохранен!");
    Возврат;
    КонецЕсли;
    
    Ценник = СоздатьОбъект("Таблица");
    Ценник.ИсходнаяТаблица("Ценник");
    
    ПечНаименование = ПолнНаименование+" "+Артикул;
    
    
    // Печатаем цену, указанную как розничная
    Если ПустоеЗначение(Константа.РозничнаяКатегорияЦен) = 0 Тогда
    ЦенаТовара = глВернутьЦену(ТекущийЭлемент(), Константа.РозничнаяКатегорияЦен);
    Если ПустоеЗначение(ЦенаТовара) = 0 Тогда
    ВремЦена = ЦенаТовара.Цена.Получить(РабочаяДата());
    Посмотреть вложение 13567

    Вложения:

    • Untitled-1.jpg
      Untitled-1.jpg
      Размер файла:
      39,1 КБ
      Просмотров:
      14
  5. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Пропиши ПечАртикул.
    Хотя бы так попробуй
    ПечАртикул = Артикул;
    В ПечНаименование оставь толко ПолнНаименование.

Поделиться этой страницей