8.х Параметры в СКД

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем qwertyu, 15 фев 2013.

  1. TopicStarter Overlay
    qwertyu
    Offline

    qwertyu Опытный в 1С

    Регистрация:
    11 ноя 2011
    Сообщения:
    609
    Симпатии:
    0
    Баллы:
    26
    Добрый день.

    Я изменяю параметр схемы при помощи элементов формы, но при установке использования в истину, в ложь вернуть не удастся.

    Подскажите пожалуйста, в чем проблема?
    Код:
    Перем ПараметрыПериода;
    
    Процедура ВыбПериодНажатие(Элемент)
    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
    Если НастройкаПериода.Редактировать() Тогда
    ИзменениеДатыНачала(НастройкаПериода.ПолучитьДатуНачала());
    ИзменениеДатыОкончания(НастройкаПериода.ПолучитьДатуОкончания());
    КонецЕсли;
    КонецПроцедуры
    
    Процедура НачПериодаПриИзменении(Элемент)
    ИзменениеДатыНачала(НачалоДня(НачПериода));
    КонецПроцедуры
    
    Процедура КонПериодаПриИзменении(Элемент)
    ИзменениеДатыОкончания(КонецДня(КонПериода));
    КонецПроцедуры
    
    Процедура ИзменениеДатыНачала(Дата)
    ПараметрыПериода.Элементы[0].Значение = Дата;
    ПараметрыПериода.Элементы[0].Использование = Не (Дата = Дата("00010101"));
    КонецПроцедуры
    
    Процедура ИзменениеДатыОкончания(Дата)
    ПараметрыПериода.Элементы[1].Значение = Дата;
    ПараметрыПериода.Элементы[2].Значение = Дата;
    ПараметрыПериода.Элементы[1].Использование = Не (Дата = Дата("00010101"));
    ПараметрыПериода.Элементы[2].Использование = Не (Дата = Дата("00010101"));
    КонецПроцедуры
    
    Процедура ПриОткрытии()
    ПараметрыПериода = КомпоновщикНастроек.Настройки.ПараметрыДанных;
    КонецПроцедуры
    
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Код:
    ПараметрыПериода.Элементы[0].Использование = Не (Дата = Дата("00010101")); 
    тут ложь будет только когда у вас Дата - будет пустой, если речь об этом

    и еще, вот При открытии вы считали параметры для СКД в переменную, а назад никак не передаете?! соответственно либо я чего-то недопонимаю, либо вы изменяете тупо переменную, а сами настройки СКд не меняете
Похожие темы
  1. НиколайН
    Ответов:
    8
    Просмотров:
    2.032
Загрузка...

Поделиться этой страницей