8.х УТ Параметр динамического списка

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем wary, 18 июн 2012.

  1. TopicStarter Overlay
    wary
    Offline

    wary Опытный в 1С

    Регистрация:
    5 авг 2009
    Сообщения:
    139
    Симпатии:
    1
    Баллы:
    26
    Добрый день!

    Управление торговлей, редакция 11.0 (11.0.8.8)

    Есть вот такая процедура:

    Код:
    Процедура УстановитьПараметрДинамическогоСписка(Список, ИмяПараметра, Значение, Использование = Истина) Экспорт
    
    Если Использование Тогда
    Список.Параметры.УстановитьЗначениеПараметра(ИмяПараметра, Значение);
    Иначе
    ЗначениеПараметра = Список.Параметры.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(ИмяПараметра));
    Если ЗначениеПараметра <> Неопределено Тогда
    ЗначениеПараметра.Значение = Значение;
    ЗначениеПараметра.Использование = Ложь;
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    Как передать в параметр динамического списка несколько значений? (В данном случае в типовой передается значение Сегмент1, мне нужно чтобы Сегмент1+Сегмент2)

    тип параметра СправочникСсылка

    Заранее спасибо!
  2. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Если тип параметра справочникссылка, то список не передать в него. Нужно менять вид сравнения или тип параметра.
    Поищите в типовой - там должны быть примеры передачи списка. Но и параметр должен быть другим (и сравнение, соответственно, в запросе)

Поделиться этой страницей