8.х Отслеживание изменений содержимого каталога

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем dzhel, 15 фев 2010.

  1. TopicStarter Overlay
    dzhel
    Offline

    dzhel

    Регистрация:
    15 фев 2010
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Есть необходимость отслеживать когда в каталоге появляется новый файл с его последующей обработкой. Нашел процедуры для обработки (см. ниже), но есть след. проблема. А именно - процедура ВнешнееСобытие работает только для конкретной формы. Но я не знаю какая форма будет открыта у пользователя в момент появления нового файла. Подскажите как поступить в этом случае, чтобы изменении содержимого каталога не было привязки к форме?


    Процедура ПриНачалеРаботыСистемы() //Предопределенная процедура 1С

    ЗагрузитьВнешнююКомпоненту("..\vk_ChangeNotification.dll");
    vk=Новый("AddIn.vk_ChangeNotification");

    vk.ОтслеживатьПодкаталоги=0;
    vk.НачатьКонтрольИзменений("Каталог");
    КонецПроцедуры

    Процедура ПриЗавершенииРаботыСистемы()
    vk.ЗакончитьКонтрольИзменений();
    КонецПроцедуры // ПриЗавершенииРаботыСистемы

    Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Сообщить("Внешнее событие: Источник="+Источник+" Событие="+Событие+" Данные="+Данные);
    КонецПроцедуры
  2. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Сделай свою форму, запихни ее в ОбщиеФормы, сделай ее прикрепленной и прячущейся.

Поделиться этой страницей