8.х Отправка сообщению пользователю

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем hays23, 30 июн 2014.

  1. TopicStarter Overlay
    hays23
    Offline

    hays23

    Регистрация:
    13 авг 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Добрый вечер!
    Файловый режим
    конфиг. "Управление торговлей", редакция 10.3 (10.3.3.3)

    Как отправить сообщение пользователю? допустим пользователь Саша, в док. ЗаказПокупателя в документе меняет Статус: "Обработан", то надо оповестить пользователю Витали- как эта сделать?

    Код:
     ТекПольз=ПользователиИнформационнойБазы.ТекущийПользователь().ПолноеИмя;
        Если ТекПольз="Саша" Тогда
        Если ВыбранноеЗначение=Перечисления.ABOCMS_СтатусЗаказа.Обработан Тогда
         
            ПоказатьОповещениеПользователя("Инфо пользователю");
         
        КонецЕсли;
        КонецЕсли;
    

    Реально вообще такое осуществить или нет?
    Последнее редактирование: 30 июн 2014
  2. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    Ну так Вы уже написали все, что нужно. В чем проблема-то?
  3. TopicStarter Overlay
    hays23
    Offline

    hays23

    Регистрация:
    13 авг 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Я оповещая самого себя, а мне нужно оповестить другого пользователя.
    Т.е. я создаю документ, ставлю статус "Обработан"- когда поставил статус-сразу оповещает другого пользователя что этот документ уже "Обработан"- как так можно сделать?
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.434
    Симпатии:
    373
    Баллы:
    104
    Поставить The BAT в локальной сети сервером почты и посредством его отправлять письма через платформу
  5. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    насколько я помню, оповещение сработает только в том случае, если у получателя запущена 1С. Воспользуйтесь советом про почтовик. А как определить имя пользователя, кому надо отправить сообщение - это уже вам надо придумать. Может это реквизит документа по типу Ответственный?
  6. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Добавляете новый регистр сообщений, ставите текст, пользователя, время и статус. При запуске системы подключаете обработчик ожидания, ну а дальше, дело техники.
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    Через регистр-самый лучший результат, можно намного шире расширить такой функционал.
  8. TopicStarter Overlay
    hays23
    Offline

    hays23

    Регистрация:
    13 авг 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Я так сказать новичек еще в этом,не совсем хорошо знаю 1с, и тяжко не много, где именно обработчик ожидания?.
    Короче говоря, выкрутился, сделал через Задачи (Оповещение задачи) создает задачку для другого пользователя и он получает задание- минус большой то что эта оповещение открывается при запуске 1С.Так вот, как открыть окно при работе 1с?
    Код:
    Если ВыбранноеЗначение=Справочники.Организации.НайтиПоКоду("000000001") Тогда
            Задача=Задачи.ЗадачиПользователя.СоздатьЗадачу();
            Задача.Дата=ТекущаяДата();
            Задача.Наименование="Проверка";
            Задача.Исполнитель=Справочники.Пользователи.НайтиПоКоду("Виталий");
            Задача.Описание="Описание для Виталика";
            Задача.Оповещение=Истина;
            Задача.СрокОповещения=ТекущаяДата();
            Задача.СрокИсполнения=ТекущаяДата()+40000;
            Задача.Инициатор=ПараметрыСеанса.ТекущийПользователь;
            Задача.Записать();
            Задача.ПолучитьФорму("ФормаОповещенияОЗадачах").ОткрытьМодально();// открывается у меня,нужно чтоб открылась  у Виталика-как сделать?
        КонецЕсли;
    

    Правда конфиг на этот код сделал УТП- т.к. времени не была установить управл. торговл.- впринципе суть не меняется-как чтоб у другого пользователя вызвать окно?

    Задача-оповестить пользователя- можно даже перезагрузить 1С у него-эта реально?:D
    Последнее редактирование: 1 июл 2014
  9. Alex_fess
    Offline

    Alex_fess Опытный в 1С

    Регистрация:
    23 мар 2011
    Сообщения:
    256
    Симпатии:
    7
    Баллы:
    29
    Обработчик ожидания. в процедуру запхните саму "оповещалку" (хоть Сообщить()) с условием. Я делал через внешние файлы (на рег. сведений косо посматривал тогда). Если в файле нужное значение - выполнить. Ну а дальше уже Ваша фантазия.

Поделиться этой страницей