8.х Отправка счета через outlook

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем skatal, 23 авг 2010.

  1. TopicStarter Overlay
    skatal
    Offline

    skatal

    Регистрация:
    27 апр 2010
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    1C бухгалтерия 8 и Outlook

    Пробую следующим способом:

    Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения = "") Экспорт

    Outlook=Новый COMОбъект("Outlook.Application");
    ТипФайла="XLS";
    Письмо=Outlook.CreateItem(0);
    Письмо.Subject=ИмяФайлаВложения;
    Письмо.Body=ИмяФайлаВложения;
    ФайлаВложения=КаталогВременныхФайлов()+СтрЗаменить(ИмяФайлаВложения, ".", " ")+"."+ТипФайла;
    Документ.Записать(ФайлаВложения,ТипФайла);
    Письмо.Attachments.Add(ФайлаВложения);
    Попытка
    Письмо.Display();
    Исключение
    КонецПопытки;

    КонецПроцедуры

    В УТ всё замечательно загружается в оутлук, а вот в Бухгалтерии ругается:

    {ОбщийМодуль.УправлениеОтчетами(2192)}: Ошибка при вызове метода контекста (Записать): Ошибка при выполнении файловой операции 'C:\Users\***\AppData\Local\Temp\Счет на оплату покупателю № ***.XLS'
    Документ.Записать(ФайлаВложения,ТипФайла);

    Что не так? подскажите пожалуйста...
  2. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    первое что я бы посмотрел, это права на папку. Ну и добавьте конструкцию Попытка Исключение когда записываете
  3. TopicStarter Overlay
    skatal
    Offline

    skatal

    Регистрация:
    27 апр 2010
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Дело в том что даже если прописываю конкретно допустим диск Д, он ругается также..
    А УТ не ругается, ей прав хватает...
  4. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Ну отладчиком пройтись попробовать
  5. kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26


    В какую часть документа прикручивать этот текст?
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Я конечно не спец, но...
    А что передается в Документ? Быть может у этого объекта нет метода Записать? Или он не определен?
  7. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Пройдитесь отладчиком и посмотрите чему равна переменная "Документ".
  8. kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    Как я понял этот код нужно вставить в счет на оплату покупателю?
  9. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Нужно посмотреть в УТ (там же работает!) что именно передается в параметр "Документ" там где вызывается процедура "ОтправитьДокументПоЭлектроннойПочте()" и по аналогии передать тоже в бухгалтерии.
  10. kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    Просмотрел там где есть функйия отправки, в модуле нет нечего связаного с отправкой по почте
  11. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    В стандартной УТ после вывода на печать есть процедура которая передает параметры:
    Код:
    Процедура КоманднаяПанельФормыОтправитьПоПочте(Кнопка)
    УправлениеОтчетами.ОтправитьДокументПоЭлектроннойПочте(ЭлементыФормы.ПолеТабличногоДокумента, Заголовок);
    КонецПроцедуры
    
    а есть сама процедура, которая их принимает:
    Код:
    Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения = "") Экспорт
    ...
    КонецПроцедуры
    
    получаем, что
    Код:
    Документ = ЭлементыФормы.ПолеТабличногоДокумента;
    
    а у вас чему?
  12. kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    у меня кнопки нет на отправку счета по мылу, как я понимаю прикрутить это дополнение не смогу?
  13. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Ну почему же не сможете.
    Нужно просто сначала получить таблицу, а потом уже ее пытаться сохранять(хоть в *.xls, хоть в *.mxl,...).
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а что мешает создать кнопку?

Поделиться этой страницей