7.7 Отменить проведение документа при закрытии формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 19 май 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всем всего доброго! Мне нужно при закрытии формы документа сделать его не проведенным, если выполняется ряд условий. Проблема в том, что здесь нужно сначала закрыть форму документа, иначе объект заблокирован, и дальше метод не выполним. В приведенном ниже коде пробовал писать Форма.Закрыть() в одной из двух процедур: ПриЗакрытии() или ОтменимкаПроведение(), но всё безрезультатно. Где ошибка в моем коде:
    Код:
    Процедура ОтменимкаПроведение()
        Докум=СоздатьОбъект("Документ.ПлатежноеПоручение");
        Докум.НайтиДокумент(ТекущийДокумент());
        Форма.Закрыть();
        Докум.СделатьНеПроведенным();
        ПроведеныСуммовыеРазницы=0;
    КонецПроцедуры
     
    Процедура ПриЗакрытии() 
    //отмена проведения
     Если ОплатитьСегодня=0 Тогда
     Если Договор.РасчетыВУЕ=1 Тогда
     Если ПроведеныСуммовыеРазницы=1 Тогда
     Ответ=Вопрос("Отменить проведение документа в системе учета курсовых разниц?",4);
     Если Ответ=7 тогда
     Возврат;
     КонецЕсли;
     Если Ответ=6 тогда
     //Форма.Закрыть();
     ОтменимкаПроведение();
     КонецЕсли;
     КонецЕсли;
     КонецЕсли;
     КонецЕсли;
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В процедуре ПриЗакрытии вызываете обработку которая бы отменила проведение документа, в качестве параметра передавайте контекст. Т.о. документ будет закрыт и из обработки можно снять проведение

Поделиться этой страницей