8.х Отмена Проводок: Метод объекта не обнаружен (Записать)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Letos, 17 мар 2010.

  1. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Необходимо отменить все проводки в документах реализация товара. Выдаёт ошибку
    "{Документ.МойДок.Форма.ОтменаПроведения(6)}: Метод объекта не обнаружен (Записать)
    ВД.Записать(РежимЗаписиДокумента.ОтменаПроведения);
    "

    Код:
      	
    ВД=Документы.РеализацияТоваровУслуг;  	
    Пока ВД.Выбрать().Следующий() Цикл  	
    ВД.Записать(РежимЗаписиДокумента.ОтменаПроведения);  	
    КонецЦикла;	
    
    
    Что не так?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Такая же ошибка, как в этой теме
  3. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Записать только у объекта, выборкой вы ссылки получаетет


    Код:
    ВД=Документы.РеализацияТоваровУслуг;  
    Пока ВД.Выбрать().Следующий() Цикл  	     
    ДокОб=ВД.ПолучитьОбъект();
    ДокОб.Записать(РежимЗаписиДокумента.ОтменаПроведения);  	  
    КонецЦикла;
    
    А че груповой обрботкой справочников и документов нельзя воспользоваться?
  4. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Мне крайне не удобно, но я не вкурил. :unsure:


    [/code]

    А че груповой обрботкой справочников и документов нельзя воспользоваться?
    [/quote]

    Я по поводу груповой обработки ничего не понял. То есть я не знаю что такая есть. Где её можно посмотреть?
  5. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Код:
    ВД=Документы.РеализацияТоваровУслуг;  
    Пока ВД.Выбрать().Следующий() Цикл           
    ВДОб=ВД.ПолучитьОбъект();
    ВДОб.Записать(РежимЗаписиДокумента.ОтменаПроведения);        
    КонецЦикла;
    
    
    В этом случае он пишет что метоб объекта не обнаружен (ПолучитьОбъект)
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    ВД=Документы.РеализацияТоваровУслуг.Выбрать();  
    Пока ВД.Следующий() Цикл           
    ВДОб=ВД.ПолучитьОбъект();
    ВДОб.Записать(РежимЗаписиДокумента.ОтменаПроведения);        
    КонецЦикла;
    
  7. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Операции-Обработки-Групповая обработка справочников и документов. Или она в меню сервис еще распологается.

    Там на первой вкладке делаете отбо, на второй указываете чт с ним делать
  8. Бухгалтерский чайник
    Offline

    Бухгалтерский чайник

    Регистрация:
    23 дек 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Это заработало. Спасибо.

Поделиться этой страницей