7.7 отмена проведения открытого документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем BOBS, 3 авг 2010.

  1. TopicStarter Overlay
    BOBS
    Offline

    BOBS

    Регистрация:
    22 май 2010
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Конфига 7,7 многократно переписанная. В стправочнике товаров есть отчет по выбранной позиции товара где он находится в резерве. Из отчета можно провалиться в документ. Но очень неудобно искать потом в журнале резервов или счетов этот документ. Сделал кнопку для снятия резерва, но выскакивает ошибка. "Объект не может быть перепозиционирован!" Вот код кнопки:
    Код:
    Процедура СделатьНеПроведенным()
    Форма.Закрыть(0);
    Докум = СоздатьОбъект("Документ");
    Докум.НайтиДокумент(ТекущийДокумент());
    Если Докум.Проведен()=0 Тогда 
    Возврат;
    Иначе
    Если Вопрос("Вы уверены что хотите снять с резерва ? << " +Докум+" >>",4,0) = 6 Тогда
    НайтиДокумент(Докум);
    Докум.СделатьНеПроведенным();
    Сообщить(" << " +Докум+ " >> был снят с резерва");
    КонецЕсли; 
    КонецЕсли;
    КонецПроцедуры 
    
    
    Подскажите плиз почему не получается ?
  2. Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Ты позиционируешся на документе в отчете? или все-таки журнале, тогда
    пробуй :
    Код:
    Процедура СделатьНеПроведенным()
    Форма.Закрыть(0);
    Докум=ТекущийДокумент;
    Если Докум.Проведен()=0 Тогда 
    СтатусВозврата(0);
    Иначе
    Если Вопрос("Вы уверены что хотите снять с резерва ? << " +Докум+" >>",4,0) = 6 Тогда
    Докум.СделатьНеПроведенным();
    Сообщить(" << " +Докум+ " >> был снят с резерва");
    КонецЕсли; 
    КонецЕсли;
    КонецПроцедуры 
    
    
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Открытый документ нельзя распровести. Только из самого документа
  4. TopicStarter Overlay
    BOBS
    Offline

    BOBS

    Регистрация:
    22 май 2010
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Для этого и закрываю форму документа.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Совершенно не обязательно закрывать... Можно передать команду и в открытый документ.
  6. TopicStarter Overlay
    BOBS
    Offline

    BOBS

    Регистрация:
    22 май 2010
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    попробовал, но сразу ошибка, даже в документ зайти не дает :
    Докум=ТекущийДокумент<<?>>;
    {Документ.СчeтНаОплату.Форма.Модуль(430)}: Переменная не определена (ТекущийДокумент)
    Бухгалтерский угодник
    Как раз этого и хотелось бы добиться. Чтоб находясь в нужном документе нажать кнопочку и он стал не проведенным.
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Используйте метод ОткрытьФорму с передачей параметров. В самом документе процедуру ПриПовторномОткрытии

Поделиться этой страницей