8.х Отмена Пометки на удаление

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Letos, 12 апр 2010.

  1. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Код:
    ПометкаУдаления
    
    Только позволяет увидеть есть ли метка или нет, а вот как это метку поставить либо снять?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    СнятьПометкуУдаления()
    
    
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
  4. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Я попробовал следующим оброзом.

    Код:
    ВД.СнятьПометкуУдаления(Истина);
    
    
    Где ВД - выборка из документа. Программа выдала следующую ошибку.

    Из-за чего?
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Прочитайте мое сообщение выше
  6. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.632
    Симпатии:
    946
    Баллы:
    204
    Там же в синтаксис помошннике написанно что пометка ставиться на Объект а не на выборку или ссылку. Допустим у Вас в выбоке ССЫЛКи на номенклатуру тогда вот так

    Код:
    Пока Выборка.Следующий() Цикл
    
    ОбъеектНОменклатура=Выборка.Номенклатура.ПолучитьОбъект();
    ОбъеектНОменклатура.СнятьПометкуУдаления(Истина);
    ОбъеектНОменклатура.Записать();
    КонецЦикла
    
  7. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Мой код следующий
    Код:
    ВД=Документы.ПоступлениеТоваровУслуг.Выбрать(Дата(2009,12,25),КонецГода(ТекущаяДата()));
    Пока ВД.Следующий() <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл		</span>
    ОтменаПроводки=ВД.ПолучитьОбъект();
    ОтменаПроводки.СнятьПометкуУдаления(Истина);
    ОтменаПроводки.Записать(РежимЗаписиДокумента.Проведение);
    КонецЦикла;
    
    
    И всё равно ошибка "Метод объекта не обнаружен"
  8. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Цель - то: в следующем. необходимо в справочнике "Договора контрагентов" поменять реквизит "Взаимо расчёт" для снял проведения у кучи документов. Когда стал возвращать обратно он начал писать, что не может провести документы помеченные на удаление, хотя таковых нет.
  9. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.632
    Симпатии:
    946
    Баллы:
    204
    Извините я не глянул и ошибся вот так должно работать

    Код:
    ВД=Документы.ПоступлениеТоваровУслуг.Выбрать(Дата(2009,12,25),КонецГода(ТекущаяДата()));
    Пока ВД.Следующий() Цикл
    ОтменаПроводки=ВД.ПолучитьОбъект();        
    ОтменаПроводки.УстановитьПометкуУдаления(Ложь);
    ОтменаПроводки.Записать(РежимЗаписиДокумента.Проведение);    
    КонецЦикла;
    
    
    Вообще все это делается групповой обработкой справочников и документов и ничего не пишется

Поделиться этой страницей