8.х Отладка правил конвертации.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Саша82, 26 мар 2010.

  1. TopicStarter Overlay
    Саша82
    Offline

    Саша82 Активный ученик

    Регистрация:
    11 окт 2007
    Сообщения:
    307
    Симпатии:
    0
    Баллы:
    26
    Запускаю отладку правил конвертации и с первого раза работает все нормально но со второго раза может и не заработать (хотя бывает что и работает). При этом переменная ФлагРежимОтладкиОбработчиков стоит в Истина но потом например вот этот код
    Код:
    Выполнить(ПолучитьСтрокуВызоваОбработчика(ПКО, "ПередВыгрузкой"));
    
    то есть модуль объекта с обработкой в которую я сохранил правила может не открыться хотя обмен произойдет. Приходится заново перезапустить конфигуратор и предприятие и тогда опять нормально все. Подскажите почему так от чего это может зависеть?
  2. x-a-d
    Offline

    x-a-d Опытный в 1С

    Регистрация:
    3 сен 2009
    Сообщения:
    184
    Симпатии:
    0
    Баллы:
    26
    совершенно не понятен вопрос.
    какая связь между
    Код:
    Выполнить(ПолучитьСтрокуВызоваОбработчика(ПКО, "ПередВыгрузкой"));
    
    и фразой " то есть модуль объекта с обработкой в которую я сохранил правила может не открыться хотя обмен произойдет."

    ваш приведенный код, на сколько помню, вызывается "при загрузке" на стороне приемника(на сколько я понял это 8-ка, вы не сказали ничего ни об источнике ни об приемнике)
    если есть какие-то проблемы с кодом при вызове метода, то открывайте ПКО, заходите в "ПередВыгрузкой" и смотрите что там напрограммировано.
  3. TopicStarter Overlay
    Саша82
    Offline

    Саша82 Активный ученик

    Регистрация:
    11 окт 2007
    Сообщения:
    307
    Симпатии:
    0
    Баллы:
    26
    Это
    Код:
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить(ПолучитьСтрокуВызоваОбработчика(ПКО, \"ПередВыгрузкой\"));</span>
    
    я привел просто как пример это происходит при выгрузки на стороне источника и не важно где код просто с первого раза после запуска конфигуратора отладка происходит нормально а потом может и не произойти но от чего это зависит я не понимаю? С кодом в обработчике все нормально и выгрузка все равно происходит даже если отладка не запустилась. Источник у меня excel лист настроенный с помощью этой http://infostart.ru/public/16316/ обработки а приемник УТ. Но это может быть проблема из за самой обработки Универсального обмена данными?

Поделиться этой страницей