7.7 Откуда корни растут ?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем freelife, 15 окт 2010.

  1. TopicStarter Overlay
    freelife
    Offline

    freelife

    Регистрация:
    7 окт 2010
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Голову сломал.
    В расчетных листках надо поменять Вид оплаты с
    "Единовременное поощрение", на другое, к примеру, "Вася любит Машу".
    За расчет по "Единовременное поощрению" отвечает Вид расчета - ЕДВзаДИДО


    Идентификатор - ЕДВзаДИДО
    Синоним - Вася любит Машу
    Комментарий - Единовременное денежное вознаграждение за добросовестное исполнение должностных обязанностей

    Делаем Расчетный лист, он в колонке выдает "Единовременное поощрение" а не "Вася любит Машу".
    Смотрим на текст модуля Расчетный лист:
    Код:
    Таблица.Область(НомерСтроки,1).Текст = глПредставлениеВидаРасчета(Расчет)+?(Запрос.Сотрудник <> Запрос.Сотрудник.ОсновнойЭлемент," (по внутр. совмест-ву)","");
    
    Таблица.Область(НомерСтроки,2).Текст = глЧислоВФорматеПользователя(Запрос.Дни,6,2);
    
    Таблица.Область(НомерСтроки,3).Текст = глЧислоВФорматеПользователя(Запрос.Часы,8,2); 
    
    
    
    глПредставлениеВидаРасчета(Расчет) тут выдает как раз и "Единовременное поощрение".
    Расчет равен - Вася любит Машу.
    т.е глПредставлениеВидаРасчета("Вася любит Машу");

    Функция в глобальном модуле глПредставлениеВидаРасчета выглядит так:
    Код:
    //******************************************************************************
    //	глПредставлениеВидаРасчета(ПарамВидРасчета)
    //
    //	Параметры:
    //		ПарамВидРасчета - вид расчета
    //
    //	Возвращаемое значение:
    //		строка - представление заданного вида расчета
    //
    //	Описание:
    //		Возвращает описание вида расчета, заданное пользователем или
    //		определенное в конфигураторе
    //
    Функция глПредставлениеВидаРасчета(ПарамВидРасчета) Экспорт
    
    Если ПустоеЗначение(ПарамВидРасчета) = 1 Тогда
    Возврат "";
    КонецЕсли;
    Если ТипЗначения(ПарамВидРасчета) <> 14 Тогда
    Возврат "";
    КонецЕсли;
    
    // возможно, названия в.р. могут быть и в документе
    
    Если глСпрВидыРасчетов.НайтиПоРеквизиту("Расчет",ПарамВидРасчета,1) = 1 Тогда
    Если ПустоеЗначение(глСпрВидыРасчетов.Наименование) = 0 Тогда
    Возврат глСпрВидыРасчетов.Наименование
    КонецЕсли;
    КонецЕсли;
    Возврат Метаданные.ВидРасчета(ПарамВидРасчета.Код).Представление()
    
    КонецФункции // глПредставлениеВидаРасчета  
    

    ТипЗначения(ПарамВидРасчета) у нас равен 14, т.о. выполняется строчка
    Возврат Метаданные.ВидРасчета(ПарамВидРасчета.Код).Представление()
    которая и возвращает "Единовременное поощрение", вот как так?
    Ведь, ПарамВидРасчета.Код у нас равен "Вася любит Машу", а в описании Метода Представление () написанно, что он возвращает Синоним, т.о. возвращать у нас должно "Вася любит Машу".
    Делал поиск по конфигуратору, по внешним ресурсам по слову "Единовременное поощрение", он его не находит, откуда он берет эту фразу и где её надо заменить?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Может начнем по порядку?
    Конфига хоть какая?
  3. TopicStarter Overlay
    freelife
    Offline

    freelife

    Регистрация:
    7 окт 2010
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Все оказалось просто Оо Просто в Справочнике Виды расчета наименование изменить.
    Пол дня потерял, копаясь в конфе

Поделиться этой страницей