7.7 Открытие журнала документов из отчета по заявкам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Voyajer, 6 дек 2012.

  1. TopicStarter Overlay
    Voyajer
    Offline

    Voyajer

    Регистрация:
    20 ноя 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Код:
    Функция Печать()
    ДатаКонца=ТекущаяДата();
    // ДатаНачала=ДатаКонца-1700;
    
    Таблица = СоздатьОбъект("Таблица");
    Таблица.ИсходнаяТаблица("Таблица");
    
    СекцияШапка=Таблица.ПолучитьСекцию("Шапка");
    ДатаДокСтр=Строка(ДатаКонца)+" г.";
    
    Таблица.ВывестиСекцию("Шапка");
    Таблица.ВывестиСекцию("Заголовок");
    
    Ном=1;
    ИтогСумма=0;
    
    
    Запрос = СоздатьОбъект("Запрос");
    СтрПериод = ?(ДатаКонца>= ПолучитьДатуТА(),"",
    "Период с ДатаКонца по ДатаКонца;");  
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |" + СтрПериод +
    "
    |ЗаявкаПокупателя = Регистр.Заявки.ЗаявкаПокупателя;
    |СтоимостьРасх = Регистр.Заявки.СтоимостьРасход;
    |Функция СтоимостьРасход = КонОст(СтоимостьРасх);
    |Группировка ЗаявкаПокупателя упорядочить по ЗаявкаПокупателя.ДатаПервоначальногоСоздания;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) <> 0 Тогда
    Пока Запрос.Группировка(1) = 1 Цикл
    ЗаявкаПокупателя=Запрос.ЗаявкаПокупателя;
    СтоимостьРасход=Запрос.СтоимостьРасход;
    СекцияСтрока=Таблица.ПолучитьСекцию("Строка");
    Номер=Ном;
    Заявка=ЗаявкаПокупателя.ТекущийДокумент();
    ДатаРедакции =ЗаявкаПокупателя.ДатаДок;
    ДатаПервоначальногоСозд=ЗаявкаПокупателя.ДатаПервоначальногоСоздания;
    ВремяХранения= ДатаКонца-ЗаявкаПокупателя.ДатаПервоначальногоСоздания;
    Контрагент = ЗаявкаПокупателя.Контрагент;
    Сумма = Формат(СтоимостьРасход, "Ч015.2, ");
    ИтогСумма=ИтогСумма+СтоимостьРасход;
    Куратор=ЗаявкаПокупателя.Контрагент.ОсновноеСвойство.ЗначениеСвойства.я_Значение;  
    Комментарии=ЗаявкаПокупателя.Комментарий;
    Ном=Ном+1;
    Таблица.ВывестиСекцию("Строка");
    КонецЦикла;
    КонецЕсли;
    
    
    печСумма = Формат(ИтогСумма, "Ч15.2, ");
    
    СекцияПовал=Таблица.ПолучитьСекцию("Подвал");
    Таблица.ВывестиСекцию("Подвал");
    
    Таблица.ТолькоПросмотр(1);
    Таблица.Показать();
    КонецФункции
    
    Процедура ПриОткрытии()
    //   ТекДок = Форма.Параметр.Получить("Контекст");
    Печать();
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры
    
    Процедура ПриВыбореЯчейкиТаблицы(ИмяЯчейки, Знач)
    
    // Тело процедуры
    
    // ...Здесь не знаю что писать
    
    КонецПроцедуры
    
    Как заставить, чтобы вместо клика по заявке, открывалась бы не сама заявка, а журнал документов на текущей заявке?

    Обращаю ваше внимание что тэги на сайте изменились.... Юзаем ["code1c"] без кавычек
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    юзаем ОбработкаЯчейкиТаблицы
    конфа какая?
  3. TopicStarter Overlay
    Voyajer
    Offline

    Voyajer

    Регистрация:
    20 ноя 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Вроде бы Рарус
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    "чур меня... чур"....
    Вот если я вам на вопрос "какая машина" отвечу "вроде бы ВАЗ" у вас какое мнение о модели сложится?
  5. TopicStarter Overlay
    Voyajer
    Offline

    Voyajer

    Регистрация:
    20 ноя 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    А может событие ОбработкаЯчейкиТаблицы работать при закрытой форме обработки?

    1С Рарус CRM "Управление продажами" 20
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1) Нет.. Если расположена в отбаботке, а не в ГМ
    2) Под рукой нет этой конфы. Поэтому не знаю параметров формы общего журнала...
    Посмотрите пример в ТиС или скидывайте МДшник.

Поделиться этой страницей