8.х Открытие сохранненого doc документа

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем AleksP, 13 сен 2012.

  1. TopicStarter Overlay
    AleksP
    Offline

    AleksP

    Регистрация:
    17 июл 2012
    Сообщения:
    44
    Симпатии:
    0
    Баллы:
    1
    Здраствуйте. Помогите решить проблему. Имеется макет внешней печатной формы, одним из ее действий является сохранение формы в doc-документ. Нужно добавить к ней функцию которая после сохранения документа сразу бы его открывала.
    Код:
    Режим = РежимДиалогаВыбораФайла.Сохранение;
    Файл = Новый ДиалогВыбораФайла(Режим);
    Файл.Фильтр = "Документы Word(*.doc, *.docx)|*.doc, *.docx";
    Файл.Заголовок = "Выберите место для сохранения";
    Файл.ПолноеИмяФайла = "договор";
    Файл.Выбрать();
    Если Не ЗначениеЗаполнено(Файл.ПолноеИмяФайла) Тогда
    Файл.ПолноеИмяФайла = "договор " + Выбор.номер;
    КонецЕсли;
    ПутьКФайлу = Файл.ПолноеИмяФайла;
    Документ.SaveAs(ПутьКФайлу);
    Ворд.Activate();
    Если (ПутьКФайлу = ИСТИНА)  Тогда
    ЗапуститьПриложение(ПутьКФайлу);
    КонецЕсли;
    
    Возврат ТабличногоДокумента;
    
    Проблема возникла с последними тремя строчками. Во-первых, не могу правильно задать условие. Во-вторых, Если убрать условие, то тогда выходит ошибка: Не удается найти "Адрес файла"
  2. AlexeyKh
    Offline

    AlexeyKh Опытный в 1С

    Регистрация:
    27 июл 2012
    Сообщения:
    62
    Симпатии:
    0
    Баллы:
    26
    какая-то полная ерунда в вашем коде, ну если вы не программист не надо писать программы!
    если вы не хирург вы же не будете своему другу вырезать аппендицит, хотя это простая операция.
  3. TopicStarter Overlay
    AleksP
    Offline

    AleksP

    Регистрация:
    17 июл 2012
    Сообщения:
    44
    Симпатии:
    0
    Баллы:
    1
    А я смотрю ты прям профи, все сказал, объяснил. Чувак да ты просто лучший. Ходи вырежи аппендецит.
  4. AlexeyKh
    Offline

    AlexeyKh Опытный в 1С

    Регистрация:
    27 июл 2012
    Сообщения:
    62
    Симпатии:
    0
    Баллы:
    26
    :+)
    да ладно не парься, просто с утра поднял настроение
    взять хотя бы твою команду

    Если (ПутьКФайлу = ИСТИНА) Тогда
    ЗапуститьПриложение(ПутьКФайлу);
    КонецЕсли;


    ПутьКФайлу - это строка
    и ты строку сравниваешь с Булево
    вообще сравнивать рекомнедуется однотипные переменные, числа с числами, строки со строками, даты с датами и т.д.
    в твоем случае сравнение всегда будет возвращать ЛОЖЬ.
    и так на каждом шагу.
    из это и сложилось впечатление что ты скорее Х...Рург чем программист. Ха-ха прикольная игра слов.
  5. TopicStarter Overlay
    AleksP
    Offline

    AleksP

    Регистрация:
    17 июл 2012
    Сообщения:
    44
    Симпатии:
    0
    Баллы:
    1
    Ну вообщето я писал, что не пойму, как правильно задать условие. Ну и, во-вторых, проверка возращает условие истина, только может принимать два значения, в зависимости сохранил я файл или нет, но здесь за подсказку спасибо, че-то действительно слегка поторопился с созданием условия.

Поделиться этой страницей