7.7 Открытие формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем consol, 24 май 2011.

  1. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    >ищу нужный цвет, выбираю его, а название ткани пропадает

    измени так

    Конт=Ткань;
    ОткрытьПодбор("Справочник.ЦветаТкани",,Конт,0);

    и добавь в док процедуру
    Процедура ОбработкаПодбора(Элем, Конт)
    Цвет=Элем;
    КонецПроцедуры

    и ещё
    Ткань=Форма.Параметр;
    Если спр.НайтиПоНаименованию(СокрЛП(Ткань),0)=1 Тогда
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Хм... И как это она найдет наименование по элементу справочника?
  3. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    ну а это для чего?
    СокрЛП(Ткань)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Это если основное представление - наименование. А если нет? Не люблю неопределенности.
  5. NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    а вот непойму один момент
    Код:
    ИспользоватьРодителя(спр.ТекущийЭлемент()); 
    
    спр.ТекущийЭлемент() - это наименование группы в Цветах?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Это найденный элемент справочника ЦветаТкани
  7. NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    а вот что б поиск осуществлялся не по группам а по элементам надо через ИспользоватьСписокЭлементов делать?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ИспользоватьСписокЭлементов - фильтр отображения элементов
    Метод НайтиПоНаименованию не различает элементы/справочники. Просто вернет первый попавшийся.

    Поиск только среди наименований групп (как вам нужно) можно осуществить только через перебор или запрос.
  9. NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    я как раз спрасил поиск не по группам
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Равносильственно. Для поиска по наименованию вы можете только указать родителя. Не более
  11. NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    просто мне задачу поставили следующая в табчасти документа есть колонки НомМоделиБаз и Модель,НомМоделиБаз выбирается из спрКаталог а Модель из СпрМодели, в СпрМодели есть группы, котлрые имеют не одинаковое название с НомМоделиБаз, а вэтих группах есть элементы которые имеют почти одинаковое название с НомМоделиБаз. Пример: выбираю из СпрКаталог НомМоделиБаз (М-10-это модель), а в СпрМодели (открываю группу и ищу расширенную модель, т.е М-10А,М-10В,М-10С из этих трех выбираю одну нужную)но в этой группе находятся не только расширеннве модели М-10, но и еще много других например (м-11 А,М-12 А и т.д)я совсем недавно начал разбираться в 1с, поэтому пока что туго идет.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Осуществлять поиск расширеных моделей нужно по всему справочнику или они 100% в этой же группе? Список расширенных моделей большой? Какая-нибудь дополнительная инфа из справочника нужна кроме наименования (количество остатка например)?
  13. NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    поиск по всему нужно делать так как все модели разбиты на 6 разных групп, список неочень большой в каждой группе штук по 70, дополнительная информация не требуется только наименоание.
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ну в вашем случае можно сделать выпадающим списком. Приблизительно так:

    Код:
    Процедура ПриНачалеВыбораЗначения(Ид,Фл)
    Если Ид="ТотСамыйРеквизит" Тогда //укажите правильно реквизит
    //приведем наименовае для поиска
    Имя=ВРег(СокрЛП(Ткань.Наименование)); //как там у вас называется реквизит - измените
    СЗ=СоздатьОбъект("СписокЗначений");
    //ищем перебором
    Спр=СоздатьОбъект("Справочник.ЦветаТкани");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    //группы не нужны
    Если Спр.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;       
    //нашли похожий
    Если Найти(ВРег(Спр.Наименование),Имя)<>0 Тогда
    СЗ.ДобавитьЗначение(Спр.ТекущийЭлемент());
    КонецЕсли;
    КонецЦикла;
    //если хоть 1 нашли - выключить стандартный механизм выбора
    Если СЗ.РазмерСписка()>0 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда			</span>
    Зн="";
    Если СЗ.ВыбратьЗначение(Зн,"",,,1) Тогда
    Фл=0;                   
    ТотСамыйРеквизит=Зн;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
  15. NemeL
    Offline

    NemeL Опытный в 1С

    Регистрация:
    11 фев 2011
    Сообщения:
    73
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое за терпение и за помощь, все получилось.
Похожие темы
  1. _mirror
    Ответов:
    2
    Просмотров:
    1.267
Загрузка...

Поделиться этой страницей