8.х Открытие формы в основном окне

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Konst82, 9 янв 2016.

  1. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    Здравствуйте,
    Платформа 8.3.7.1759
    Конфа тренировочная (упр формы Режим совместимости 8.2)
    Пытаюсь из формы списка документов открыть форму дока в Основном окне. При помощи след. кода в модуле формы:

    &НаКлиенте
    Процедура ПриОткрытии(Отказ)

    ВО = ПолучитьОкна();
    ЭтаФорма.Окно = ВО[0];

    КонецПроцедуры

    Не получается , все равно открывает в дополнительном окне. Можно ли как-нибудь заставить открываться в основном?
  2. TopicStarter Overlay
    Konst82
    Offline

    Konst82 Опытный в 1С

    Регистрация:
    29 авг 2014
    Сообщения:
    53
    Симпатии:
    1
    Баллы:
    29
    Пока сделал так:

    Если ЭтаФорма.ВладелецФормы <> Неопределено ТОгда

    СтруктураПараметров = Новый Структура;

    ТекСтрока = ЭтаФорма.ВладелецФормы.ТекущаяСтрока;

    СтруктураПараметров.Вставить("Ключ", ТекСтрока);
    ОкнаПриложения = ПолучитьОкна();
    Для Индекс = 0 По ОкнаПриложения.Количество() - 1 Цикл
    Если ОкнаПриложения[Индекс].Основное Тогда
    ОткрываемоеОкно = ОкнаПриложения[Индекс];
    Прервать;
    КонецЕсли;
    КонецЦикла;

    ОткрытьФорму("Документ.Накладная.ФормаОбъекта", СтруктураПараметров, , , ОткрываемоеОкно);
    Отказ = Истина;
    КонецЕсли;

Поделиться этой страницей