[РЕШЕНО] Открытие формы регистра сведений из справочника в управляемой форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ppkmlite, 28 окт 2014.

  1. TopicStarter Overlay
    ppkmlite
    Offline

    ppkmlite Опытный в 1С

    Регистрация:
    28 окт 2014
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, подскажите,пожалуйста.
    Как сделать Открытие формы регистра сведений из справочника в управляемой форме.
    Выходит ошибка ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.по причине:Ошибка преобразования данных XDTO:Запись значения свойства 'ret': форма: Элемент

    &НаКлиенте
    Процедура Нормы(Команда)
    рег = НормыНаСервере();
    рег.ПолучитьФормуСписка().О ткрыть();
    ОткрытьФорму("РегистрыСвед ений.АГС_НормыРасхода.Форм� �");


    КонецПроцедуры

    &НаСервере
    Функция НормыНаСервере()
    рег = РегистрыСведений.АГС_Нормы Расхода;

    Возврат рег;

    КонецФункции
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.573
    Симпатии:
    717
    Баллы:
    204
    &НаКлиенте
    Процедура ВыполнитьНажатие(Элемент)
    Форма = ОткрытьФорму("РегистрыСвед ений.АГС_НормыРасхода.Форма");
    КонецПроцедуры
  3. TopicStarter Overlay
    ppkmlite
    Offline

    ppkmlite Опытный в 1С

    Регистрация:
    28 окт 2014
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое, что откликнулись, получилось, заработало. Спасибо большое!

Поделиться этой страницей