8.х Открытие файла из обработки

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Ivan2014, 28 май 2014.

  1. TopicStarter Overlay
    Ivan2014
    Offline

    Ivan2014 Опытный в 1С

    Регистрация:
    10 апр 2014
    Сообщения:
    384
    Симпатии:
    2
    Баллы:
    29
    Здравствуйте. Как открыть файл из обработки? Мне нужно получить путь к файлу, а дальше уже с ним буду работать. Добавил на форму поле ввода. Дальше нужно видимо событие НачалоВыбора использовать? Есть ли примеры?
    Спасибо.
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Курите ДиалогВыбораФайла()
    Ivan2014 нравится это.
  3. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    Код:
    // Выдается окно для выбора файла.
    // ................................................................................
    Процедура ВыборФайла(Файл, Заголовок, ТипФайла) Экспорт
    
        ДиалогОткрытияФайла = Новый ДиалогВыбораФайла (РежимДиалогаВыбораФайла.Открытие);
        ДиалогОткрытияФайла.ПолноеИмяФайла = "";
        Если ТипФайла = "dbf" Тогда
            Фильтр = "Файл dbf(*.dbf)|*.dbf";
        ИначеЕсли ТипФайла = "txt" Тогда
            Фильтр = "Текстовый документ(*.txt)|*.txt";
        ИначеЕсли ТипФайла = "mxl" Тогда
            Фильтр = "Табличный документ(*.mxl)|*.mxl";
        КонецЕсли;
        ДиалогОткрытияФайла.Фильтр = Фильтр;
        ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
        ДиалогОткрытияФайла.Заголовок = Заголовок;
        Если ДиалогОткрытияФайла.Выбрать() тогда
            Файл = ДиалогОткрытияФайла.ПолноеИмяФайла;
        КонецЕсли;
    
    КонецПроцедуры
    Ivan2014 нравится это.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Да и примеров в сети навалом...
    Ivan2014 нравится это.
  5. TopicStarter Overlay
    Ivan2014
    Offline

    Ivan2014 Опытный в 1С

    Регистрация:
    10 апр 2014
    Сообщения:
    384
    Симпатии:
    2
    Баллы:
    29
    Прошу прощения за глупый вопрос, а к чему сама процедура ВыборФайла привязывается? К чему на форме цепляется? К какому событию какого элемента? Не понимаю как с полем ввода связать эту процедуру.
  6. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.989
    Симпатии:
    399
    Баллы:
    104
    Пожалуйста.

    Вложения:

    Ivan2014 нравится это.
  7. TopicStarter Overlay
    Ivan2014
    Offline

    Ivan2014 Опытный в 1С

    Регистрация:
    10 апр 2014
    Сообщения:
    384
    Симпатии:
    2
    Баллы:
    29
    Спасибо.

Поделиться этой страницей