8.х Открыть форму внешней обработки

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем bluntschi, 27 июн 2014.

  1. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    Добрый день, подскажите, у меня внешняя обработка, в ней есть форма, она управляемая, мне нужно открыть ее, но при отркытии выдается ошибка "
    Значение не является значением объектного типа (Открыть)
    "

    код такой
    Код:
    Функция ПолучитьДокументИзПодбора()
       
    Форма1  = ПолучитьФорму("Форма");
    
        Результат = Форма1.Открыть();
       
        Если Результат = Неопределено Тогда
           
             Результат = Неопределено;
            
             Возврат Результат;
        Иначе
           
            Возврат Результат.Ссылка;
           
        КонецЕсли;
    
    КонецФункции
    
  2. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    хотя теперь данные есть, выводит, но при выборе элемента пусто :( на самой форме нужно прописать обработку выбора или как?
  3. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    в самой форме - при выборе значения вызвать процедуру ОповеститьОВыборе
    в вызывающей форме - или при создании формы задавать элемент-владелец, который примет значение, переданное в ОповеститьОВыборе, или в самой форме написать обработчик события ОбработкаВыбора
  4. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    а в процедуру Выбор или ОбработкаВыбора помещать
    Код:
    ОповеститьОВыборе
    у меня сейчас вот так:

    Код:
    &НаКлиенте
    Процедура СписокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
        ОповеститьОВыборе(ВыбранноеЗначение);
    КонецПроцедуры
    
  5. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    оповещение на месте - теперь в вызывающей форме это добро принять надо - оно не возвращается как значение метода Открыть формы, а передается либо элементу-владельцу, либо попадает в обработчик ОбработкаВыбора вызывающей формы в виде параметра
  6. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    теория понятна, непонятно как это кодом реализовать (
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Если через обработчик ОбработкаВыбора() - обрабатывайте параметр.

Поделиться этой страницей