7.7 Открыть форму документа из строки табличной части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем badsector, 29 мар 2013.

  1. TopicStarter Overlay
    badsector
    Offline

    badsector

    Регистрация:
    29 мар 2013
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Доброго всем времени суток...
    Вопрос мой вот в чем -устроился в контору которая таскает товар в Казахстан из Китая(дрели ,перфораторы,шуруповёрты ...и.т.д)
    в 1с я новичек но понятия имею
    вот что требуется сделать;

    Требование к программе​
    Платформа 7.7
    1 поставить на приход
    1.1 инструмент на ремонт​
    1.2 запчасти привезённые с Китая​
    2 Сформировать инструменты с замененными запчастями​
    3 Сделать галочку платно бесплатно​
    4 Внутреннее перемещение на 2 склад(просто перемещение)​
    5 Отчет по реализации запчастей​
    6 Материальны отчет​
    7 Защита программ паролем и установки с диска или как либо это возможно степенью защиты​
    8 На бумажном виде в крайнем верхнем левом углу скрытый текст (Сервис центр P.I.T.)необходимо внести​
    9 На ярлыке и при загрузки программы установить наш логотип ​
    Ну да ладно​

    Задача в том что по гарантии от какого либо контрагента приходит несколько товаров ,они принимаются актом приемки в ремонт
    в документе есть табличная часть с товаром который принимается ...
    возможно ли сделать так чтоб при переходе(либо при редактировании определенной колонки ) на другую строку в таблице с товаром открывался документ расходная накладная
    для выбора и реализации запчастей именно для текущего элемента в акте приемки
    а если документ уже имеется то открывался именно он
    Только прошу без издевок и подколов
    если что то не понятно я объясню
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да. Устанавливайте.в свойство колонки документа по зап. частям положение "на следующей строке" и будет вам счастье.
  3. web.num
    Offline

    web.num Опытный в 1С Команда форума

    Регистрация:
    6 окт 2011
    Сообщения:
    908
    Симпатии:
    4
    Баллы:
    29
    Вот тебе пример из 1С 8:
    Код:
    Процедура <имяТвоейТЧ>Выбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    Если (Колонка.Имя = "Имя колонки из которой ты собираешься открывать документ") Тогда
    
    ТекущиеДанные = Элемент.ТекущиеДанные[Колонка.Имя];
    
    Если Не ЗначениеЗаполнено(ТекущиеДанные) Тогда
    Возврат; //Или пишешь код для создания нового документа
    КонецЕсли;
    
    ФормаЭлемента = ТекущиеДанные.ПолучитьФорму();
    ФормаЭлемента.Открыть();
    КонецЕсли;
    
    КонецПроцедуры
    
    Повторюсь это для 8.(Вдруг сообразишь как адаптировать для 7.7) Для 7.7 я не знаю как писать. Сто лет не писал на ней. В общем если кто то напишет для 7.7 - тебе повезло! ))
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В 7ке достаточно добавить процедуру вызова/создания документа и прописать ее в поле формула номенклатуры

Поделиться этой страницей