8.х ОБМЕН отключить базу от УРБД

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем vgv8, 2 окт 2008.

  1. TopicStarter Overlay
    vgv8
    Offline

    vgv8 Опытный в 1С

    Регистрация:
    4 сен 2007
    Сообщения:
    79
    Симпатии:
    2
    Баллы:
    29
    Чувствую себя полнейшим кретином...

    Читаю в Габец и др. "Профессиональная разработка...", стр.599, 2 абзац сверху 2й колонки
    (раздел "Процедура восстановления информационной базы подчиненного узла"):
    "отключение от распределенной информационной базы (осуществляется путем установки свойству ГлавныйУзел значения Неопределено) - ПланыОбмена.УстановитьГлавныйУзел(Неопределено);"​


    А, где это свойство устанавливается - хз?

    Поскольку "изменения конфигурации заблокированы средствами управления распределенной ИБ", то не нашел ничего лучше, как попытаться выполнить указанный код в отладчике, остановив его на метке кода. Ну, и предчувствия меня не обманули - ничего не вышло.

    Мне этот код
    ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
    непонятен - не указан никакой определенный план обмена (у меня их несколько)

    Как же отключить базу от УРБД?
  2. Aidis
    Offline

    Aidis

    Регистрация:
    13 дек 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1

    Создаешь внешнюю обработку или отчет в ней пишешь
    "ПланыОбмена.УстановитьГлавныйУзел(Неопределено);"

    Сохраняешь обработку.

    Закрываешь конфигуратор

    Запускаешь пользовательский режим.

    Запускаешь обработку.
  3. TopicStarter Overlay
    vgv8
    Offline

    vgv8 Опытный в 1С

    Регистрация:
    4 сен 2007
    Сообщения:
    79
    Симпатии:
    2
    Баллы:
    29
    Да, спасибо.
    Вроде теперь все очевидно... когда получилось. Но ведь нигде не написано явно!

    В отладчике или при открытом конфигураторе этот код нельзя выполнять, т.к. этому коду требуется исключительная блокировка базы! А обработку надо создавать в другой (незаблокированной) конфигурации! А в конфигурации подчиненного узла (заблокированной) нельзя даже добавть внешнюю обработку, надо открывать файл обработки в монопольном пользовательском режиме (никак не в отладочном, и никак при открытом конфигураторе), "вслепую", т.к. отладкой никак нельзя пользоваться!

    Вкладываю тут готовые обработки для отключения от и восстановления подключения подчиненного узла от/к УРБД (т.е. от/к главного/ому узла/у)

    Код:
    Процедура ОтключитьГлавныйУзелНажатие(Элемент)
    Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
    СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном",
    ПланыОбмена.ГлавныйУзел());
    ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
    КонецЕсли;
    Предупреждение("Главный узел отключен");
    КонецПроцедуры
    
    Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
    Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
    ПланыОбмена.УстановитьГлавныйУзел(
    ВосстановитьЗначение(
    "ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
    КонецЕсли;
    Предупреждение("Главный узел восстановлен");
    КонецПроцедуры
    
    
    
    kusja369 нравится это.
  4. crack_am
    Offline

    crack_am

    Регистрация:
    30 окт 2008
    Сообщения:
    46
    Симпатии:
    0
    Баллы:
    1
    а можно попросить такую же обработку?
    а то не могу справочники перенести!
  5. TopicStarter Overlay
    vgv8
    Offline

    vgv8 Опытный в 1С

    Регистрация:
    4 сен 2007
    Сообщения:
    79
    Симпатии:
    2
    Баллы:
    29
    можно, просите!
    Если такую же, то она приложена, надо нажать на линк под "Прикрепленные файлы" для скачивания без всяких просьб

Поделиться этой страницей