7.7 Отгрузка мат. в сторону

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем KingX, 31 июл 2015.

  1. TopicStarter Overlay
    KingX
    Offline

    KingX Опытный в 1С

    Регистрация:
    19 дек 2011
    Сообщения:
    144
    Симпатии:
    0
    Баллы:
    26
    Всем привет!
    Народ, подскажите, а то не могу ни как понять. Вот в документе "Отгрузка материалов в сторону" есть столбец "Надлежит отпустить" и "Отпущено".
    Вот, вопрос в том. Как сделать чтоб в столбце "Отпущено" дублировалось из столбца "Надлежит отпустить".
    Материалы выбираем через "Подбор", там ставим кол-во. Но это кол-во не дублируется в столбце "Отпущено".

    Помогите пожалуйста поправить этот документ.

    Безымянный.jpg

    1С предприятие 7.7 7.70.027
    Бухгалтерия ПРОФ
    Релиз 7.70.593
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    в модуле формы документа в процедуре ОбработкаПодбора добавь строку

    Процедура ОбработкаПодбора(ВыбрМатериал)
    Кол = 1;
    Если ВвестиЧисло(Кол, "Введите количество", 14, 3) = 0 Тогда
    Возврат;
    ИначеЕсли Кол = 0 Тогда
    Возврат;
    КонецЕсли;

    НоваяСтрока();
    Материал = ВыбрМатериал;
    КоличествоНадлежитОтпустить = Кол;
    АктивизироватьСтроку();
    Пересчет("Материал");
    Пересчет("КоличествоНадлежитОтпустить");//вот ету строку надо добавить
    КонецПроцедуры
    KingX нравится это.
  3. TopicStarter Overlay
    KingX
    Offline

    KingX Опытный в 1С

    Регистрация:
    19 дек 2011
    Сообщения:
    144
    Симпатии:
    0
    Баллы:
    26
    Привет! Оно не дублирует в колонку Отпущено.
    --- Объединение сообщений, 3 авг 2015 ---
    Все сделал!

    Код:
    Процедура ОбработкаПодбора(ВыбрМатериал)
       Кол = 1;
       Если ВвестиЧисло(Кол, "Введите количество", 14, 3) = 0 Тогда
         Возврат;
       ИначеЕсли Кол = 0 Тогда
         Возврат;
       КонецЕсли;
    
       НоваяСтрока();
       Материал = ВыбрМатериал;
       КоличествоНадлежитОтпустить = Кол;
       КоличествоОтпущено = Кол; // добавил строку
       АктивизироватьСтроку();
       Пересчет("Материал");
       Пересчет("КоличествоНадлежитОтпустить");
       Пересчет("КоличествоОтпущено"); // Добавил строку
    КонецПроцедуры

    СПАСИБО за подсказку!
    Последнее редактирование модератором: 3 авг 2015

Поделиться этой страницей