8.х Отчёт, срочно помощь нужна :(

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем ProfforG, 23 апр 2012.

  1. TopicStarter Overlay
    ProfforG
    Offline

    ProfforG Опытный в 1С

    Регистрация:
    31 окт 2011
    Сообщения:
    139
    Симпатии:
    1
    Баллы:
    29
    Доброго времени суток! 1с 8.2 управляемое приложение, своя разработка.

    Проблема вот в чём... есть документ накладная, и есть справочник смеси, необходимо при выводе информации из документа накладная, к примеру по бетонной смеси, вывести инфу в макет по этой смеси из справочника.

    в ручную не приходилось формировать запросы, отчёты автоматом генерил всё время. а сделать нужно срочно, помогите пожалуйста.

    и ещё, есть у меня константы, температуры, заданные на день. вот эти температуры нужно так же записывать в этом макете, как это сделать?
  2. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Трудности в написании запроса? Или отчета в целом? В запросе используйте соединения.
  3. TopicStarter Overlay
    ProfforG
    Offline

    ProfforG Опытный в 1С

    Регистрация:
    31 окт 2011
    Сообщения:
    139
    Симпатии:
    1
    Баллы:
    29
    трудность в написании запроса. вот что сам сделал, но видимо не верно...


    Запрос = Новый Запрос;
    Код:
    <br>Запрос.Текст =<br>"ВЫБРАТЬ<br>| ДокументНакладная.Ссылка,<br>| ДокументНакладная.ВерсияДанных,<br>| ДокументНакладная.ПометкаУдаления,<br>| ДокументНакладная.Номер,<br>| ДокументНакладная.Дата,<br>| ДокументНакладная.Проведен,<br>| ДокументНакладная.ВременныйНомер,<br>| ДокументНакладная.Закрыта,<br>| ДокументНакладная.Группа,<br>| ДокументНакладная.НаименованиеПокупатель,<br>| ДокументНакладная.Доверенность,<br>| ДокументНакладная.ПризнакОрганизации,<br>| ДокументНакладная.Продавец,<br>| ДокументНакладная.Выписано,<br>| ДокументНакладная.Отгружено,<br>| ДокументНакладная.Остаток,<br>| ДокументНакладная.Вспомогательный1,<br>| ДокументНакладная.Вспомогательный2,<br>| ДокументНакладная.КолГруза,<br>| ДокументНакладная.Товары.(<br>| Ссылка,<br>| НомерСтроки,<br>| Товар,<br>| МаркаСмеси,<br>| КоличествоВыписано,<br>| КоличествоОтгружено,<br>| Остаток,<br>| ЕдиницыИзмерения,<br>| ПоТребованию<br>| ),<br>| ДокументНакладная.Рейсы.(<br>| Ссылка,<br>| НомерСтроки,<br>| Дата,<br>| НомерПропуска,<br>| Транспорт,<br>| РегНомер,<br>| КоличествоГруза,<br>| ЕдИзмГруза,<br>| НаименованиеОбъект,<br>| Расстояние,<br>| ВремяРейсаС,<br>| ВремяРейсаПо,<br>| Товар,<br>| МаркаСмеси,<br>| Объёмы<br>| ),<br>| Смеси.Ссылка КАК Ссылка1,<br>| Смеси.ВерсияДанных КАК ВерсияДанных1,<br>| Смеси.ПометкаУдаления КАК ПометкаУдаления1,<br>| Смеси.Предопределенный,<br>| Смеси.Код,<br>| Смеси.Наименование,<br>| Смеси.ГруппаТовара,<br>| Смеси.ГруппаТовараДоп,<br>| Смеси.ВидСмеси,<br>| Смеси.ВидСмесиДоп,<br>| Смеси.МаркаКлассОбщ,<br>| Смеси.МаркаКласс,<br>| Смеси.МаркаКлассБ,<br>| Смеси.МаркаКлассБдоп,<br>| Смеси.СредняяПрочностьБетона,<br>| Смеси.МаркаКлассР,<br>| Смеси.Удобоукладываемость,<br>| Смеси.ГОСТ,<br>| Смеси.ЦифровоеЗначение,<br>| Смеси.КлассМатериалов,<br>| Смеси.НаибольшаяКрупностьЗаполнителя,<br>| Смеси.Заполнитель,<br>| Смеси.Пластификатор,<br>| Смеси.НормаОтМассыВяжущего,<br>| Смеси.ПротивоморозийнаяДобавка,<br>| Смеси.НаименованиеСмеси<br>|ИЗ<br>| Справочник.Смеси КАК Смеси<br>| ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ДокументНакладная КАК ДокументНакладная<br>| ПО (Смеси.Наименование = ДокументНакладная.Товары.МаркаСмеси)<br>| И (Смеси.ВидСмеси = ДокументНакладная.Товары.Товар)<br>|ГДЕ<br>| ДокументНакладная.Ссылка = &amp;Ссылка";<br><br>Запрос.УстановитьПараметр("Ссылка", Ссылка);<br><br>Результат = Запрос.Выполнить();<br><br>ВыборкаДетальныеЗаписи = Результат.Выбрать();<br><br>Пока ВыборкаДетальныеЗаписи.Следующий() Цикл<br>// Вставить обработку выборки ВыборкаДетальныеЗаписи<br>КонецЦикла;
  4. TopicStarter Overlay
    ProfforG
    Offline

    ProfforG Опытный в 1С

    Регистрация:
    31 окт 2011
    Сообщения:
    139
    Симпатии:
    1
    Баллы:
    29
    Процедура ПечатьПропускаИДокументаОКачестве(ТабДок, Ссылка) Экспорт
    Макет = Документы.ДокументНакладная.ПолучитьМакет("ПечатьПропускаИДокументаОКачестве");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ДокументНакладная.ВременныйНомер,
    | ДокументНакладная.Закрыта,
    | ДокументНакладная.Группа,
    | ДокументНакладная.НаименованиеПокупатель,
    | ДокументНакладная.Доверенность,
    | ДокументНакладная.ПризнакОрганизации,
    | ДокументНакладная.Продавец,
    | ДокументНакладная.Выписано,
    | ДокументНакладная.Отгружено,
    | ДокументНакладная.Остаток,
    | ДокументНакладная.Вспомогательный1,
    | ДокументНакладная.Вспомогательный2,
    | ДокументНакладная.КолГруза,
    | ДокументНакладная.Товары.(
    | Ссылка,
    | НомерСтроки,
    | Товар,
    | МаркаСмеси,
    | КоличествоВыписано,
    | КоличествоОтгружено,
    | Остаток,
    | ЕдиницыИзмерения,
    | ПоТребованию
    | ),
    | ДокументНакладная.Рейсы.(
    | Ссылка,
    | НомерСтроки,
    | Дата,
    | НомерПропуска,
    | Транспорт,
    | РегНомер,
    | КоличествоГруза,
    | ЕдИзмГруза,
    | НаименованиеОбъект,
    | Расстояние,
    | ВремяРейсаС,
    | ВремяРейсаПо,
    | Товар,
    | МаркаСмеси,
    | Объёмы
    | ),
    | Смеси.Ссылка КАК Ссылка1,
    | Смеси.ВерсияДанных КАК ВерсияДанных1,
    | Смеси.ПометкаУдаления КАК ПометкаУдаления1,
    | Смеси.Предопределенный,
    | Смеси.Код,
    | Смеси.Наименование,
    | Смеси.ГруппаТовара,
    | Смеси.ГруппаТовараДоп,
    | Смеси.ВидСмеси,
    | Смеси.ВидСмесиДоп,
    | Смеси.МаркаКлассОбщ,
    | Смеси.МаркаКласс,
    | Смеси.МаркаКлассБ,
    | Смеси.МаркаКлассБдоп,
    | Смеси.СредняяПрочностьБетона,
    | Смеси.МаркаКлассР,
    | Смеси.Удобоукладываемость,
    | Смеси.ГОСТ,
    | Смеси.ЦифровоеЗначение,
    | Смеси.КлассМатериалов,
    | Смеси.НаибольшаяКрупностьЗаполнителя,
    | Смеси.Заполнитель,
    | Смеси.Пластификатор,
    | Смеси.НормаОтМассыВяжущего,
    | Смеси.ПротивоморозийнаяДобавка,
    | Смеси.НаименованиеСмеси
    |ИЗ
    | Справочник.Смеси КАК Смеси
    | ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ДокументНакладная КАК ДокументНакладная
    | ПО (Смеси.НаименованиеСмеси = ДокументНакладная.Товары.Товар)
    | И (Смеси.Наименование = ДокументНакладная.Товары.МаркаСмеси)
    |ГДЕ
    | ДокументНакладная.Ссылка В (&Ссылка)";

    Запрос.УстановитьПараметр("Ссылка", Ссылка);
    Результат = Запрос.Выполнить();

    Шапка = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Очистить();
    ВставлятьРазделительСтраниц = Ложь;


    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Шапка.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
    ТабДок.Вывести(Шапка, ВыборкаДетальныеЗаписи.Уровень());
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЦикла;

    КонецПроцедуры

    первоначально макет был под стандартный запрос сформирован, который по умолчанию. теперь я запрос переделал, свой вставил и на выводе макет вообще пустой.

    помогите пжлст
  5. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Если есть возможность, скиньте базу. (если конечно она не очень большая). Я вам помогу. Или хотя бы конфигурацию.
  6. TopicStarter Overlay
    ProfforG
    Offline

    ProfforG Опытный в 1С

    Регистрация:
    31 окт 2011
    Сообщения:
    139
    Симпатии:
    1
    Баллы:
    29
    м.б. лучше на словах?! связующим между справочником и документом является

    Код:
    Смеси.НаименованиеСмеси = ДокументНакладная.Товары.Товар
    (например: раствор товарный)
    Код:
    Смеси.Наименование = ДокументНакладная.Товары.МаркаСмеси
    (здесь марка этого раствора, например, М-145 П3)

    в запросе это нужно связать и потом выводить информацию в макете как по документу так и одновременно по этому товару.
    кстати, в документе может быть множество этих товаров.

    и...после запроса какую выборку использовать?! по умолчанию или детальную?!

    в общем вся проблема предполагаю в запросе.

    извините что так долго не отвечал.
  7. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    что значит одновременно по документу и этому товару - не очень понятно, приведите скрины что-ли того что есть и что надо получить....

    и вообще неужели все поля, что вы выбираете в запросе вы будите выводить? если нет, то зачем усложнять себе жизнь. Запрос по связыванию документа и справочника в принципе прост. Через конструктор все отлично делается, здесь же особых наворотов то нет. Попробуйте отладить запрос в консоли запросов, сразу и посмотрите чего выбираете и в каком виде, поймете как обойти эту выборку в конфигураторе...

Поделиться этой страницей