7.7 Отчёт по журналу транзакций

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем enb83, 23 июн 2008.

  1. TopicStarter Overlay
    enb83
    Offline

    enb83

    Регистрация:
    23 июн 2008
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    1С Предприятие, Штрих-М Кассир.
    Сейчас дела обстоят вот так(я не стал выводить цену стоимость и ещё некоторые поля и так понятно что это журнал транзакций):

    Код Наименование ДатаТранз ВремяТранз ТипТран. НомЧек. Секция КодТова
    165500 Продажа по коду 02.06.08 09:08:02 11 2294 1 6048990010009
    165501 Оплата 02.06.08 09:08:05 40 2294 297 0
    165503 Продажа по коду 02.06.08 09:08:44 11 2295 1 6037750009209
    165504 Продажа по коду 02.06.08 09:08:48 11 2295 1 6027110034309
    165505 Отмена чека 02.06.08 09:15:29 56 2295 0 0
    165506 Продажа по коду 02.06.08 09:15:54 11 2295 1 6037750009209
    165507 Продажа по коду 02.06.08 09:15:56 11 2295 1 6027110034309
    165508 Проц. скидка на чек 02.06.08 09:17:11 37 2295 0 0
    165509 Детализация скидки на чек 02.06.08 09:17:11 71 2295 1 300
    165510 Оплата 02.06.08 09:17:17 40 2295 297 0
    165512 Продажа по коду 02.06.08 09:20:02 11 2296 1 6041970057506
    165513 Продажа по коду 02.06.08 09:20:17 11 2296 1 6041930154504
    165514 Продажа по коду 02.06.08 09:21:24 11 2296 1 6010940011206
    165515 Проц. скидка на чек 02.06.08 09:22:08 37 2296 0 0
    165516 Детализация скидки на чек 02.06.08 09:22:08 71 2296 1 301
    165517 Оплата 02.06.08 09:22:33 40 2296 297 0
    165519 Продажа по коду 02.06.08 09:24:17 11 2297 1 6046170050609
    165520 Продажа по коду 02.06.08 09:24:19 11 2297 1 6073980048007
    165521 Оплата 02.06.08 09:24:32 40 2297 297 0
    Код:
    // Это процедура моего отчёта которая выводит на печать журнал транзакций
    Процедура Печать()
    Перем ВыводитьСтроку;
    Если НачДата>КонДата Тогда
    Предупреждение("Неверный диапазон дат!");
    Возврат;
    КонецЕсли;  
    //		Список.УдалитьВсе();
    Спр=СоздатьОбъект("Справочник.Транзакции");
    Для Пар=0 по КонДата-НачДата Цикл
    Спр.ВыбратьЭлементыПоРеквизиту("ДатаТранз",НачДата+Пар,1,0);
    КонецЦикла;
    
    Спр = СоздатьОбъект("Справочник.Транзакции");
    //	Спр.ИспользоватьДату(ИспользоватьДату());
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Печать");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    
    Если НачДата>КонДата Тогда
    Предупреждение("Неверный диапазон дат!");
    Возврат;
    КонецЕсли;  
    Для Пар=0 по КонДата-НачДата Цикл
    Спр.ВыбратьЭлементыПоРеквизиту("ДатаТранз",НачДата+Пар,1,0);
    Пока Спр.ПолучитьЭлемент()>0 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл					</span>
    Если Спр.ТипТранзакции = 55 Тогда
    Таб.ВывестиСекцию("Группа");
    Иначе
    
    Таб.ВывестиСекцию("Строка");
    
    КонецЕсли;	               			
    КонецЦикла;
    КонецЦикла;	
    
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать Транзакции","");
    КонецПроцедуры
    //}}ПРОЦЕДУРА_ПЕЧАТИ   
    
    
    ХОТЕЛОСЬ БЫ СДЕЛАТЬ ВОТ ТАК:
    Код Наименование ДатаТранз ВремяТранз ТипТран. НомЧек. Секция КодТова
    165506 Продажа по коду 02.06.08 09:15:54 11 2295 1 6037750009209
    165507 Продажа по коду 02.06.08 09:15:56 11 2295 1 6027110034309
    165508 Проц. скидка на чек 02.06.08 09:17:11 37 2295 0 0
    165509 Детализация скидки на чек 02.06.08 09:17:11 71 2295 1 300
    165510 Оплата 02.06.08 09:17:17 40 2295 297 0
    165512 Продажа по коду 02.06.08 09:20:02 11 2296 1 6041970057506
    165513 Продажа по коду 02.06.08 09:20:17 11 2296 1 6041930154504
    165514 Продажа по коду 02.06.08 09:21:24 11 2296 1 6010940011206
    165515 Проц. скидка на чек 02.06.08 09:22:08 37 2296 0 0
    165516 Детализация скидки на чек 02.06.08 09:22:08 71 2296 1 301
    165517 Оплата 02.06.08 09:22:33 40 2296 297 0

    Т.е. выводить только те чеки в операциях который присутствуют скидки.
    Ну конечно же подцепить ещё сюда журнал товаров, чтобы и КодТовара был и Наименование.

Поделиться этой страницей