7.7 отчёт о бухгалтерских проводках

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Sanches, 13 дек 2007.

  1. TopicStarter Overlay
    Sanches
    Offline

    Sanches

    Регистрация:
    13 дек 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый вечер, помогите, пожалста...
    Суть вопроса:у меня на основании Реализации выводится Поступление ТМЦ, но Поступление ТМЦ по итогу по накладной, который меньше итога по реализации, далее высчиывается процент от итога по реализации и итога по накладной,на который в дальнейшем уменьшается сумма в каждой строке табличнй части Поступления ТМЦ колонки Сумма. При проводке документа, в отчете о бухгалтерских проводках отбражается сумма от реализации, а не сумма получившаяся спомощью вышесказанных махинаций в Поступлении ТМЦ, как сделать,чтоб в отчёте была именно сумма получившаяся спомощью вышесказанных махинаций в Поступлении ТМЦ?

    Ниже приводится часть кода заполнения табличной части Поступления ТМЦ в процедуре ВводНаОсновании

    Код:
    Если ДокументОснование.Вид()="Реализация" тогда
    
    ТаблицаДокумента = СоздатьОбъект("ТаблицаЗначений");
    ДокОснование.ВыгрузитьТабличнуюЧасть(ТаблицаДокумента);
    СуммаВклНДС=1;
    // очищаем наш документ
    УдалитьСтроки();
    
    ТаблицаДокумента.ВыбратьСтроки();
    
    СуммДо=ДокОснование.Итог("Сумма");
    Процент=Окр((СуммДо-контроль)/СуммДо,4,1);
    Сообщить(Процент);
    КолСтр=ТаблицаДокумента.КоличествоСтрок();
    Сообщить(КолСтр);
    
    ном=0;
    ИтогС=0;
    Пока ТаблицаДокумента.ПолучитьСтроку()=1 Цикл
    
    ном=ном+1;
    НоваяСтрока();
    Если КолСтр=1 Тогда
    Сумма=контроль;   
    ИначеЕсли ном=КолСтр-1 Тогда
    Сумма=контроль-ИтогС;
    Иначе
    Сумма= Окр(ТаблицаДокумента.Сумма-Окр(ТаблицаДокумента.Сумма*Процент,4,1),2,1);
    ИтогС=ИтогС+Сумма;
    КонецЕсли;
    
    Номенклатура= ТаблицаДокумента.Номенклатура;
    Количество     = ТаблицаДокумента.Количество; 
    Единица     = ТаблицаДокумента.Единица;
    Коэффициент = ТаблицаДокумента.Коэффициент;
    //
    //Цена         = ТаблицаДокумента.Цена;
    Если Количество <> 0 Тогда
    Цена = Сумма / Количество;
    Иначе
    Цена = Сумма;
    КонецЕсли;
    ВидТМЦ      = Перечисление.ВидыТМЦ.Товар;
    //Если глЕстьРеквизитМнЧ("РозничнаяЦена", ДокОснование.Вид()) = 1 Тогда
    //    РозничнаяЦена    = ТаблицаДокумента.РозничнаяЦена;
    //КонецЕсли;
    
    СуммаНДС     = ТаблицаДокумента.СуммаНДС;
    СуммаНП     = ТаблицаДокумента.СуммаНП;
    СтавкаНДС     = ТаблицаДокумента.СтавкаНДС;
    СтавкаНП     = ТаблицаДокумента.СтавкаНП;
    
    СоздатьПартию();
    КонецЦикла; // по строкам основания
    
    
    СуммаВзаиморасчетов    = ДокОснование.СуммаВзаиморасчетов;
    //Контрагент="";
    //Договор="";
    //Склад="";
    
    Если КоличествоСтрок() = 0 Тогда
    //Возврат "В документе основании не заполнена табличная часть";
    Сообщить("В документе основании не заполнена табличная часть");
    КонецЕсли;
    
    Используйте тэг
    Код:
    [/color]
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Ответ отчет о бухгалтерских проводках выводи ту сумму каторая провелась смотри сам документ и его проводки. по коду есть вопросы чему равна переменная контроль если она = 0 то сумма в док = сумме в док.основание

    Если предположить что контроль - сумма на которую стоимость прихода должна быть меньше суммы продажи, то вызывает подазрение:
    Код:
       
    Если КолСтр=1 Тогда
    Сумма=контроль;   
    ИначеЕсли ном=КолСтр-1 Тогда
    Сумма=контроль-ИтогС;
    Иначе
    Сумма= Окр(ТаблицаДокумента.Сумма-Окр(ТаблицаДокумента.Сумма*Процент,4,1),2,1);
    ИтогС=ИтогС+Сумма;
    КонецЕсли;
    
    
    ДА И В КОНЦЕ

    Код:
       
    СуммаНДС     = ТаблицаДокумента.СуммаНДС;
    СуммаНП     = ТаблицаДокумента.СуммаНП;
    СтавкаНДС     = ТаблицаДокумента.СтавкаНДС;
    СтавкаНП     = ТаблицаДокумента.СтавкаНП;
    
    

    Это ж присваевание сумм из расходной накладной в приходную и 1с (смотреть код надо конечно) проводит суммы и ей по логике вещей по барабану что там твориться с ценой т .е. фактически ты заполняешь поля прихода следующим образом:
    товар 1 шт цена 2 рубля сумма 3 рубля минуя стадию умножения 1*2

    да и цена = Сумма имхо допустима только при количестве=1, а не нулю :unsure:

Поделиться этой страницей