7.7 Отчет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 23 апр 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Народ подскажите как заменить пустые значения в отчете "х".То есть если реквезит не выбран то вместо пустого значения записавался
    "Х"в отчете.
    Код:
    //*******************************************
    Перем ВыбСотрудник;
    Процедура Сформировать()
    Перем Зпр;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Секция_1");
    Зпр = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Обрабатывать Все;
    |Сп= Справочник.Сотрудники.ТекущийЭлемент;
    |Гр= Справочник.Сотрудники.ТекущийЭлемент;
    |Фм=Справочник.Сотрудники.Фирма;
    |Ад=Справочник.Сотрудники.Адрес;
    |ИНН=Справочник.Сотрудники.ИНН;
    |Группировка Гр;
    |Группировка Сп Упорядочить По Сп.Наименование без групп ;
    |Условие(Сп.ПринадлежитГруппе(Сотрудник)=1);
    |";						   
    
    
    Зпр.Выполнить(ТекстЗапроса);
    Пока Зпр.Группировка("Гр")>0 Цикл
    Если Зпр.Гр.ЭтоГруппа()=1 Тогда
    Таб.ВывестиСекцию("Секция_4");
    КонецЕсли;
    Пока Зпр.Группировка("Сп") >0 Цикл
    Таб.ВывестиСекцию("Секция_2");
    КонецЦикла;
    КонецЦикла;
    Таб.ВывестиСекцию("Секция_3");
    Таб.ТолькоПросмотр(1);										  
    Таб.Показать("Зпр");
    КонецПроцедуры
    
    Пробовал так
    Код:
    Если ПустоеЗначение("Зпр.Фм")=1Тогда
    Зпр.Фм="x"
    КонецЕсли;
  2. Vlan
    Online

    Vlan Гость Гость

    В самой таблице попробуйте сделать выражение ячейки:
    Код:
    ?(ПустоеЗначение(Зпр.Фы)=1,"Х",Зпр.Фы)
  3. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Во получилось)Спасибо большое Влан)

Поделиться этой страницей