8.х Отчет Ведомость по партиям товара на складе - Не выводит данные в отчет! ПОМОГИТЕ!

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем softwarebbs, 29 июл 2012.

  1. TopicStarter Overlay
    softwarebbs
    Offline

    softwarebbs

    Регистрация:
    29 июл 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Перешел на 8`ку.. 4 день разбираюсь....

    Задача такая: Добавить колонку Цена в отчет "Ведомость по партиям товара" - данные должны браться из РегистрСведений.ЦеныНоменклатуры.СрезПоследних.

    Написал сначала код в консоле (отчет) - данные выводятся, колонка цена есть и данные тоже...
    но вот когда перенес все в универсальныйотчет, то колонка цена есть - а вот данных там нету.
    подскажите что я не так делаю?
    уже 4 день пытаюсь создать этот отчет.

    Кто поможет, могу выслать денег на Yandex.Деньги или на Web.money.

    Константин.

    Код:
    #Если Клиент Тогда
    
    ////////////////////////////////////////////////////////////////////////////////
    // ПРОЦЕДУРЫ И ФУНКЦИИ НАЧАЛЬНОЙ НАСТРОЙКИ ОТЧЕТА[/font][/color]
    [color=#412A23][font=Verdana]// Процедура установки начальных настроек отчета с использованием текста запроса
    //
    Процедура УстановитьНачальныеНастройкиУпр(ДополнительныеПараметры = Неопределено)
    
    // Дополнительные параметры, переданные из отчета, вызвавшего расшифровку.
    // Информация, передаваемая в переменной ДополнительныеПараметры, может быть использована
    // для реализации специфичных для данного отчета параметрических настроек.
    
    // Описание исходного текста запроса.
    ТекстЗапроса =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    | ВложенныйЗапрос.Цена КАК Цена,
    | ИсточникДанных.Номенклатура КАК Номенклатура,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.Номенклатура),
    | ИсточникДанных.Склад КАК Склад,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.Склад),
    | ИсточникДанных.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.ХарактеристикаНоменклатуры),
    | ИсточникДанных.СерияНоменклатуры КАК СерияНоменклатуры,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.СерияНоменклатуры),
    | ИсточникДанных.ДокументОприходования КАК ДокументОприходования,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.ДокументОприходования),
    | ИсточникДанных.СтатусПартии КАК СтатусПартии,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.СтатусПартии),
    | ИсточникДанных.Заказ КАК Заказ,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.Заказ),
    | ИсточникДанных.Качество КАК Качество,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.Качество),
    | ИсточникДанных.КоличествоНачальныйОстаток КАК КоличествоНачальныйОстаток,
    | ИсточникДанных.КоличествоНачальныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент КАК КоличествоНачальныйОстатокВЕдиницахДляОтчетов,
    | ИсточникДанных.КоличествоНачальныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоличествоНачальныйОстатокВБазовыхЕдиницах,
    | ИсточникДанных.КоличествоПриход КАК КоличествоПриход,
    | ИсточникДанных.КоличествоПриход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент КАК КоличествоПриходВЕдиницахДляОтчетов,
    | ИсточникДанных.КоличествоПриход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоличествоПриходВБазовыхЕдиницах,
    | ИсточникДанных.КоличествоРасход КАК КоличествоРасход,
    | ИсточникДанных.КоличествоРасход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент КАК КоличествоРасходВЕдиницахДляОтчетов,
    | ИсточникДанных.КоличествоРасход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоличествоРасходВБазовыхЕдиницах,
    | ИсточникДанных.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток,
    | ИсточникДанных.КоличествоКонечныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент КАК КоличествоКонечныйОстатокВЕдиницахДляОтчетов,
    | ИсточникДанных.КоличествоКонечныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК КоличествоКонечныйОстатокВБазовыхЕдиницах,
    | ИсточникДанных.СтоимостьНачальныйОстаток КАК СтоимостьНачальныйОстаток,
    | ИсточникДанных.СтоимостьПриход КАК СтоимостьПриход,
    | ИсточникДанных.СтоимостьРасход КАК СтоимостьРасход,
    | ИсточникДанных.СтоимостьКонечныйОстаток КАК СтоимостьКонечныйОстаток,
    | ИсточникДанных.Регистратор КАК Регистратор,
    | ПРЕДСТАВЛЕНИЕ(ИсточникДанных.Регистратор),
    | ИсточникДанных.Период КАК Период,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕНЬ) КАК ПериодДень,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, НЕДЕЛЯ) КАК ПериодНеделя,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕКАДА) КАК ПериодДекада,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, МЕСЯЦ) КАК ПериодМесяц,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, КВАРТАЛ) КАК ПериодКвартал,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ПОЛУГОДИЕ) КАК ПериодПолугодие,
    | НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ГОД) КАК ПериодГод
    |{ВЫБРАТЬ
    | Номенклатура.*,
    | Склад.*,
    | ХарактеристикаНоменклатуры.*,
    | СерияНоменклатуры.*,
    | ДокументОприходования.*,
    | СтатусПартии.*,
    | Заказ.*,
    | Качество.*,
    | КоличествоНачальныйОстаток,
    | КоличествоНачальныйОстатокВЕдиницахДляОтчетов,
    | КоличествоНачальныйОстатокВБазовыхЕдиницах,
    | КоличествоПриход,
    | КоличествоПриходВЕдиницахДляОтчетов,
    | КоличествоПриходВБазовыхЕдиницах,
    | КоличествоРасход,
    | КоличествоРасходВЕдиницахДляОтчетов,
    | КоличествоРасходВБазовыхЕдиницах,
    | КоличествоКонечныйОстаток,
    | КоличествоКонечныйОстатокВЕдиницахДляОтчетов,
    | КоличествоКонечныйОстатокВБазовыхЕдиницах,
    | СтоимостьНачальныйОстаток,
    | СтоимостьПриход,
    | СтоимостьРасход,
    | СтоимостьКонечныйОстаток,
    | Регистратор.*,
    | Период,
    | ПериодДень,
    | ПериодНеделя,
    | ПериодДекада,
    | ПериодМесяц,
    | ПериодКвартал,
    | ПериодПолугодие,
    | ПериодГод,
    | Цена}
    |ИЗ
    | РегистрНакопления.ПартииТоваровНаСкладах.ОстаткиИОбороты(&ДатаНач, &ДатаКон, Регистратор {(&Периодичность)}, , {(Номенклатура).* КАК Номенклатура, (Склад).* КАК Склад, (ХарактеристикаНоменклатуры).* КАК ХарактеристикаНоменклатуры, (СерияНоменклатуры).* КАК СерияНоменклатуры, (ДокументОприходования).* КАК ДокументОприходования, (СтатусПартии).* КАК СтатусПартии, (Заказ).* КАК Заказ, (Качество).* КАК Качество}) КАК ИсточникДанных
    |  ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    |   ЦеныНоменклатурыСрезПервых.Цена КАК Цена,
    |   ЦеныНоменклатурыСрезПервых.Номенклатура КАК Номенклатура
    |  ИЗ
    |   РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, ТипЦен = &ТипЦены) КАК ЦеныНоменклатурыСрезПервых) КАК ВложенныйЗапрос
    |  ПО ИсточникДанных.Номенклатура.Ссылка = ВложенныйЗапрос.Номенклатура.Ссылка
    |{ГДЕ
    | ИсточникДанных.КоличествоНачальныйОстаток КАК КоличествоНачальныйОстаток,
    | (ИсточникДанных.КоличествоНачальныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент) КАК КоличествоНачальныйОстатокВЕдиницахДляОтчетов,
    | (ИсточникДанных.КоличествоНачальныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК КоличествоНачальныйОстатокВБазовыхЕдиницах,
    | ИсточникДанных.КоличествоПриход КАК КоличествоПриход,
    | (ИсточникДанных.КоличествоПриход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент) КАК КоличествоПриходВЕдиницахДляОтчетов,
    | (ИсточникДанных.КоличествоПриход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК КоличествоПриходВБазовыхЕдиницах,
    | ИсточникДанных.КоличествоРасход КАК КоличествоРасход,
    | (ИсточникДанных.КоличествоРасход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент) КАК КоличествоРасходВЕдиницахДляОтчетов,
    | (ИсточникДанных.КоличествоРасход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК КоличествоРасходВБазовыхЕдиницах,
    | ИсточникДанных.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток,
    | (ИсточникДанных.КоличествоКонечныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент) КАК КоличествоКонечныйОстатокВЕдиницахДляОтчетов,
    | (ИсточникДанных.КоличествоКонечныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент) КАК КоличествоКонечныйОстатокВБазовыхЕдиницах,
    | ИсточникДанных.СтоимостьНачальныйОстаток КАК СтоимостьНачальныйОстаток,
    | ИсточникДанных.СтоимостьПриход КАК СтоимостьПриход,
    | ИсточникДанных.СтоимостьРасход КАК СтоимостьРасход,
    | ИсточникДанных.СтоимостьКонечныйОстаток КАК СтоимостьКонечныйОстаток,
    | ИсточникДанных.Регистратор.* КАК Регистратор,
    | ИсточникДанных.Период КАК Период,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕНЬ)) КАК ПериодДень,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, НЕДЕЛЯ)) КАК ПериодНеделя,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ДЕКАДА)) КАК ПериодДекада,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, МЕСЯЦ)) КАК ПериодМесяц,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, КВАРТАЛ)) КАК ПериодКвартал,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ПОЛУГОДИЕ)) КАК ПериодПолугодие,
    | (НАЧАЛОПЕРИОДА(ИсточникДанных.Период, ГОД)) КАК ПериодГод,
    | ВложенныйЗапрос.Цена КАК Цена}
    |
    |СГРУППИРОВАТЬ ПО
    | ИсточникДанных.Номенклатура,
    | ИсточникДанных.Склад,
    | ИсточникДанных.ХарактеристикаНоменклатуры,
    | ИсточникДанных.СерияНоменклатуры,
    | ИсточникДанных.ДокументОприходования,
    | ИсточникДанных.СтатусПартии,
    | ИсточникДанных.Заказ,
    | ИсточникДанных.Качество,
    | ИсточникДанных.КоличествоНачальныйОстаток,
    | ИсточникДанных.КоличествоПриход,
    | ИсточникДанных.КоличествоРасход,
    | ИсточникДанных.КоличествоКонечныйОстаток,
    | ИсточникДанных.СтоимостьНачальныйОстаток,
    | ИсточникДанных.СтоимостьПриход,
    | ИсточникДанных.СтоимостьРасход,
    | ИсточникДанных.СтоимостьКонечныйОстаток,
    | ИсточникДанных.Регистратор,
    | ИсточникДанных.Период,
    | ИсточникДанных.КоличествоНачальныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент,
    | ИсточникДанных.КоличествоНачальныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент,
    | ИсточникДанных.КоличествоПриход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент,
    | ИсточникДанных.КоличествоПриход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент,
    | ИсточникДанных.КоличествоРасход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент,
    | ИсточникДанных.КоличествоРасход * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент,
    | ИсточникДанных.КоличествоКонечныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент / ИсточникДанных.Номенклатура.ЕдиницаДляОтчетов.Коэффициент,
    | ИсточникДанных.КоличествоКонечныйОстаток * ИсточникДанных.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент,
    | ВложенныйЗапрос.Цена
    |{УПОРЯДОЧИТЬ ПО
    | Номенклатура.*,
    | Склад.*,
    | ХарактеристикаНоменклатуры.*,
    | СерияНоменклатуры.*,
    | ДокументОприходования.*,
    | СтатусПартии.*,
    | Заказ.*,
    | Качество.*,
    | КоличествоНачальныйОстаток,
    | КоличествоНачальныйОстатокВЕдиницахДляОтчетов,
    | КоличествоНачальныйОстатокВБазовыхЕдиницах,
    | КоличествоПриход,
    | КоличествоПриходВЕдиницахДляОтчетов,
    | КоличествоПриходВБазовыхЕдиницах,
    | КоличествоРасход,
    | КоличествоРасходВЕдиницахДляОтчетов,
    | КоличествоРасходВБазовыхЕдиницах,
    | КоличествоКонечныйОстаток,
    | КоличествоКонечныйОстатокВЕдиницахДляОтчетов,
    | КоличествоКонечныйОстатокВБазовыхЕдиницах,
    | СтоимостьНачальныйОстаток,
    | СтоимостьПриход,
    | СтоимостьРасход,
    | СтоимостьКонечныйОстаток,
    | Регистратор.*,
    | Период,
    | ПериодДень,
    | ПериодНеделя,
    | ПериодДекада,
    | ПериодМесяц,
    | ПериодКвартал,
    | ПериодПолугодие,
    | ПериодГод}
    |ИТОГИ
    | СУММА(Цена),
    | СУММА(КоличествоНачальныйОстаток),
    | СУММА(КоличествоНачальныйОстатокВЕдиницахДляОтчетов),
    | СУММА(КоличествоНачальныйОстатокВБазовыхЕдиницах),
    | СУММА(КоличествоПриход),
    | СУММА(КоличествоПриходВЕдиницахДляОтчетов),
    | СУММА(КоличествоПриходВБазовыхЕдиницах),
    | СУММА(КоличествоРасход),
    | СУММА(КоличествоРасходВЕдиницахДляОтчетов),
    | СУММА(КоличествоРасходВБазовыхЕдиницах),
    | СУММА(КоличествоКонечныйОстаток),
    | СУММА(КоличествоКонечныйОстатокВЕдиницахДляОтчетов),
    | СУММА(КоличествоКонечныйОстатокВБазовыхЕдиницах),
    | СУММА(СтоимостьНачальныйОстаток),
    | СУММА(СтоимостьПриход),
    | СУММА(СтоимостьРасход),
    | СУММА(СтоимостьКонечныйОстаток)
    |ПО
    | ОБЩИЕ
    |{ИТОГИ ПО
    | Номенклатура.*,
    | Склад.*,
    | ХарактеристикаНоменклатуры.*,
    | СерияНоменклатуры.*,
    | ДокументОприходования.*,
    | СтатусПартии.*,
    | Заказ.*,
    | Качество.*,
    | Регистратор.*,
    | Период,
    | ПериодДень,
    | ПериодНеделя,
    | ПериодДекада,
    | ПериодМесяц,
    | ПериодКвартал,
    | ПериодПолугодие,
    | ПериодГод,
    | Цена}";
    
    
    
    
    
    // В универсальном отчете включен флаг использования свойств и категорий.
    Если УниверсальныйОтчет.ИспользоватьСвойстваИКатегории Тогда
    
    // Добавление свойств и категорий поля запроса в таблицу полей.
    // Необходимо вызывать для каждого поля запроса, предоставляющего возможность использования свойств и категорий.
    
    // УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля(<ПсевдонимТаблицы>.<Поле> , <ПсевдонимПоля>, <Представление>, <Назначение>);
    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных.Номенклатура", "Номенклатура", "Номенклатура", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура);
    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных.ХарактеристикаНоменклатуры", "ХарактеристикаНоменклатуры", "Характеристика номенклатуры", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_ХарактеристикиНоменклатуры);
    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных.Склад", "Склад", "Склад", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Склады);
    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных.ДокументОприходования", "ДокументОприходования", "Документ оприходования", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Документы);
    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных.Заказ", "Заказ", "Заказ", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Документы);
    УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля("Цена", "Цена", "Цена", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Документы);
    
    // Добавление свойств и категорий в исходный текст запроса.
    УниверсальныйОтчет.ДобавитьВТекстЗапросаСвойстваИКатегории(ТекстЗапроса);
    
    КонецЕсли;
    
    // Инициализация текста запроса построителя отчета
    УниверсальныйОтчет.ПостроительОтчета.Текст = ТекстЗапроса;
    
    // Представления полей отчета.
    // Необходимо вызывать для каждого поля запроса.
    // УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить(<ИмяПоля>, <ПредставлениеПоля>);
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ДокументОприходования", "Документ оприходования");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ХарактеристикаНоменклатуры", "Характеристика номенклатуры");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СерияНоменклатуры", "Серия номенклатуры");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СтатусПартии","Статус партии");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоНачальныйОстаток","Количество начальный остаток");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоНачальныйОстатокВЕдиницахДляОтчетов","Количество начальный остаток (в ед. отчетов)");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоНачальныйОстатокВБазовыхЕдиницах","Количество начальный остаток (в базовых ед.)");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СтоимостьНачальныйОстаток","Стоимость начальный остаток");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоПриход","Количество приход");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоПриходВЕдиницахДляОтчетов","Количество приход (в ед. отчетов)");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоПриходВБазовыхЕдиницах","Количество приход (в базовых ед.)");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СтоимостьПриход","Стоимость приход");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоРасход","Количество расход");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоРасходВЕдиницахДляОтчетов","Количество расход (в ед. отчетов)");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоРасходВБазовыхЕдиницах","Количество расход (в базовых ед.)");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СтоимостьРасход","Стоимость расход");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоКонечныйОстаток", "Количество конечный остаток");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоКонечныйОстатокВЕдиницахДляОтчетов","Количество конечный остаток (в ед. отчетов)");
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("КоличествоКонечныйОстатокВБазовыхЕдиницах","Количество конечный остаток (в базовых ед.)");
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СтоимостьКонечныйОстаток","Стоимость конечный остаток");
    
    
    УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Цена","Цена товара");
    //	УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("ТипЦенНаименование","ТипЦенНаименование");
    // Добавление показателей
    // Необходимо вызывать для каждого добавляемого показателя.
    // УниверсальныйОтчет.ДобавитьПоказатель(<ИмяПоказателя>, <ПредставлениеПоказателя>, <ВключенПоУмолчанию>, <Формат>, <ИмяГруппы>, <ПредставлениеГруппы>);
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоНачальныйОстаток","Количество", Истина, "ЧЦ=15; ЧДЦ=3", "НачальныйОстаток", "Начальный остаток");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоНачальныйОстатокВЕдиницахДляОтчетов","Количество (в ед. отчетов)", Ложь, "ЧЦ=15; ЧДЦ=3", "НачальныйОстаток", "Начальный остаток");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоНачальныйОстатокВБазовыхЕдиницах","Количество (в базовых ед.)", Ложь, "ЧЦ=15; ЧДЦ=3", "НачальныйОстаток", "Начальный остаток");
    УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьНачальныйОстаток","Стоимость", Истина, "ЧЦ=15; ЧДЦ=2", "НачальныйОстаток", "Начальный остаток");
    
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоПриход","Количество", Истина, "ЧЦ=15; ЧДЦ=3", "Приход", "Приход");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоПриходВЕдиницахДляОтчетов","Количество (в ед. отчетов)", Ложь, "ЧЦ=15; ЧДЦ=3", "Приход", "Приход");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоПриходВБазовыхЕдиницах","Количество (в базовых ед.)", Ложь, "ЧЦ=15; ЧДЦ=3", "Приход", "Приход");
    УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьПриход","Стоимость", Истина, "ЧЦ=15; ЧДЦ=2", "Приход", "Приход");
    
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоРасход","Количество", Истина, "ЧЦ=15; ЧДЦ=3", "Расход", "Расход");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоРасходВЕдиницахДляОтчетов","Количество (в ед. отчетов)", Ложь, "ЧЦ=15; ЧДЦ=3", "Расход", "Расход");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоРасходВБазовыхЕдиницах","Количество (в базовых ед.)", Ложь, "ЧЦ=15; ЧДЦ=3", "Расход", "Расход");
    УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьРасход","Стоимость", Истина, "ЧЦ=15; ЧДЦ=2", "Расход", "Расход");
    
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоКонечныйОстаток", "Количество", Истина, "ЧЦ=15; ЧДЦ=3", "КонечныйОстаток", "Конечный остаток");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоКонечныйОстатокВЕдиницахДляОтчетов","Количество (в ед. отчетов)", Ложь, "ЧЦ=15; ЧДЦ=3", "КонечныйОстаток", "Конечный остаток");
    УниверсальныйОтчет.ДобавитьПоказатель("КоличествоКонечныйОстатокВБазовыхЕдиницах","Количество (в базовых ед.)", Ложь, "ЧЦ=15; ЧДЦ=3", "КонечныйОстаток", "Конечный остаток");
    УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьКонечныйОстаток","Стоимость", Истина, "ЧЦ=15; ЧДЦ=2", "КонечныйОстаток", "Конечный остаток");
    
    УниверсальныйОтчет.ДобавитьПоказатель("Цена","Цена", Истина, "ЧЦ=15.2; ЧДЦ=2", "Цена", "Цена");[/font][/color]
    [color=#412A23][font=Verdana]//УниверсальныйОтчет.ДобавитьПоказатель("ТипЦенНаименование","ТипЦенНаименование", Истина, "ЧЦ=15; ЧДЦ=2", "ТипЦенНаименование", "ТипЦенНаименование");
    // Добавление предопределенных группировок строк отчета.
    // Необходимо вызывать для каждой добавляемой группировки строки.
    // УниверсальныйОтчет.ДобавитьИзмерениеСтроки(<ПутьКДанным>);
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("ДокументОприходования");
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Номенклатура");
    УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Цена");[/font][/color]
    [color=#412A23][font=Verdana]// Добавление предопределенных группировок колонок отчета.
    // Необходимо вызывать для каждой добавляемой группировки колонки.
    // УниверсальныйОтчет.ДобавитьИзмерениеКолонки("Цена");
    
    // Добавление предопределенных отборов отчета.
    // Необходимо вызывать для каждого добавляемого отбора.
    // УниверсальныйОтчет.ДобавитьОтбор(<ПутьКДанным>);
    УниверсальныйОтчет.ДобавитьОтбор("Склад");
    УниверсальныйОтчет.ДобавитьОтбор("Номенклатура");
    УниверсальныйОтчет.ДобавитьОтбор("ДокументОприходования");
    УниверсальныйОтчет.ДобавитьОтбор("Цена");
    
    // Добавление предопределенных полей порядка отчета.
    // Необходимо вызывать для каждого добавляемого поля порядка.
    УниверсальныйОтчет.ДобавитьПорядок("Цена");
    
    // Установка связи подчиненных и родительских полей
    // УниверсальныйОтчет.УстановитьСвязьПолей(<ПутьКДанным>, <ПутьКДанным>);
    //  УниверсальныйОтчет.УстановитьСвязьПолей("Цена","Цена");
    
    // Установка связи полей и измерений
    //  УниверсальныйОтчет.УстановитьСвязьПоляИИзмерения("Цена","Цена");
    
    // Установка представлений полей
    УниверсальныйОтчет.УстановитьПредставленияПолей(УниверсальныйОтчет.мСтруктураПредставлениеПолей, УниверсальныйОтчет.ПостроительОтчета);
    
    // Установка типов значений свойств в отборах отчета
    УниверсальныйОтчет.УстановитьТипыЗначенийСвойствДляОтбора();
    
    // Заполнение начальных настроек универсального отчета
    УниверсальныйОтчет.УстановитьНачальныеНастройки(Ложь);
    
    // Добавление дополнительных полей
    // Необходимо вызывать для каждого добавляемого дополнительного поля.
    // УниверсальныйОтчет.ДобавитьДополнительноеПоле(<ПутьКДанным>);
    УниверсальныйОтчет.ДобавитьДополнительноеПоле("Цена"); [/font][/color]
    
    [color=#412A23][font=Verdana]КонецПроцедуры // УстановитьНачальныеНастройкиУпр()[/font][/color]
    [color=#412A23][font=Verdana]// Процедура установки начальных настроек отчета с использованием текста запроса
    //
    Процедура УстановитьНачальныеНастройки(ДополнительныеПараметры = Неопределено) Экспорт
    
    // Настройка общих параметров универсального отчета
    УправлениеОтчетами.ВосстановитьРеквизитыОтчета(ЭтотОбъект, ДополнительныеПараметры);
    
    // Содержит название отчета, которое будет выводиться в шапке.
    // Тип: Строка.
    // Пример:
    // УниверсальныйОтчет.мНазваниеОтчета = "Название отчета";
    УниверсальныйОтчет.мНазваниеОтчета = СокрЛП(ЭтотОбъект.Метаданные().Синоним);
    
    // Содержит признак необходимости отображения надписи и поля выбора раздела учета в форме настройки.
    // Тип: Булево.
    // Значение по умолчанию: Истина.
    // Пример:
    // УниверсальныйОтчет.мВыбиратьИмяРегистра = Ложь;
    УниверсальныйОтчет.мВыбиратьИмяРегистра = Ложь;
    
    // Содержит имя регистра, по метаданным которого будет выполняться заполнение настроек отчета.
    // Тип: Строка.
    // Пример:
    УниверсальныйОтчет.ИмяРегистра = "";
    
    // Содержит значение используемого режима ввода периода.
    // Тип: Число.
    // Возможные значения: 0 - произвольный период, 1 - на дату, 2 - неделя, 3 - декада, 4 - месяц, 5 - квартал, 6 - полугодие, 7 - год
    // Значение по умолчанию: 0
    // Пример:
    // УниверсальныйОтчет.мРежимВводаПериода = 0;
    
    // Содержит признак необходимости вывода отрицательных значений показателей красным цветом.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ОтрицательноеКрасным = Истина;
    УниверсальныйОтчет.ОтрицательноеКрасным = Истина;
    
    // Содержит признак необходимости вывода в отчет общих итогов.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ВыводитьОбщиеИтоги = Ложь;
    
    // Содержит признак необходимости вывода детальных записей в отчет.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ВыводитьДетальныеЗаписи = Истина;
    
    // Содержит признак необходимости отображения флага использования свойств и категорий в форме настройки.
    // Тип: Булево.
    // Значение по умолчанию: Истина.
    // Пример:
    // УниверсальныйОтчет.мВыбиратьИспользованиеСвойств = Ложь;
    
    // Содержит признак использования свойств и категорий при заполнении настроек отчета.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.ИспользоватьСвойстваИКатегории = Истина;
    //УниверсальныйОтчет.ИспользоватьСвойстваИКатегории = Истина;
    
    // Содержит признак использования простой формы настроек отчета без группировок колонок.
    // Тип: Булево.
    // Значение по умолчанию: Ложь.
    // Пример:
    // УниверсальныйОтчет.мРежимФормыНастройкиБезГруппировокКолонок = Истина;
    УниверсальныйОтчет.мРежимФормыНастройкиБезГруппировокКолонок = Истина;
    
    УстановитьНачальныеНастройкиУпр(ДополнительныеПараметры);
    КонецПроцедуры // УстановитьНачальныеНастройки()[/font][/color]
    [color=#412A23][font=Verdana]////////////////////////////////////////////////////////////////////////////////
    // ПРОЦЕДУРЫ И ФУНКЦИИ ФОРМИРОВАНИЯ ОТЧЕТА
    
    // Процедура формирования отчета
    //
    Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
    
    // Перед формирование отчета можно установить необходимые параметры универсального отчета.
    
    УниверсальныйОтчет.ПостроительОтчета.Параметры.Очистить();
    УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("ТипЦены","Закупочная");[/font][/color]
    [color=#412A23][font=Verdana]	   Сообщить(ТекущаяДата()-200);
    УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент);[/font][/color]
    [color=#412A23][font=Verdana]КонецПроцедуры // СформироватьОтчет()[/font][/color]
    [color=#412A23][font=Verdana]////////////////////////////////////////////////////////////////////////////////
    // ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ[/font][/color]
    [color=#412A23][font=Verdana]// Процедура обработки расшифровки
    //
    Процедура ОбработкаРасшифровки(Расшифровка, Объект) Экспорт
    
    // Дополнительные параметры в расшифровывающий отчет можно передать
    // посредством инициализации переменной "ДополнительныеПараметры".
    
    ДополнительныеПараметры = УправлениеОтчетами.СохранитьРеквизитыОтчета(ЭтотОбъект);
    УниверсальныйОтчет.ОбработкаРасшифровкиУниверсальногоОтчета(Расшифровка, Объект, ДополнительныеПараметры);
    
    КонецПроцедуры // ОбработкаРасшифровки()[/font][/color]
    [color=#412A23][font=Verdana]// Формирует структуру для сохранения настроек отчета
    //
    Процедура СформироватьСтруктуруДляСохраненияНастроек(СтруктураСНастройками) Экспорт
    
    УниверсальныйОтчет.СформироватьСтруктуруДляСохраненияНастроек(СтруктураСНастройками);
    УправлениеОтчетами.СохранитьРеквизитыОтчета(ЭтотОбъект, СтруктураСНастройками);
    
    КонецПроцедуры // СформироватьСтруктуруДляСохраненияНастроек()[/font][/color]
    [color=#412A23][font=Verdana]// Заполняет настройки отчета из структуры сохраненных настроек
    //
    Функция ВосстановитьНастройкиИзСтруктуры(СтруктураСНастройками) Экспорт
    
    УправлениеОтчетами.ВосстановитьРеквизитыОтчета(ЭтотОбъект, СтруктураСНастройками);
    Возврат УниверсальныйОтчет.ВосстановитьНастройкиИзСтруктуры(СтруктураСНастройками, ЭтотОбъект);
    
    КонецФункции // ВосстановитьНастройкиИзСтруктуры()[/font][/color]
    [color=#412A23][font=Verdana]// Содержит значение используемого режима ввода периода.
    // Тип: Число.
    // Возможные значения: 0 - произвольный период, 1 - на дату, 2 - неделя, 3 - декада, 4 - месяц, 5 - квартал, 6 - полугодие, 7 - год
    // Значение по умолчанию: 0
    // Пример:
    // УниверсальныйОтчет.мРежимВводаПериода = 1;[/font][/color]
    [color=#412A23][font=Verdana]#КонецЕсли[/font][/color]
    [color=#412A23][font=Verdana]
  2. TopicStarter Overlay
    softwarebbs
    Offline

    softwarebbs

    Регистрация:
    29 июл 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Ребята с другого форума помогли.
    Нужно было изменить одну строчку.
    УниверсальныйОтчет.ПостроительОтчета.Параметры.Вставить("ТипЦены",Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Закупочная"));

    Тема закрыта.

Поделиться этой страницей