8.х WEB Отчет веб-клиент

Тема в разделе ""1C:Web-Сервер"", создана пользователем Tesse, 29 сен 2010.

  1. TopicStarter Overlay
    Tesse
    Offline

    Tesse

    Регистрация:
    22 сен 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    Платформа: 8.2.12.80. Есть отчет, не СКД, в тонком клиенте работает отлично, но на веб-клиенте нет. Конкретно: в отчет выводится табличка и диаграмма. По клику на какую-либо ячейку таблички, должна перестраиваться диаграмма. Делаю так:

    Код:
    &НаКлиенте
    Процедура ТабличныйДокументПриАктивизацииОбласти(Элемент)
    Строка = Элемент.ТекущаяОбласть.Расшифровка;
    Данные = Непоределено;
    Если Строка = "Что-то" Тогда 
    Данные = 1;
    ИначеЕсли Строка = "Что-то другое" Тогда
    Данные = 2;
    КонецЕсли;
    Если Данные <> Неопределено Тогда
    Диаграмма = ТабличныйДокумент.Области.МояДиаграмма.Объект;
    ТутОчищаемДиаграмму(Диаграмма);
    ТутЗаполняемДиаграммуДанными(Диаграмма, Данные);
    Диаграмма.Обновление = Истина;
    КонецЕсли;
    КонецПроцедуры
    
    и не работает, т.е. диаграмма не перестраивается. В чем может быть проблема?
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Категорически не рекомендуется использовать серверные вызовы в событиях ПриАктивизации.

    Это официальная позиция 1С
  3. TopicStarter Overlay
    Tesse
    Offline

    Tesse

    Регистрация:
    22 сен 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    А никаких обращений к серверу нет, все выполняется на клиенте.
  4. Stark_ch
    Offline

    Stark_ch

    Регистрация:
    15 мар 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    1С 8.2.12.96.
    У меня тоже проблемы с диаграммой в ВЕБ-клиенте.
    В тонком клиенте все нормально отрабатывает, а в веб-клиенте - не хочет.
    Проблема 1.
    Вывожу данные в диаграмму, а она не показывает заголовки строк и интервалы. В настройках диаграммы меняю масштаб в авто или все данные - диаграмма отображается правильно.
    Пробовал программно задавать Диаграмма.ПоддержкаМасштаба = ПоддержкаМасштабаДиаграммыГанта.Авто - не помогает.

    В настройках диаграммы (в режиме предприятие) в контекстном меню Настройки отсутствуют настройки шкал времени. В тонком клиенте они присутствуют - это у всех так?

    Проблема 2.
    В событии ПриОкончанииРедактированияИнтервала(Элемент, Интервал, ОтменаРедактирования)
    В параметре Интервал теряется свойство Расшифровка. Свойство задается при построении диаграммы (как текст). В тонком клиенте это свойство присутствует (не теряется), а в веб-клиенте оно равно Неопределено.

    Это свойство использую для связи ТЧ с Диаграммой.

    Или подскажите, как правильно передавать обратно в ТЧ данные (Интервал.начало) при изменении интервала диаграммы Ганта?

Поделиться этой страницей