7.7 Отчет Сортировка на печать с документа помогите)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 25 мар 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Месяц Программирую на 1с помогите!Мне нужно Вывести на печать документов по полю со списком фирм.Чтобы когда пользователь выбирал фирму отчет формировался только по фирме.помогите Если кто знает то 2 дня бьюсь((((((((
    Код:
    Перем Док;
    Перем Таб;
    //*******************************************
    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Секция_1");
    Док = СоздатьОбъект("Документ");
    Спр=СоздатьОбъект("Справочник.Фирмы");
    Если Фирма.Выбран()=1 Тогда//Фирма индетификатор поля со списком фирм
    КонецЕсли;
    Док.ВыбратьДокументы(НачДата,КонДата);
    Номер=0;
    Пока Док.ПолучитьДокумент()>0 Цикл							 
    Номер = Номер + 1;						   
    Таб.ВывестиСекцию("Секция_2");					 
    КонецЦикла;								 
    Таб.ВывестиСекцию("Секция_3");
    Таб.ТолькоПросмотр(1);										  
    Таб.Показать("Документ");
    КонецПроцедуры
    //*******************************************
    Процедура ПоВсемФирмам()
    Если Все = 1 Тогда
    Фирма = 0;
    Форма.Фирма.Доступность(0);						   
    НачДата=0;
    КонДата=0;								 
    Иначе
    Форма.Фирма.Доступность(1);
    КонецЕсли;
    КонецПроцедуры
    //-----------------------------------------
    Процедура ПриОткрытии()								
    НачДата=НачМесяца(РабочаяДата());						   
    КонДата=КонМесяца(РабочаяДата());
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Озвучте конфигурацию. В вашем коде вообще нет фильтра по фирме.
  3. Vlan
    Offline

    Vlan Гость Гость

    В Бухгалтерии 7.7 есть встроенная обработка, которая называется Обработка документов. Посмотрите, как она сделана. А может проще скопировать ее и подогнать под свою конфигурацию (если не Бухгалтерия)?
    Особое внимание обратите на эти строчки:
    Код:
     Док = СоздатьОбъект("Документ");
    Если ВыбрКонтрагент.Выбран() = 1 Тогда
    Док.ВыбратьПоЗначению(Дата1,Дата2,"Контрагент",ВыбрКонтрагент);
    Иначе
    Док.ВыбратьДокументы(Дата1,Дата2);
    КонецЕсли;
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Да практически в каждой есть подобная обработка для формирования реестра документов.
  5. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    7.7 Предприятие.Мне просто нужно чтобы при выборе фирмы на печать сортировались только те документы которые принадлежат этой фирме)
  6. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    и отсортитровать в таблице пытаюсь по Секции по столбцу Док.Фирма
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Самописка что-ли? Просто не зная структуру метаданных невозможно ответить на ваш вопрос.
  8. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерский учет 1с предприятие Стандартная вроде)
  9. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Проосто я наверно не понимаю чего то)
    мне надо все документы отсортировать в отчете по выбранной фирме....Секция_2 выводит у меня список документов,В Секции_2 есть ссылка док.Фирмы на реквизит документа и мне по ней нужно отсортировать)запутался я уже капец)
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А смысл? В бухгалтерии всего одна фирма. Или вы имеете в виду контрагента?
  11. Vlan
    Offline

    Vlan Гость Гость

    Замените вот этот кусок:
    Код:
    Если Фирма.Выбран()=1 Тогда//Фирма индетификатор поля со списком фирм
    КонецЕсли;
    Док.ВыбратьДокументы(НачДата,КонДата);
    на приведенный мной выше:

    Код:
    Если Фирма.Выбран() = 1 Тогда
    Док.ВыбратьПоЗначению(Дата1,Дата2,"Контрагент",Фирма);
    Иначе
    Док.ВыбратьДокументы(Дата1,Дата2);
    КонецЕсли;
    и будет вам счастье отбор по фирме.
  12. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Секция_1");
    Док = СоздатьОбъект("Документ");
    Спр=СоздатьОбъект("Справочник.Фирмы");
    Если Фирма.Выбран() = 1 Тогда
    Док.ВыбратьПоЗначению(НачДата,КонДата,"Контрагент",Фирма);
    Иначе
    Док.ВыбратьДокументы(НачДата,КонДата);
    КонецЕсли;
    Номер=0;
    Пока Док.ПолучитьДокумент()>0 Цикл							 
    Номер = Номер + 1;						   
    Таб.ВывестиСекцию("Секция_2");					 
    КонецЦикла;								 
    Таб.ВывестиСекцию("Секция_3");
    Таб.ТолькоПросмотр(1);										  
    Таб.Показать("Документ");
    КонецПроцедуры
    
    Секция_2 Номер Док.ДатаДок Док.НомерДок Док.Контрагент Док.Фирма-по этому отсортировать нужно)
    Заменил пишет:
    Док.ВыбратьПоЗначению(НачДата,КонДата,"Контрагент",Фирма);
    {Отчет.ПечатьДокументов.Форма.Модуль(11)}: Неверное имя реквизита!
    подставлял фирма.,Док.Фирма всеравно то же пишет( Никак понять не могу(
  13. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Секция_2 Номер Док.ДатаДок Док.НомерДок Док.Контрагент Док.Фирма-по этому отсортировать нужно)
    Секция_2 -из Табличной части строка
  14. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Именно по справочнику фирм нужно)Задание дали)
  15. Vlan
    Offline

    Vlan Гость Гость

    А если так?
    Код:
    Док.ВыбратьПоЗначению(НачДата,КонДата,"Фирма",Фирма);
  16. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Код:
    Док.ВыбратьПоЗначению(НачДата,КонДата,"Фирма",Фирма);
    {Отчет.ПечатьДокументов.Форма.Модуль(11)}: Неверное имя реквизита!
    Тоже я уже так пробовал)
  17. Vlan
    Offline

    Vlan Гость Гость

    А "Фирма" - это реквизит шапки или табличной части? Конфигурация явно самописка - в типовой нет никакого справочника Фирмы - поэтому остается только гадать, как у вас все устроено.
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    О чем я и говорил выше. змейкин, выложите МДшник
  19. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    не могу выложить( на сайте ограничение с загрузкой((((((
  20. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Ошибка Вы не можете загружать файлы подобного типа

Поделиться этой страницей