7.7 Отчет Себестоимости

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Anton_nikitin, 12 сен 2008.

  1. TopicStarter Overlay
    Anton_nikitin
    Offline

    Anton_nikitin

    Регистрация:
    12 сен 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Номенклатура = Справочник.Номенклатура.ТекущийЭлемент;
    |Себестоимость = Справочник.Номенклатура.Себестоимость;	
    |Группировка Номенклатура;
    |Группировка Месяц;
    |Группировка Себестоимость;
    |Условие(Номенклатура в ВыбНоменклатура);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    Пер=СоздатьОбъект("Периодический");
    Ном=СоздатьОбъект("Справочник.Номенклатура");
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);	
    Пока Запрос.Группировка(1) = 1 Цикл
    Если Запрос.Номенклатура.этоГруппа() = 1 Тогда
    Таб.ВывестиСекцию("НоменклатураРод");
    продолжить;
    конецЕсли;
    Ном.НайтиЭлемент(Запрос.Номенклатура);
    Таб.ВывестиСекцию("Номенклатура");
    Пока Запрос.Группировка(2) = 1 Цикл
    Месяц=СокрЛП(Запрос.Месяц);
    сообщить(Месяц); 
    ВырезкаГода=Прав(Месяц,2);
    Результат=СтрЗаменить(Месяц,ВырезкаГода," ");
    Если Строка(СокрЛП(Результат))="Январь" Тогда
    ТекМесяц = "01Январь";
    ИначеЕсли Строка(СокрЛП(Результат))="Февраль" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "02Февраль"; 
    ИначеЕсли Строка(СокрЛП(Результат))="Март" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "03Март"; 
    ИначеЕсли Строка(СокрЛП(Результат))="Апрель" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "04Февраль"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Май" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "05Май"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Июнь" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "06Июнь"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Июль" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "07Июль"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Август" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "08Август";
    ИначеЕсли Строка(СокрЛП(Результат))="Сентябрь" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "09Сентябрь"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Октябрь" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "10Октябрь"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Ноябрь" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "11Ноябрь"; 	  
    ИначеЕсли Строка(СокрЛП(Результат))="Декабрь" <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    ТекМесяц = "12Декбрь";	    
    КонецЕсли;	   		
    Таб.ВывестиСекцию("Месяц");
    Пока Запрос.Группировка(3) = 1 Цикл
    пер.ИспользоватьОбъект("Себестоимость", Запрос.Номенклатура);
    сообщить(пер.ЗначениеНаДату(Месяц));
    Таб.ВывестиСекцию("Себестоимость");
    КонецЦикла;
    КонецЦикла; 
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
    Хочется,чтоб себестоимость выводилась по месяцам,конф-я БУП!
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    вот что я могу сказать по этому поводу... вывод по месяцам - это не тривиальная вещь... тут ее не объяснишь... бери какой-нибудь пример и смотри... например этот: http://www.infostart.ru/profile/18916/projects/2095/
    но судя по твоим
    Код:
    ИначеЕсли Строка(СокрЛП(Результат))="Февраль" Тогда
    
    
    результата тебе будет добиться не просто...

Поделиться этой страницей