7.7 Отчет "Расход запчастей"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем pofigist, 28 сен 2009.

  1. TopicStarter Overlay
    pofigist
    Offline

    pofigist

    Регистрация:
    13 авг 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Люди помогите сделать отчет. Выборка данных происходит из документов "Приход ТМЦ", а мне нужно что бы из документов "ВнутреннееПеремещениеТМЦ" не пойму в чем касяк. Вот собственно программный код:




    Код:
    //////////////////////////////////////////////////////////////////////////////////
    
    Процедура Сформировать_Колонки(Ит, Таб, Стр)
    Таб.ВывестиСекцию(Стр+"|Начало");
    Ит.ВыбратьСчета(1);
    Пока Ит.ПолучитьСчет() = 1 Цикл
    Таб.ПрисоединитьСекцию(Стр+"|Счет");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Итог");
    КонецПроцедуры
    
    Процедура Сформировать() 
    
    
    
    ИтогРасход=0;
    Итогпрчас=0;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит1=СоздатьОбъект("БухгалтерскиеИтоги");
    Ит1.периодД(ВыбНачПериода,ВыбКонПериода);
    Ит.ИспользоватьСубконто(ВидыСубконто.Водители, ВыбСубконто1, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.Машина, ВыбСубконто2, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.Материалы, ВыбСубконто4, 1); 
    
    Ит.Включатьсубсчета(1,-1);
    
    Если Счет.Выбран()=0 Тогда
    КСЧ="20;25;26;86;91;08"
    иначе
    КСЧ=СЧЕТ;
    КонецЕсли; 
    
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, Счет,,, 1,, 5);  
    Таб.ВывестиСекцию("Заголовок");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);  
    
    
    Ит.ВыбратьСубконто(ВидыСубконто.Водители);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Водители) = 1 Цикл       
    
    Ит.ВыбратьСубконто(ВидыСубконто.Машина);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Машина) = 1 Цикл  
    
    
    Ит.ВыбратьСубконто(ВидыСубконто.Материалы);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл   
    
    Если (Ит.ДО(3)>0)или(Ит.ДО()>0) Тогда           
    Таб.ВывестиСекцию("Субконто1");	
    ИтогРасход=ИтогРасход+Ит.ДО(3); 	
    КонецЕсли;  
    
    КонецЦикла;
    
    КонецЦикла;	
    
    КонецЦикла; 
    
    Таб.ПараметрыСтраницы(2);
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Расход ГСМ","");
    КонецПроцедуры
    
    
    
    Процедура ПриОткрытии()
    
    ВыбНачПериода = НачалоПериодаБИ();
    ВыбКонПериода = КонецПериодаБИ();
    
    КонецПроцедуры
    
    ////////////////////////////////////////////////////////////////////////////////////
    


    Просто в документах "Приход ТМЦ" запчасть привязанна к МОЛ, а в документах "ВнутреннееПеремещениеТМЦ" она привязана на какой автомобиль эту запчасть поставили. Тоесть мне нужен отчет по определеному автомобилю, какие на него запчасти и в каком количестве ставили за определенный период. А данные беруться не от туда откуда мне надо. Не пойму в чем дело. :unsure: :smile: :aua:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Может в данном случае имеет смысл обратиться непосредственно к документам перемещения, а не к бухгалтерским итогам?
  3. TopicStarter Overlay
    pofigist
    Offline

    pofigist

    Регистрация:
    13 авг 2009
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Каким образом это сделать?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Через обыкновенный запрос.
    Вот пример выборки количества товара за период из расходной накладной
    Код:
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Товар = Документ.РасходнаяНакладная.Товар;
    |Количество = Документ.РасходнаяНакладная.Количество;
    |Функция КоличествоСумма = Сумма(Количество);
    |Группировка Товар;
    |"//}}ЗАПРОС
    ;
    
    
    

Поделиться этой страницей