7.7 Отчет по закупкам

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем pharaone, 24 май 2007.

  1. TopicStarter Overlay
    pharaone
    Offline

    pharaone

    Регистрация:
    24 май 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Всем привет. Вроде все нормально, только почему-то группировки не работают. Запрос.Группировка(1) выдает 0 и Запрос.Группировка(2) выдает 0. Не понятно почему?


    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Фирма = Регистр.ПартииНаличие.Фирма;
    |ТекущийДокумент = Регистр.ПартииНаличие.ТекущийДокумент;
    |Номенклатура = Регистр.ПартииНаличие.Номенклатура;
    //|Единица = Регистр.ПартииНаличие.Номенклатура.ОсновнаяЕдиница;

    // |Единица = Регистр.ПартииНаличие.ТекущийДокумент.Единица;

    |Количество = Регистр.ПартииНаличие.Количество;
    |СуммаРуб = Регистр.ПартииНаличие.СуммаРуб;
    |КодОперации = Регистр.ПартииНаличие.КодОперации;
    |Поставщик = Регистр.ПартииНаличие.Партия.Поставщик;
    |Функция КоличествоПриход = Приход(Количество) когда(КодОперации = глКО.Закупка);
    |Функция СуммаРубПриход = Приход(СуммаРуб) когда(КодОперации = глКО.Закупка);
    |Функция КоличествоРасход = Расход(Количество) когда(КодОперации = глКО.ВозвратПоставщику);
    |Функция СуммаРубРасход = Расход(СуммаРуб) когда(КодОперации = глКО.ВозвратПоставщику);
    |Группировка Поставщик без групп;
    |Группировка ТекущийДокумент;
    //|Группировка Номенклатура без групп;

    |Условие(Фирма в ВыбФирма);
    |Условие(Поставщик = ВыбПоставщик);
    |"//}}ЗАПРОС

    ;
    // Авто = ВыбАвтомашина

    // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    ВесИтог = 0;
    СуммаИтог = 0;
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Поставщик

    ВесПост = 0;
    СуммаПост = 0;
    //Таб.ВывестиСекцию("Поставщик");

    Поставщик = Запрос.Поставщик;
    Пока Запрос.Группировка(2) = 1 Цикл
    //Пока Запрос.Группировка(3) = 1 Цикл

    Вес = Окр(Запрос.ТекущийДокумент.Единица.Вес*Запрос.КоличествоПриход - Запрос.ТекущийДокумент.Единица.Вес*Запрос.КоличествоРасход,3);
    ВесПост = ВесПост + Вес;
    //КонецЦикла;

    КонецЦикла;
    СуммаПост = Запрос.СуммаРубПриход - Запрос.СуммаРубРасход;
    ВесИтог = ВесИтог + ВесПост;
    Таб.ВывестиСекцию("Поставщик");
    КонецЦикла;
    // Заполнение полей "Итого"

    // ВесИтог = ВесИтог

    СуммаИтог = Запрос.СуммаРубПриход - Запрос.СуммаРубРасход;
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Попробуй вместо
    |Условие(Поставщик в ВыбПоставщик);

    А вообще сложно сказать, не видя самой ИБ. Может регистры пустые, может ТА в прошлом...

Поделиться этой страницей